The forum

DxVk support?

Can PoL enable "DxVk" so DirectX games use Vulkan?

Author Replies
Mugsy Sunday 23 September 2018 at 21:57
MugsyAnonymous

I want to run some old DirectX-11 games using Vulkan via DxVk.

I can install/run/play them just fine from PoL (and directly from HDD), but without any DX features. I have Vulkan installed and am using the latest 3.16 distro of Wine which supposedly supports Vulkan. But there's doesn't appear to be any setting under PoL to enable it.

Is this possible with the current version? If not, will there be an update to support it? Thx.

plata Monday 24 September 2018 at 18:30
plata
Developer

We have dxvk for Phoenicis (PoL5): https://github.com/PhoenicisOrg/scripts/tree/master/Engines/Wine/Verbs/DXVK

 

If you want to try it and need support, just open an issue on GitHub.

Mugsy Monday 24 September 2018 at 19:42
MugsyAnonymous

Thanks for the reply.

I'm a bit of a Linux neophyte so I'm not sure what to do with a ".json" file. I also see the files say they will "upgrade" you to v0.53 of DxVK. I have the 0.72 files and I believe the latest version is now 0.80.

Are these ".json" files out of date?

All help is appreciated. Thx.

plata Monday 24 September 2018 at 20:00
plata
Developer

It's a so called Verb which can be used in the installation script. Check the README in the repository to get an idea about how you can write a script. Don't be afraid, it's really easy once you get it. As I said before, it's best to open an issue on GitHub if you run into problems - especially because you can get assistance by the guy who developed the dxvk support.

Mugsy Monday 24 September 2018 at 20:41
MugsyAnonymous

"Writing" a json script isn't anything I'm worried about. I just don't know how to RUN one. :)

"chmod +x"?

Thx.

plata Monday 24 September 2018 at 21:10
plata
Developer

No no. You checkout the scripts repository, add your script and then you can start it directly from within Phoenicis.

Mugsy Monday 24 September 2018 at 23:24
MugsyAnonymous

Okay, remember I'm pretty low-level on manhandling Linux.

I'm not sure how I would "checkout the scripts repository" or what exactly that even means.

And I'm not sure how I would start something "from within Phoenicis" since I'm not even aware I even have "Phoenicis" installed. Is it an app from the Ubu App Store? Do I d/l & install it directly? :(

Thx.

Edited by Mugsy

plata Tuesday 25 September 2018 at 17:34
plata
Developer

Phoenicis (aka PlayOnLinux 5) is the designated successor of PlayOnLinux 4. See also this news: https://www.playonlinux.com/en/comments-1354.html

 

You can either use the binaries linked in the news or download and build it yourself (https://github.com/PhoenicisOrg/phoenicis). To checkout the scripts repository, do: "git clone https://github.com/PhoenicisOrg/scripts.git". Once you got that, you can add the repository from Phoenicis → Settings.

Mugsy Wednesday 26 September 2018 at 22:21
MugsyAnonymous

Sorry for the late reply but I don't get on Linux often. frown

I installed PoL-5 and downloaded the Repository from the Terminal, but after that, I don't see how to add it from PoL Settings. I have three tabs: "Internet", "Plugins" and "File Associations" and none of them mention adding a Repository ("Plugins" has an add button but wants a ".pol" file.)

Thx.

Edited by Mugsy

plata Thursday 27 September 2018 at 18:42
plata
Developer

You have to add the repository to PoL 5. Looks like you're trying to add it to PoL 4. That's not gonna work.

Mugsy Thursday 27 September 2018 at 21:50
MugsyAnonymous

When I try to launch "Phoenicis", I simply get a busy icon for a few seconds then nothing.

"Info" says it's a CLI. What would I launch from the Terminal and how?

Edited by Mugsy

plata Thursday 27 September 2018 at 21:53
plata
Developer

Please run from the terminal to get some output and open an issue on GitHub. Usually you run phoenicis.sh. If you installed the deb, run the JavaFX version (not CLI).

Edited by plata

DrM1173 Thursday 10 January 2019 at 15:38
DrM1173Anonymous

Does dxvk also support DirectX9? Older games usually require DirectX9.

Mugsy Thursday 10 January 2019 at 21:15
MugsyAnonymous

No. DX11 only. Sorry.

booman Thursday 10 January 2019 at 22:29
booman

I have been running DXVK with a manual installation in PlayOnLinux 4

Works great!

I just manually add the libraries in Wine Configuration (Library Tab) & Set them all as "windows (Native)"

  • d3d10
  • d3d10_1
  • d3d10core
  • d3d11
  • dxgi

Then I use a Staging version of Wine and copy/paste the DLLs to the games executable directory.

We have a small guide on how to prepare your system for DXVK here:  GamersOnLinux


† Booman †
Mint 18.3 64-bit | Nvidia 396.54 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
You are here: Index > PlayOnLinux > DxVk support?