The forum

Itunes 12 : black coverage and cannot start

Author Replies
yupangestu Saturday 27 April 2019 at 11:42
yupangestuAnonymous

I have tried to install itunes on this platform, i had installed it using the 64bit installer with manual installation but when i finished the install, it got like this state

here is the error log

[04/27/19 16:41:18] - Running wine- iTunes.exe (Working directory : /home/yuko/.PlayOnLinux/wineprefix/default/drive_c/Program Files/iTunes)
RegisterBuiltInVisualizers**********************
GetEnvironmentVariable num characters = 16

ConnectNamedPipe [ERROR_PIPE_CONNECTED]
ConnectNamedPipe SetEvent returned true

 

is there anything i can do to fix this?

NinjaLynn Monday 6 May 2019 at 22:42
NinjaLynnAnonymous

My husband and I switched from Windows 10 to Linux within the past week and a half. We are having this exact same issue with 32 and 64 bit installation versions. I've been googling my head off trying to find anything close to this and yupangestu's post is literally the only thing I've found. 

Definitely need a solution for this! 

 

Dadu042 Monday 6 May 2019 at 23:10
Dadu042
Moderator

I also had the issue with iTunes 12.

I recommend to look (and contribute) to Wine test reports of iTunes. Perhaps someone will find a trick.

 

I suggest to have a look to this alternative software : Rhythmbox (Wikipedia page).

Edited by Dadu042

NinjaLynn Monday 13 May 2019 at 2:00
NinjaLynnAnonymous

Rhythmbox seems to be good but I dont see any options to play purchased movies/music from iTunes in it. I might be missing something and will look into it more. 

 

I did find this (bug report) on WineHQ: https://bugs.winehq.org/show_bug.cgi?id=47165

Edited by Dadu042

Mette619 Monday 27 May 2019 at 7:54
Mette619Anonymous

I have still problem, I have black sreen. I can hear notfication and sounds even Siri but nothing is helping to turn on my Ipad.
No Idea what to do!!! I have done everything !!

 

 


ttrockstars

Edited by Mette619

Dadu042 Monday 27 May 2019 at 12:16
Dadu042
Moderator

Read : https://discussions.apple.com/thread/7108667

And please give reports.

gueneal Friday 23 August 2019 at 15:57
guenealAnonymous

I had to download itunes for older videocards. This fixed it for me... but of course this is version 12.4 not 12.9.

Link is here https://support.apple.com/kb/DL1614?viewlocale=en_US&locale=en_US