Itunes 12 : black coverage and cannot start

Auteur Réponses
yupangestu Samedi 27 Avril 2019 à 11:42

I have tried to install itunes on this platform, i had installed it using the 64bit installer with manual installation but when i finished the install, it got like this state

here is the error log

[04/27/19 16:41:18] - Running wine- iTunes.exe (Working directory : /home/yuko/.PlayOnLinux/wineprefix/default/drive_c/Program Files/iTunes)
GetEnvironmentVariable num characters = 16

ConnectNamedPipe SetEvent returned true


is there anything i can do to fix this?

NinjaLynn Lundi 6 Mai 2019 à 22:42

My husband and I switched from Windows 10 to Linux within the past week and a half. We are having this exact same issue with 32 and 64 bit installation versions. I've been googling my head off trying to find anything close to this and yupangestu's post is literally the only thing I've found. 

Definitely need a solution for this! 


Dadu042 Lundi 6 Mai 2019 à 23:10

I also had the issue with iTunes 12.

I recommend to look (and contribute) to Wine test reports of iTunes. Perhaps someone will find a trick.


I suggest to have a look to this alternative software : Rhythmbox (Wikipedia page).

Edité par Dadu042

NinjaLynn Lundi 13 Mai 2019 à 2:00

Rhythmbox seems to be good but I dont see any options to play purchased movies/music from iTunes in it. I might be missing something and will look into it more. 


I did find this (bug report) on WineHQ:

Edité par Dadu042

Mette619 Lundi 27 Mai 2019 à 7:54

I have still problem, I have black sreen. I can hear notfication and sounds even Siri but nothing is helping to turn on my Ipad.
No Idea what to do!!! I have done everything !!




Edité par Mette619

Dadu042 Lundi 27 Mai 2019 à 12:16

Read :

And please give reports.

gueneal Vendredi 23 Aoüt 2019 à 15:57

I had to download itunes for older videocards. This fixed it for me... but of course this is version 12.4 not 12.9.

Link is here