Adobe Photoshop Lightroom 5

Informations

Créateur Messages
Ronin DUSETTE
Admin

Information

Cet installateur a été accepté par l'équipe.

Informations

Plate-formes :
Téléchargements : 86937
Wine: 1.8.5

Retours d'expérience

Description

THIS SHOULD WORK WITH THE ADOBE CC VERSION OF LIGHTROOM, AS WELL. 

IMPORTANT: This program does NOT work well with most Intel graphics. It WILL crash. Nvidia and AMD proprietary drivers should be used.

From http://www.adobe.com/products/photoshop-lightroom.html:

"Essential software for extraordinary photography.

Lightroom 5 makes digital photography easier, faster, and more amazing. Experiment without limits in a nondestructive editing environment. Perfect your shots with advanced controls for tone, contrast, color, and more. Efficiently organize all your photos and share them almost anywhere."

Captures d'écran

MiniatureMiniatureMiniature

Code source

#!/bin/bash
# Date : (2016-11-11)
# Distribution used to test : Mint 18 LXDE 64-bit
# Author : RoninDusette, taurin
# Licence : GPLv3
# PlayOnLinux: 4.2.10
       
       
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
       
PREFIX="Lightroom57"
WINEVERSION="1.8.5"
TITLE="Adobe Photoshop Lightroom 5"
EDITOR="Adobe Systems Inc."
GAME_URL="http://www.adobe.com"
AUTHOR="RoninDusette, taurin"
       
#Initialization
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
POL_SetupWindow_Init
       
POL_Debug_Init
       
# Presentation
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"
 
POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program may NOT work well with most Intel graphics. Nvidia and AMD proprietary drivers are REQUIRED in most cases.
\n\n
Needs sRGB color profile for images to be visible. Copy sRGB.icm (comes with some native Linux software, such as GraphicsMagick) to "~/.PlayOnLinux/wineprefix/$PREFIX/drive_c/windows/system32/spool/drivers/color/sRGB Color Space Profile.icm".
\n
Or if you have winetricks installed you can run "env WINEPREFIX=~/.PlayOnLinux/wineprefix/$PREFIX winetricks colorprofile"')" "$TITLE"
 
# Create Prefix
POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"
 
# Configuration
Set_OS "win7"

POL_Call POL_Install_atmlib
POL_Call POL_Install_corefonts
POL_Call POL_Install_wintrust
POL_Call POL_Install_msasn1
POL_Call POL_Install_vcrun2008
POL_Download_Resource "https://web.archive.org/web/20061224003406/http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" "0c0f6e300800e49472e9b2e0890a09c1" "0c0f6e300800e49472e9b2e0890a09c1"
   
cd "$WINEPREFIX/drive_c/windows/temp"
cabextract "$POL_USER_ROOT/ressources/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" -F WINHTTP.DLL
if [ "$POL_ARCH" = "amd64" ]; then
        cp -f WINHTTP.DLL ../syswow64/winhttp.dll
else
        cp -f WINHTTP.DLL ../system32/winhttp.dll
fi
POL_Wine_OverrideDLL "native, builtin" "winhttp"
POL_Download_Resource "https://web.archive.org/web/20061224003406/http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" "0c0f6e300800e49472e9b2e0890a09c1"
cd "$WINEPREFIX/drive_c/windows/temp"
cabextract "$POL_USER_ROOT/ressources/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" -F WININET.DLL
if [ "$POL_ARCH" = "amd64" ]; then
        cp -f WININET.DLL ../syswow64/wininet.dll
else
        cp -f WININET.DLL ../system32/wininet.dll
fi
POL_Wine_OverrideDLL "native, builtin" "wininet"

 
# Installation
POL_Wine_WaitBefore "$TITLE"
POL_Wine "$APP_ANSWER"
POL_Wine_WaitExit "$TITLE"
 
POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"
 
#Dependencies
Set_OS "winxp"
POL_Call POL_Install_ie6
POL_Call POL_Install_wmpcodecs
POL_Call POL_Install_FontsSmoothRGB
Set_OS "win7"
POL_Call POL_Install_gdiplus
 
# Create Shortcuts
POL_Shortcut "lightroom.exe" "$TITLE"
POL_Shortcut_InsertBeforeWine "$TITLE" "export LC_ALL=C.UTF-8"
      
POL_SetupWindow_Close
exit 0

Contributions

Filters:

Contribuer
Membre Messages
gabry78 Mercredi 28 Novembre 2018 à 16:14
gabry78 Anonymous

Messages

Hello

I've recently updated ubuntu from 16.04 to 18.04. In the previous version I installed Lightroom 5 32bit succesfully.

After ubuntu update lightroom didn't work anymore so I tried to install without success.I tried several times. Sometimes in debug file I saw that wine had been crashed. The version of playonlinux is the same (4.3.3). I report that freetype versiona installed is 2.8.1

 

I attach the playonlinux log file:

 

1/28/18 15:42:14] - Content of /home/gabry/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine]
"Version"="win7"
-----------
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
[11/28/18 15:42:14] - ----- Starting function POL_Install_atmlib -----
[11/28/18 15:42:14] - ----- Starting function POL_SP2_Extract -----
[11/28/18 15:42:20] - ----- Ending function POL_SP2_Extract -----
[11/28/18 15:42:20] - ----- Ending function POL_Install_atmlib -----
[11/28/18 15:42:20] - ----- Starting function POL_Install_corefonts -----
[11/28/18 15:42:20] - ----- Starting function POL_Internal_InstallFonts -----
[11/28/18 15:42:20] - ----- Ending function POL_Internal_InstallFonts -----
[11/28/18 15:42:20] - ----- Ending function POL_Install_corefonts -----
[11/28/18 15:42:21] - ----- Starting function POL_Install_wintrust -----
[11/28/18 15:42:21] - Running wine-1.8.5 regsvr32 wintrust.dll (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/drive_c/windows/temp)
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
fixme:crypt:I_CryptCreateLruCache (0x33fa24, 0x76c5a018): stub!
fixme:crypt:I_CryptInstallAsn1Module (0x120c70 00000000 (nil)): stub
regsvr32: Successfully registered DLL 'wintrust.dll'
fixme:crypt:I_CryptFreeLruCache (0xbaadf00d, 00000000, 00000000): stub!
fixme:crypt:I_CryptUninstallAsn1Module (00000001): stub
[11/28/18 15:42:22] - ----- Starting function POL_Function_OverrideDLL -----
[11/28/18 15:42:22] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/tmp)
[11/28/18 15:42:22] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*wintrust"="native"
-----------
[11/28/18 15:42:22] - ----- Ending function POL_Function_OverrideDLL -----
[11/28/18 15:42:22] - ----- Ending function POL_Install_wintrust -----
[11/28/18 15:42:22] - ----- Starting function POL_Install_msasn1 -----
[11/28/18 15:42:23] - ----- Starting function POL_Function_OverrideDLL -----
[11/28/18 15:42:23] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/tmp)
[11/28/18 15:42:23] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*msasn1"="native"
-----------
[11/28/18 15:42:23] - ----- Ending function POL_Function_OverrideDLL -----
[11/28/18 15:42:23] - ----- Ending function POL_Install_msasn1 -----
[11/28/18 15:42:23] - ----- Starting function POL_Install_vcrun2008 -----
[11/28/18 15:42:25] - ----- Ending function POL_Install_vcrun2008 -----
[11/28/18 15:42:25] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/drive_c/windows/temp)
[11/28/18 15:42:25] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*winhttp"="native, builtin"
-----------
[11/28/18 15:42:26] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/drive_c/windows/temp)
[11/28/18 15:42:26] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*wininet"="native, builtin"
-----------
[11/28/18 15:42:26] - Running wine-1.8.5 /home/gabry/Scaricati/Adobe Photoshop Lightroom 5.4 Final (32 bit) [ChingLiu]/setup32.exe (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
fixme:ole:CoInitializeSecurity (0x32ed88,-1,(nil),(nil),6,2,(nil),8192,(nil)) - stub!
[11/28/18 16:05:03] - Running wine-1.8.5 cmd /c echo %ProgramFiles% (Working directory : /home/gabry)
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
C:\Program Files
[11/28/18 16:05:07] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/regkey.reg (Working directory : /home/gabry)
[11/28/18 16:05:07] - Content of /home/gabry/.PlayOnLinux//tmp/regkey.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine]
"Version"="win7"
-----------
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
[11/28/18 16:05:07] - ----- Starting function POL_Install_atmlib -----
[11/28/18 16:05:08] - ----- Starting function POL_SP2_Extract -----
[11/28/18 16:05:13] - ----- Ending function POL_SP2_Extract -----
[11/28/18 16:05:13] - ----- Ending function POL_Install_atmlib -----
[11/28/18 16:05:13] - ----- Starting function POL_Install_corefonts -----
[11/28/18 16:05:13] - ----- Starting function POL_Internal_InstallFonts -----
[11/28/18 16:05:13] - ----- Ending function POL_Internal_InstallFonts -----
[11/28/18 16:05:13] - ----- Ending function POL_Install_corefonts -----
[11/28/18 16:05:14] - ----- Starting function POL_Install_wintrust -----
[11/28/18 16:05:14] - Running wine-1.8.5 regsvr32 wintrust.dll (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/drive_c/windows/temp)
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
fixme:crypt:I_CryptCreateLruCache (0x32fa24, 0x76c5a018): stub!
fixme:crypt:I_CryptInstallAsn1Module (0x121678 00000000 (nil)): stub
regsvr32: Successfully registered DLL 'wintrust.dll'
fixme:crypt:I_CryptFreeLruCache (0xbaadf00d, 00000000, 00000000): stub!
fixme:crypt:I_CryptUninstallAsn1Module (00000001): stub
[11/28/18 16:05:15] - ----- Starting function POL_Function_OverrideDLL -----
[11/28/18 16:05:15] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/tmp)
[11/28/18 16:05:15] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*wintrust"="native"
-----------
[11/28/18 16:05:15] - ----- Ending function POL_Function_OverrideDLL -----
[11/28/18 16:05:15] - ----- Ending function POL_Install_wintrust -----
[11/28/18 16:05:15] - ----- Starting function POL_Install_msasn1 -----
[11/28/18 16:05:16] - ----- Starting function POL_Function_OverrideDLL -----
[11/28/18 16:05:16] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/tmp)
[11/28/18 16:05:16] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*msasn1"="native"
-----------
[11/28/18 16:05:16] - ----- Ending function POL_Function_OverrideDLL -----
[11/28/18 16:05:16] - ----- Ending function POL_Install_msasn1 -----
[11/28/18 16:05:17] - ----- Starting function POL_Install_vcrun2008 -----
[11/28/18 16:05:18] - ----- Ending function POL_Install_vcrun2008 -----
[11/28/18 16:05:19] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/drive_c/windows/temp)
[11/28/18 16:05:19] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*winhttp"="native, builtin"
-----------
[11/28/18 16:05:19] - Running wine-1.8.5 regedit /home/gabry/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/drive_c/windows/temp)
[11/28/18 16:05:19] - Content of /home/gabry/.PlayOnLinux//tmp/override-dll.reg
-----------
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\DllOverrides]
"*wininet"="native, builtin"
-----------
[11/28/18 16:05:20] - Running wine-1.8.5 /home/gabry/Scaricati/Adobe Photoshop Lightroom 5.4 Final (32 bit) [ChingLiu]/setup32.exe (Working directory : /home/gabry/.PlayOnLinux/wineprefix/Lightroom57/Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
fixme:ole:CoInitializeSecurity (0x32ed88,-1,(nil),(nil),6,2,(nil),8192,(nil)) - stub!

 

 

Réponses

Carbur Lundi 26 Février 2018 à 18:03
Carbur Anonymous

Messages

Hello,

When I try to install Lightroom 6.0 through Playonlinux, I get an Adobe message saying : "The installation failed. This product can be installed on a 64 bits system only", while it's the 64 bits version of Ubuntu that I use.

Do you have any idea on how to fix this ?

Thanks in advance.

Réponses

Ronin DUSETTE Samedi 6 Janvier 2018 à 18:25
Ronin DUSETTE
Admin

Information

Cette mise à jour a été acceptée par l'équipe

Differences

@@ -38,6 +38,32 @@
  
 # Configuration
 Set_OS "win7"
+
+POL_Call POL_Install_atmlib
+POL_Call POL_Install_corefonts
+POL_Call POL_Install_wintrust
+POL_Call POL_Install_msasn1
+POL_Call POL_Install_vcrun2008
+POL_Download_Resource "https://web.archive.org/web/20061224003406/http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" "0c0f6e300800e49472e9b2e0890a09c1" "0c0f6e300800e49472e9b2e0890a09c1"
+   
+cd "$WINEPREFIX/drive_c/windows/temp"
+cabextract "$POL_USER_ROOT/ressources/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" -F WINHTTP.DLL
+if [ "$POL_ARCH" = "amd64" ]; then
+        cp -f WINHTTP.DLL ../syswow64/winhttp.dll
+else
+        cp -f WINHTTP.DLL ../system32/winhttp.dll
+fi
+POL_Wine_OverrideDLL "native, builtin" "winhttp"
+POL_Download_Resource "https://web.archive.org/web/20061224003406/http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" "0c0f6e300800e49472e9b2e0890a09c1"
+cd "$WINEPREFIX/drive_c/windows/temp"
+cabextract "$POL_USER_ROOT/ressources/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" -F WININET.DLL
+if [ "$POL_ARCH" = "amd64" ]; then
+        cp -f WININET.DLL ../syswow64/wininet.dll
+else
+        cp -f WININET.DLL ../system32/wininet.dll
+fi
+POL_Wine_OverrideDLL "native, builtin" "wininet"
+
  
 # Installation
 POL_Wine_WaitBefore "$TITLE"

Nouveau code source

#!/bin/bash
# Date : (2016-11-11)
# Distribution used to test : Mint 18 LXDE 64-bit
# Author : RoninDusette, taurin
# Licence : GPLv3
# PlayOnLinux: 4.2.10
       
       
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
       
PREFIX="Lightroom57"
WINEVERSION="1.8.5"
TITLE="Adobe Photoshop Lightroom 5"
EDITOR="Adobe Systems Inc."
GAME_URL="http://www.adobe.com"
AUTHOR="RoninDusette, taurin"
       
#Initialization
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
POL_SetupWindow_Init
       
POL_Debug_Init
       
# Presentation
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"
 
POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program may NOT work well with most Intel graphics. Nvidia and AMD proprietary drivers are REQUIRED in most cases.
\n\n
Needs sRGB color profile for images to be visible. Copy sRGB.icm (comes with some native Linux software, such as GraphicsMagick) to "~/.PlayOnLinux/wineprefix/$PREFIX/drive_c/windows/system32/spool/drivers/color/sRGB Color Space Profile.icm".
\n
Or if you have winetricks installed you can run "env WINEPREFIX=~/.PlayOnLinux/wineprefix/$PREFIX winetricks colorprofile"')" "$TITLE"
 
# Create Prefix
POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"
 
# Configuration
Set_OS "win7"

POL_Call POL_Install_atmlib
POL_Call POL_Install_corefonts
POL_Call POL_Install_wintrust
POL_Call POL_Install_msasn1
POL_Call POL_Install_vcrun2008
POL_Download_Resource "https://web.archive.org/web/20061224003406/http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" "0c0f6e300800e49472e9b2e0890a09c1" "0c0f6e300800e49472e9b2e0890a09c1"
   
cd "$WINEPREFIX/drive_c/windows/temp"
cabextract "$POL_USER_ROOT/ressources/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" -F WINHTTP.DLL
if [ "$POL_ARCH" = "amd64" ]; then
        cp -f WINHTTP.DLL ../syswow64/winhttp.dll
else
        cp -f WINHTTP.DLL ../system32/winhttp.dll
fi
POL_Wine_OverrideDLL "native, builtin" "winhttp"
POL_Download_Resource "https://web.archive.org/web/20061224003406/http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" "0c0f6e300800e49472e9b2e0890a09c1"
cd "$WINEPREFIX/drive_c/windows/temp"
cabextract "$POL_USER_ROOT/ressources/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe" -F WININET.DLL
if [ "$POL_ARCH" = "amd64" ]; then
        cp -f WININET.DLL ../syswow64/wininet.dll
else
        cp -f WININET.DLL ../system32/wininet.dll
fi
POL_Wine_OverrideDLL "native, builtin" "wininet"

 
# Installation
POL_Wine_WaitBefore "$TITLE"
POL_Wine "$APP_ANSWER"
POL_Wine_WaitExit "$TITLE"
 
POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"
 
#Dependencies
Set_OS "winxp"
POL_Call POL_Install_ie6
POL_Call POL_Install_wmpcodecs
POL_Call POL_Install_FontsSmoothRGB
Set_OS "win7"
POL_Call POL_Install_gdiplus
 
# Create Shortcuts
POL_Shortcut "lightroom.exe" "$TITLE"
POL_Shortcut_InsertBeforeWine "$TITLE" "export LC_ALL=C.UTF-8"
      
POL_SetupWindow_Close
exit 0

Réponses

bipco Jeudi 23 Novembre 2017 à 13:03
bipco Anonymous

Messages

Hi

Anyone any experience of getting Lightroom 5 to login to Lightroom Mobile?  I've installed via this script:

https://github.com/corbindavenport/creative-cloud-linux/tree/dev

Which has worked well, mobile sync is about the only thing I've found so far that isn't working (after getting the Flickr plugin (http://regex.info/blog/lightroom-goodies/flickr) to fix Flickr non-login.

Thanks

Warren

 

Réponses

captain_Deken Lundi 19 Décembre 2016 à 23:00
captain_Deken Anonymous

Messages

Hi, everyone!

This program now runs well.

But then I tried to run English LR 5.7.1 on Ubuntu 14.04 (Xubuntu 16.04) LTS 64-bit with russian localisation, I receive only a splashscreen and system stops. I solved this by adding command "export LC_ALL=C.UTF-8" before programm runs and now everything is OK.

This problem appears on different versions of LR and different distribs of Ubuntu. I think this information could be added to programm discription, because I have no idea how to modify PlayOnLinux script.

P.S. Sorry for my English=)

Réponses

Vendredi 23 Décembre 2016 à 11:06
Hi! The script that solves this problem is just below =)
Anonymous
Samedi 14 Janvier 2017 à 15:31
Yes it works
Anonymous
Lundi 23 Janvier 2017 à 16:58
Thanx a lot=)))
imtaurin Vendredi 11 Novembre 2016 à 17:17
imtaurin

Warning

Cette mise à jour n'a pas été approuvée par l'équipe.
Utilisez-la à vos risques et périls

Messages

Some improvements, fixes and additional information for better start the program.

PS Lightroom runs well on Intel graphics, that's why I made little change in "important" notice.

Differences

@@ -1,56 +1,62 @@
 #!/bin/bash
-# Date : (2014-08-24)
-# Distribution used to test : Kubuntu 14.04 LTS 64-bit
-# Author : RoninDusette
+# Date : (2016-11-11)
+# Distribution used to test : Mint 18 LXDE 64-bit
+# Author : RoninDusette, taurin
 # Licence : GPLv3
-# PlayOnLinux: 4.2.4
-      
-      
+# PlayOnLinux: 4.2.10
+       
+       
 [ "$PLAYONLINUX" = "" ] && exit 0
 source "$PLAYONLINUX/lib/sources"
-      
-PREFIX="Lightroom54"
-WINEVERSION="1.7.11-lightroom54"
+       
+PREFIX="Lightroom57"
+WINEVERSION="1.8.5"
 TITLE="Adobe Photoshop Lightroom 5"
 EDITOR="Adobe Systems Inc."
 GAME_URL="http://www.adobe.com"
-AUTHOR="RoninDusette"
-      
+AUTHOR="RoninDusette, taurin"
+       
 #Initialization
 POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
 POL_SetupWindow_Init
-      
+       
 POL_Debug_Init
-      
+       
 # Presentation
 POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"
-
-POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program does NOT work well with most Intel graphics. It WILL crash. Nvidia and AMD proprietary drivers are REQUIRED in most cases.')" "$TITLE"
-
+ 
+POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program may NOT work well with most Intel graphics. Nvidia and AMD proprietary drivers are REQUIRED in most cases.
+\n\n
+Needs sRGB color profile for images to be visible. Copy sRGB.icm (comes with some native Linux software, such as GraphicsMagick) to "~/.PlayOnLinux/wineprefix/$PREFIX/drive_c/windows/system32/spool/drivers/color/sRGB Color Space Profile.icm".
+\n
+Or if you have winetricks installed you can run "env WINEPREFIX=~/.PlayOnLinux/wineprefix/$PREFIX winetricks colorprofile"')" "$TITLE"
+ 
 # Create Prefix
 POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
 POL_Wine_SelectPrefix "$PREFIX"
 POL_Wine_PrefixCreate "$WINEVERSION"
-
+ 
 # Configuration
 Set_OS "win7"
-
+ 
 # Installation
 POL_Wine_WaitBefore "$TITLE"
 POL_Wine "$APP_ANSWER"
 POL_Wine_WaitExit "$TITLE"
-
+ 
 POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"
-
+ 
 #Dependencies
 Set_OS "winxp"
 POL_Call POL_Install_ie6
 POL_Call POL_Install_wmpcodecs
+POL_Call POL_Install_FontsSmoothRGB
 Set_OS "win7"
 POL_Call POL_Install_gdiplus
-
+ 
 # Create Shortcuts
 POL_Shortcut "lightroom.exe" "$TITLE"
-     
+POL_Shortcut_InsertBeforeWine "$TITLE" "export LC_ALL=C.UTF-8"
+      
 POL_SetupWindow_Close
-exit 0
\ No newline at end of file
+exit 0

Nouveau code source

#!/bin/bash
# Date : (2016-11-11)
# Distribution used to test : Mint 18 LXDE 64-bit
# Author : RoninDusette, taurin
# Licence : GPLv3
# PlayOnLinux: 4.2.10
       
       
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
       
PREFIX="Lightroom57"
WINEVERSION="1.8.5"
TITLE="Adobe Photoshop Lightroom 5"
EDITOR="Adobe Systems Inc."
GAME_URL="http://www.adobe.com"
AUTHOR="RoninDusette, taurin"
       
#Initialization
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
POL_SetupWindow_Init
       
POL_Debug_Init
       
# Presentation
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"
 
POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program may NOT work well with most Intel graphics. Nvidia and AMD proprietary drivers are REQUIRED in most cases.
\n\n
Needs sRGB color profile for images to be visible. Copy sRGB.icm (comes with some native Linux software, such as GraphicsMagick) to "~/.PlayOnLinux/wineprefix/$PREFIX/drive_c/windows/system32/spool/drivers/color/sRGB Color Space Profile.icm".
\n
Or if you have winetricks installed you can run "env WINEPREFIX=~/.PlayOnLinux/wineprefix/$PREFIX winetricks colorprofile"')" "$TITLE"
 
# Create Prefix
POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"
 
# Configuration
Set_OS "win7"
 
# Installation
POL_Wine_WaitBefore "$TITLE"
POL_Wine "$APP_ANSWER"
POL_Wine_WaitExit "$TITLE"
 
POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"
 
#Dependencies
Set_OS "winxp"
POL_Call POL_Install_ie6
POL_Call POL_Install_wmpcodecs
POL_Call POL_Install_FontsSmoothRGB
Set_OS "win7"
POL_Call POL_Install_gdiplus
 
# Create Shortcuts
POL_Shortcut "lightroom.exe" "$TITLE"
POL_Shortcut_InsertBeforeWine "$TITLE" "export LC_ALL=C.UTF-8"
      
POL_SetupWindow_Close
exit 0

Réponses

Anonymous
Samedi 14 Janvier 2017 à 15:31
Hello! Where can i use this script in PoL?
Anonymous
Samedi 14 Janvier 2017 à 15:33
Found. In Russian it is "??????? - ????????? ????????? ????????"
Anonymous
Samedi 14 Octobre 2017 à 18:46
working
Linux 4.10.0-37-generic #41~16.04.1-Ubuntu SMP Fri Oct 6 22:42:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
falldaron Samedi 30 Juillet 2016 à 2:25
falldaron Anonymous

Messages

Bonjour,

C'est très bien, mai il ne reconnait pas ma carte graphique Nvidia Quadro K3100

alors que la meme version de ce logiciel sous windows il et bien reconnu, du coup l'accélération graphique ne s'active pas.

============ english ===========

 

Hello,

This is fine, it may not recognize my Nvidia Quadro K3100

while the same version of the software under Windows it and much recognized, suddenly graphics acceleration is not activated.

Réponses

Erathor Samedi 23 Juillet 2016 à 12:28
Erathor Anonymous

Messages

Hi all. 

I've installed Lightroom 5.7 under playonlinux and, really, runs quite good. I've only have seen a couple of issues. 

a. If I try to use export images with plugins like "Flickr" or "Picasa Uploader" the software reports no internet connection available. Even with a simple account authoritation. 

b. I loose the image when I try to crop it and, in develop mode, I only can edit images if I click "screen test" mode. I've seen in old posts that this problem could be fixed importing a color profile, but I have not understood how to achieve that. 

 

Thx in advance and king regards for all!

Réponses

wayneTrain Jeudi 26 Mai 2016 à 15:18
wayneTrain Anonymous

Messages

What's with Lightroom 6? Did somebody try?

Réponses

Retro Gamer Jeudi 19 Mai 2016 à 10:21
Retro Gamer

Messages

The POL installer fails due to a crc mismatch when downloading resource http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe. Might need to find a new source for that file.

Réponses

Jeudi 19 Mai 2016 à 10:30
Looks like Microsoft has removed the links/files to the older files for unsupported versions of Windows.
Jeudi 19 Mai 2016 à 21:00
I did find an alternate download for that file, but I'm not sure how go about using it instead of the file POL is trying to access that's no longer there. Its not a priority at the moment, but I did want you to be aware.
Jeudi 19 Mai 2016 à 21:42
Shoot me the link to it and I can make the change in the script. Then you can just use the installer like normal. :)
Jeudi 19 Mai 2016 à 22:03
For sure. So, I am available to make that change right now, so if you get me the direct download link, I will correct it.
Samedi 21 Mai 2016 à 2:41
http://itinfo.uthm.edu.my/files/download/browser/IE/ie5/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe
Samedi 21 Mai 2016 à 2:41
http://itinfo.uthm.edu.my/files/download/browser/IE/ie5/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe
Samedi 21 Mai 2016 à 3:15
Is that a stable place to host that file? Also, is it legal for them to offer that file for download? I only ask because most MS packages like that are not freely distributable, if I am not mistaken. Even if it's a free download, their license may not allow for 3rd party hosting of their distributables. I haven't checkes the license for that, but we should double check if you could.
Samedi 21 Mai 2016 à 11:35
I've looked for other places, but its the only spot I could find it already hosted.
Samedi 21 Mai 2016 à 11:56
I'm trying to look into the legality of 3rd party hosting the file. If we are not able to use it then the script will need to be changed to ask for the file location on the users hard drive leaving it up to the user to find and download the file themselves.
Samedi 21 Mai 2016 à 15:49
That's not graceful, and that package is needed by a lot of scripts. MS has to have it hosted somewhere. I'll look into it this weekend and see what I can figure out.
Samedi 21 Mai 2016 à 16:29
They don't need to host files for things they dropped support for years ago. Your going to find more and more files like this dropped or being dropped. W2KSP4_EN.EXE is also no longer availible from Microsoft https://web.archive.org/web/20061224003406/http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe
Samedi 21 Mai 2016 à 16:31
Recently many OLD support files where dropped from the Microsoft site. Some can be found via the web archive or mirror sites.
Samedi 21 Mai 2016 à 16:39
winetricks is obviously having the same issue regarding dropped support files from the MS site. There solution was using the web archive as a backup down, but still not sure of the legalities of that.
Samedi 21 Mai 2016 à 18:38
Word. I'll get it straightened out when I have a moment.
Samedi 21 Mai 2016 à 21:21
Unfortunately even if they remove that stuff from their site because they don't support it, that doesn't change the license, so we will have to figure out a solution. ;(
Dimanche 22 Mai 2016 à 0:57
I'm not a lawyer, but as I see it as long as your not the one hosting the file(s) I don't see a legal issue for POL.
Dimanche 22 Mai 2016 à 1:02
Yeah, but that could also mean that no server will ever be reliable like theirs because they could shut it down, meaning we have to switch the download link often. I'm not able to troubleshoot it at the moment, but when I can I will see if there is some way to get around it. I'm sure everyone is open to solutions, though. We just need something graceful, solid, and legal.
maulwurf Jeudi 3 Mars 2016 à 21:17
maulwurf Anonymous

Messages

works well with Lightroom 5.7 (32bit) on Linux Mint 17.3 with a Intel Core i5 2500K with onboard graphics.

Had to add a color profile in Colors/Farbe > My monitor to see anything while cropping.

Only crash so far is the catalog chooser. Can be prevented by not clicking in the pre populated catalog list but choosing manually with "other location".

Some graphic glitches here and there, but no show stopper. 

 

Is there any chance to add Quicktime to the install script for having video support, too? The separate QuickTime POL install is not recognized by LR. 

Réponses

Jeudi 19 Mai 2016 à 10:17
The POL installer fails due to a crc mismatch when downloading resource http://download.microsoft.com/download/5/0/c/50c42d0e-07a8-4a2b-befb-1a403bd0df96/IE5.01sp4-KB871260-Windows2000sp4-x86-ENU.exe. How did you get around that?
Jeudi 19 Mai 2016 à 15:39
This was back in March when this user posted. I'll try to figure out a solution.
TrickyDicky Samedi 24 Janvier 2015 à 4:55
TrickyDicky Anonymous

Messages

Successful install... Thanks!

However, Lightroom does not see my NAS where all my photos are stored. NAS connects to Linux Mint fine

I would be really grateful if anyone knows how to get Lightroom to access the NAS to import photos... If not I will have to go back to using Windows, which pains me greatly. <Sigh>

Cheers

Réponses

Samedi 24 Janvier 2015 à 5:42
What you would need to do is mount your NAS to a folder on your system, and in PlayOnLinux -> configure -> select the Lightroom virtual drive -> Wine tab -> Wine Configuration

and set a drive letter to your folder where your NAS is mounted at. That is the only way I can see it working, as that is not a very normal configuration (most use their NAS as a backup, and have a physical HD attached to their machine for usage), but that should work. If it doesn't, then you will need a more complicated setup, with a NAS drive being shared via nfs, and mounted to your Linux system (NTFS and Wine can be grumpy sometimes. )

Hope this helps. If not, a more traditional configuration with an HD attached to the main workstation, and then just backing up to the NAS (network access is far slower than direct HD access anyway, so you may see better results), though it just depends on your situation. If you need to run it off a NAS, and cannot get it mounted and used via Wine, then Windows may be the only solution for the time being, besides switching storage mediums.
Ronin DUSETTE Vendredi 19 Décembre 2014 à 21:54
Ronin DUSETTE
Admin

Messages

THIS SHOULD WORK WITH THE ADOBE CC VERSION OF LIGHTROOM, AS WELL. 

 

Réponses

Anonymous
Mardi 12 Janvier 2016 à 10:14
Should this still work? I could only get the 64 bit versions of Lightroom at Creative Cloud, and the Wine version seems to be a 32 bit install...?
Mardi 12 Janvier 2016 à 14:00
Most install scripts are 32bit, this one is no exception... For example it depends on ie6 component, that only installs on 32bit Wine
Mardi 12 Janvier 2016 à 17:18
Yeah. When I wrote this, I didn't realise that CC was 64-bit only, so it won't work. CS6 does actually work well.
SKAL Mercredi 10 Décembre 2014 à 11:03
SKAL Anonymous

Warning

Cette mise à jour n'a pas été approuvée par l'équipe.
Utilisez-la à vos risques et périls

Messages

Hi, 

I've just tried to install it on a ubuntu box.

I was using the LR5.7 installation file, but it works anyway. 

I would like to notify that POL_Install_ie6 was not working giving me some problems with the installation of the kb871260 patch. I've changed the script to POL_Install_ie8 and everything went good untill the end.

Differences

@@ -44,7 +44,7 @@
 
 #Dependencies
 Set_OS "winxp"
-POL_Call POL_Install_ie6
+POL_Call POL_Install_ie8
 POL_Call POL_Install_wmpcodecs
 Set_OS "win7"
 POL_Call POL_Install_gdiplus

Nouveau code source

#!/bin/bash
# Date : (2014-08-24)
# Distribution used to test : Kubuntu 14.04 LTS 64-bit
# Author : RoninDusette
# Licence : GPLv3
# PlayOnLinux: 4.2.4
      
      
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
      
PREFIX="Lightroom54"
WINEVERSION="1.7.11-lightroom54"
TITLE="Adobe Photoshop Lightroom 5"
EDITOR="Adobe Systems Inc."
GAME_URL="http://www.adobe.com"
AUTHOR="RoninDusette"
      
#Initialization
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
POL_SetupWindow_Init
      
POL_Debug_Init
      
# Presentation
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"

POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program does NOT work well with most Intel graphics. It WILL crash. Nvidia and AMD proprietary drivers are REQUIRED in most cases.')" "$TITLE"

# Create Prefix
POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"

# Configuration
Set_OS "win7"

# Installation
POL_Wine_WaitBefore "$TITLE"
POL_Wine "$APP_ANSWER"
POL_Wine_WaitExit "$TITLE"

POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"

#Dependencies
Set_OS "winxp"
POL_Call POL_Install_ie8
POL_Call POL_Install_wmpcodecs
Set_OS "win7"
POL_Call POL_Install_gdiplus

# Create Shortcuts
POL_Shortcut "lightroom.exe" "$TITLE"
     
POL_SetupWindow_Close
exit 0

Réponses

Mardi 16 Décembre 2014 à 7:19
Don't change the script. ie6 works fine. Don't install updates or patches. Just let it install ie6 itself, and that is it. I know it gives an option to run updates, but just don't. They are not needed. It should install fine after that.
Ronin DUSETTE Samedi 25 Octobre 2014 à 21:26
Ronin DUSETTE
Admin

Warning

Cette mise à jour n'a pas été approuvée par l'équipe.
Utilisez-la à vos risques et périls

Differences

@@ -14,7 +14,7 @@
 TITLE="Adobe Photoshop Lightroom 5"
 EDITOR="Adobe Systems Inc."
 GAME_URL="http://www.adobe.com"
-AUTHOR="DJYoshaBYD"
+AUTHOR="RoninDusette"
       
 #Initialization
 POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"

Nouveau code source

#!/bin/bash
# Date : (2014-08-24)
# Distribution used to test : Kubuntu 14.04 LTS 64-bit
# Author : RoninDusette
# Licence : GPLv3
# PlayOnLinux: 4.2.4
      
      
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
      
PREFIX="Lightroom54"
WINEVERSION="1.7.11-lightroom54"
TITLE="Adobe Photoshop Lightroom 5"
EDITOR="Adobe Systems Inc."
GAME_URL="http://www.adobe.com"
AUTHOR="RoninDusette"
      
#Initialization
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
POL_SetupWindow_Init
      
POL_Debug_Init
      
# Presentation
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"

POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program does NOT work well with most Intel graphics. It WILL crash. Nvidia and AMD proprietary drivers are REQUIRED in most cases.')" "$TITLE"

# Create Prefix
POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"

# Configuration
Set_OS "win7"

# Installation
POL_Wine_WaitBefore "$TITLE"
POL_Wine "$APP_ANSWER"
POL_Wine_WaitExit "$TITLE"

POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"

#Dependencies
Set_OS "winxp"
POL_Call POL_Install_ie6
POL_Call POL_Install_wmpcodecs
Set_OS "win7"
POL_Call POL_Install_gdiplus

# Create Shortcuts
POL_Shortcut "lightroom.exe" "$TITLE"
     
POL_SetupWindow_Close
exit 0

Réponses

Ronin DUSETTE Samedi 25 Octobre 2014 à 19:19
Ronin DUSETTE
Admin

Warning

Cette mise à jour n'a pas été approuvée par l'équipe.
Utilisez-la à vos risques et périls

Differences

@@ -1,7 +1,7 @@
 #!/bin/bash
 # Date : (2014-08-24)
 # Distribution used to test : Kubuntu 14.04 LTS 64-bit
-# Author : DJYoshaBYD
+# Author : RoninDusette
 # Licence : GPLv3
 # PlayOnLinux: 4.2.4
       

Nouveau code source

#!/bin/bash
# Date : (2014-08-24)
# Distribution used to test : Kubuntu 14.04 LTS 64-bit
# Author : RoninDusette
# Licence : GPLv3
# PlayOnLinux: 4.2.4
      
      
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
      
PREFIX="Lightroom54"
WINEVERSION="1.7.11-lightroom54"
TITLE="Adobe Photoshop Lightroom 5"
EDITOR="Adobe Systems Inc."
GAME_URL="http://www.adobe.com"
AUTHOR="DJYoshaBYD"
      
#Initialization
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
POL_SetupWindow_Init
      
POL_Debug_Init
      
# Presentation
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"

POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program does NOT work well with most Intel graphics. It WILL crash. Nvidia and AMD proprietary drivers are REQUIRED in most cases.')" "$TITLE"

# Create Prefix
POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"

# Configuration
Set_OS "win7"

# Installation
POL_Wine_WaitBefore "$TITLE"
POL_Wine "$APP_ANSWER"
POL_Wine_WaitExit "$TITLE"

POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"

#Dependencies
Set_OS "winxp"
POL_Call POL_Install_ie6
POL_Call POL_Install_wmpcodecs
Set_OS "win7"
POL_Call POL_Install_gdiplus

# Create Shortcuts
POL_Shortcut "lightroom.exe" "$TITLE"
     
POL_SetupWindow_Close
exit 0

Réponses

Maroce Mercredi 15 Octobre 2014 à 16:00
Maroce

Messages

im sorry, i've a problem if i click the "install this program" button, can you help me to solve the problem? i hope yes, thx, im Feisal from Indonesia

Réponses

Mercredi 15 Octobre 2014 à 20:09
You need to associate the URL "protocol" ("scheme" actually) to playonlinux-url_handler script
http://www.playonlinux.com/en/topic-10662-PlayOnLinux_Need_Help_with_qprotocol_playonlinux_isnt_associatedq.html
Ronin DUSETTE Lundi 25 Aoüt 2014 à 19:56
Ronin DUSETTE
Admin

Warning

Cette mise à jour n'a pas été approuvée par l'équipe.
Utilisez-la à vos risques et périls

Messages

Initial commit.

Differences

@@ -0,0 +1,56 @@
+#!/bin/bash
+# Date : (2014-08-24)
+# Distribution used to test : Kubuntu 14.04 LTS 64-bit
+# Author : DJYoshaBYD
+# Licence : GPLv3
+# PlayOnLinux: 4.2.4
+      
+      
+[ "$PLAYONLINUX" = "" ] && exit 0
+source "$PLAYONLINUX/lib/sources"
+      
+PREFIX="Lightroom54"
+WINEVERSION="1.7.11-lightroom54"
+TITLE="Adobe Photoshop Lightroom 5"
+EDITOR="Adobe Systems Inc."
+GAME_URL="http://www.adobe.com"
+AUTHOR="DJYoshaBYD"
+      
+#Initialization
+POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
+POL_SetupWindow_Init
+      
+POL_Debug_Init
+      
+# Presentation
+POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"
+
+POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program does NOT work well with most Intel graphics. It WILL crash. Nvidia and AMD proprietary drivers are REQUIRED in most cases.')" "$TITLE"
+
+# Create Prefix
+POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
+POL_Wine_SelectPrefix "$PREFIX"
+POL_Wine_PrefixCreate "$WINEVERSION"
+
+# Configuration
+Set_OS "win7"
+
+# Installation
+POL_Wine_WaitBefore "$TITLE"
+POL_Wine "$APP_ANSWER"
+POL_Wine_WaitExit "$TITLE"
+
+POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"
+
+#Dependencies
+Set_OS "winxp"
+POL_Call POL_Install_ie6
+POL_Call POL_Install_wmpcodecs
+Set_OS "win7"
+POL_Call POL_Install_gdiplus
+
+# Create Shortcuts
+POL_Shortcut "lightroom.exe" "$TITLE"
+     
+POL_SetupWindow_Close
+exit 0
\ No newline at end of file

Nouveau code source

#!/bin/bash
# Date : (2014-08-24)
# Distribution used to test : Kubuntu 14.04 LTS 64-bit
# Author : DJYoshaBYD
# Licence : GPLv3
# PlayOnLinux: 4.2.4
      
      
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
      
PREFIX="Lightroom54"
WINEVERSION="1.7.11-lightroom54"
TITLE="Adobe Photoshop Lightroom 5"
EDITOR="Adobe Systems Inc."
GAME_URL="http://www.adobe.com"
AUTHOR="DJYoshaBYD"
      
#Initialization
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
POL_SetupWindow_Init
      
POL_Debug_Init
      
# Presentation
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"

POL_SetupWindow_message "$(eval_gettext 'IMPORTANT: This program does NOT work well with most Intel graphics. It WILL crash. Nvidia and AMD proprietary drivers are REQUIRED in most cases.')" "$TITLE"

# Create Prefix
POL_SetupWindow_browse "$(eval_gettext 'Please select $TITLE install file.')" "$TITLE"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"

# Configuration
Set_OS "win7"

# Installation
POL_Wine_WaitBefore "$TITLE"
POL_Wine "$APP_ANSWER"
POL_Wine_WaitExit "$TITLE"

POL_SetupWindow_message "$(eval_gettext 'PlayOnLinux will now install a few required programs, including IE6. Just click NEXT through IE install, as you usually would.')" "$TITLE"

#Dependencies
Set_OS "winxp"
POL_Call POL_Install_ie6
POL_Call POL_Install_wmpcodecs
Set_OS "win7"
POL_Call POL_Install_gdiplus

# Create Shortcuts
POL_Shortcut "lightroom.exe" "$TITLE"
     
POL_SetupWindow_Close
exit 0

Réponses

Lundi 25 Aoüt 2014 à 19:58
Here are the resources for this script, as well:
Lundi 25 Aoüt 2014 à 19:59
http://repo.dusette.net/FOSS/PlayOnLinux/Scripts/Lightroom/Images/
Lundi 25 Aoüt 2014 à 20:26
They should be available now
Lundi 25 Aoüt 2014 à 20:28
Sweet. Thanks, petch.
Mardi 26 Aoüt 2014 à 1:05
Do you really need ie6?
Mardi 26 Aoüt 2014 à 1:12
Yes. I was going to break it down and individually take care of all of the dll's, but it for sure needs it. There are so many things that it installs, that everything I have read and tried made me do the ie6 install. I would love to do it silently, so if you know of a better way, I am all for it.
Mardi 26 Aoüt 2014 à 1:14
Well, considering we did a new wine-build, let me check to see if it works without it real quick. I did not have success before. brb.
Mardi 26 Aoüt 2014 à 1:21
Yes, without IE, it crashes instantly on launching it. I can see that it is crashing and the traceback pretty much shows everything that IE installs listed.
Mardi 26 Aoüt 2014 à 1:25
Well, a lot of them, anyway. I will see what I can do to streamline it sometime in the next day or two.
Mardi 26 Aoüt 2014 à 1:28
I'm pretty sure you only need one of the dependances of IE6. (Wininet?)
Mardi 26 Aoüt 2014 à 1:35
Ok. I will try it and post back up with what I find.
Mardi 26 Aoüt 2014 à 1:39
Crashes.
Mardi 26 Aoüt 2014 à 1:40
http://pastebin.com/4EhfkTFE
Samedi 6 September 2014 à 22:20
Thank you for the Lightroom Script :)
Samedi 6 September 2014 à 22:22
I have a problem with the development screen, the live image is not updating ( same problem is described here https://appdb.winehq.org/objectManager.php?sClass=version&iId=28669 ) . It is showing a grey image instead of the live preview. Any suggestions ?
Samedi 6 September 2014 à 22:47
Debug output and systems specs, please. That is odd that it is doing that, as I have tried it on quite a few systems and it seems to be working fine. Post that stuff up and let's see if we can figure it out. :-) I am super glad that people found this useful. Lightroom is awesome.
Samedi 6 September 2014 à 22:49
Also, what version of lightroom are you using? This is only for 5.4 and up, 32 bit only.
Dimanche 7 September 2014 à 11:39
I read about your Lightroom engagement on phoronix, I am very happy about this, because LR on Linux is a pain in the ass, you know :)
Dimanche 7 September 2014 à 11:43
Arch Linux - Kernel 3.15.10 on a Lenovo T520, so I am using bumblebee with primusrun to run Playonlinux on the Nvidia GPU. I've tried LR 5.6 and LR 5.4
Dimanche 7 September 2014 à 11:43
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [Quadro NVS 4200M] (rev a1)
Dimanche 7 September 2014 à 11:52
The whole log is here http://pastebin.com/p7Dvn6y8
Dimanche 7 September 2014 à 11:54
The trackbar messages appear when I apply a filter, while zooming in, nothing is logged
Dimanche 7 September 2014 à 11:56
This evening I try the installation on my normal pc (gtx 560) maybe the problems are related to the special laptop environment
Dimanche 7 September 2014 à 12:33
You may force wine to use your nvidia card by running POL with optirun
Dimanche 7 September 2014 à 13:39
I am using primusrun instead of optirun, is forcing the Nvidia card, too. I have the same results with the nvidia card
Dimanche 7 September 2014 à 23:13
I have the same problems witch my pc at home. Arch Linux 64bit (3.15.6), (Lightroom and Wine is 32bit). Live Image is not updating. If you have any suggestion, I try it and give you a feedback. IRC maybe?
Lundi 8 September 2014 à 1:58
Could you provide me the patches you have used to build the wine version for lightroom? I´d like to do some tests
Lundi 8 September 2014 à 2:54
Fixed the problem by adding the file "sRGB Color Space Profile.icm" to ~/PlayOnLinux's virtual drives/Lightroom54/drive_c/windows/system32/spool/drivers/color
Lundi 8 September 2014 à 4:32
Yeah. I was just about to say that. That is the issue. The Wine version is totally fine. I have seen that color profile issue pop up in forums talking about this, but I haven't personally seen it. The patches can be found on PlayOnLinux's GitHub page (same with all of the patches used to patch Wine for POL builds. ) :)
Lundi 8 September 2014 à 8:57
I wonder if there is a way to detect the presence of a colour profile (or rather, the need for a colour profile), to automatically do this? It seems system/setup-dependant, because, again, I have not run into this personally, but it is not unheard of with Lightroom 5 and Wine.
Lundi 8 September 2014 à 16:32
I think, if a full blow DE is used (Gnome, KDE), there is a color profile manager and a color daemon, and mentioned here ( https://appdb.winehq.org/objectManager.php?sClass=version&iId=28669 comment "color profile") it is working with a selected color profile. I do not have a DE, I use i3wm and have "colord" to start my monitor profile. It seems not to be sufficent for LR5 :D , maybe you should copy the srgb...icm file always instead of checking if the file is needed.
Lundi 8 September 2014 à 17:47
Well, it would make no sense to just always throw it in there. Over 800+ uses of this script, and you are the only one that reported it, plus I have tested it multiple times on multiple systems, and this is not needed. Yes, they are KDE, but I would be weary to just toss it in there, and possibly cripple and otherwise fine installation. It is simply bad form to install something without actually knowing whether or not you need it, plus scripting a check shouldn't that hard. Even then, I would need to see this issue actually reported more before changing anything, because with over 800 uses and only this report of issues, it to be working fine without that. Most people run DE's anyway, so yeah. No to always just installing it, but I would still like to figure out a check to see if it is needed. Worse-case scenario, I will put a note at the end of the installer mentioning this issue and the fix. 
Lundi 8 September 2014 à 17:52
Yes, you're right, that makes no sense. A note for this special issue is sufficient :) Thanks for your support
Lundi 8 September 2014 à 17:56
No problem. I will start with a note in the script (I will add that later today after I get some work done), and if I can find a way to check for the need for a color profile, I am sure I can at least rig some sort of function to do that or at least alert the user.
Anonymous
Jeudi 9 Octobre 2014 à 18:12
Hi! Many Thanks for this installer!
Anonymous
Jeudi 9 Octobre 2014 à 18:15
But I have to manually adding the file "sRGB Color Space Profile.icm" to ~/PlayOnLinux's virtual drives/Lightroom54/drive_c/windows/system32/spool/drivers/color
And do export LC_ALL=C before installation. Because without this Lightroom launches but hangs at splashscreen with 1 CPU loaded at 100%.
My default locale is "uk_UA.UTF-8".
Anonymous
Jeudi 9 Octobre 2014 à 18:22
Forget to say. I have Mobility Radeon HD5650 and using opensource driver. Seems like it works fine.
Jeudi 9 Octobre 2014 à 18:32
Yeah. The color profile thing is not always needed, and will need to be done manually. I am glad you like it. It was a major challenge to get it this stable. Also, thanks for posting your gfx card and drivers. At least now we know that it works with the radeon drivers. :-)
Anonymous
Jeudi 9 Octobre 2014 à 19:52
Without sRGB Color Space Profile.icm Lightroom show me only gray rectangles instead of photo pictures.
Jeudi 9 Octobre 2014 à 19:53
Yeah. That happens only with a couple of DE's. What distro are you running?
Jeudi 9 Octobre 2014 à 19:55
Also, I didn't have to do ANY of that (no export LC_ALL, no color profile) with KDE, which is what I use, and that is tested on 2 different systems. It might be something with GTK, as it looks like DE's written in QT don't seem to have this problem. Of course, more testing would be needed, to verify this. You are helping out a lot by providing this information. I appreciate, as will the rest of the community. :)
Anonymous
Jeudi 9 Octobre 2014 à 20:20
I'm glad to help )
I use Ubuntu 12.04 with xfce 4.10.
Maybe KDE have color profile somewhere, where wine can find it and use it with Lightroom?
Jeudi 9 Octobre 2014 à 20:23
Maybe. I am not sure. I need to figure out a way to check if it is needed, and then I can script it. I just don't want to throw it in all of the time, especially if it is not needed. That is just bad practice. If I knew of a way to check to see if the color profile being missing would cause a problem, then I will automate that and make it a non-issue.
Anonymous
Jeudi 9 Octobre 2014 à 20:39
I can send my wine logs, and maube you can found a difference, and figure out why icm is needed for my system? If you want my logs, say what debug level I have to select, and where to send it.
Jeudi 9 Octobre 2014 à 20:41
It won't say in there. I am working on it. I will have it corrected soon. You are not the only one with this issue. I just need to isolate the systems that need it and write some conditionals in the script. Sit tight. I will have it fixed this week for sure.
Jeudi 9 Octobre 2014 à 20:47
Actually, just for the sake of coverage, can you pastebin your full log here, without the colour profile (remove it so that it does not work, and post that log), so that I can just check it out. I wouldn't think it would give me everything I need, but it can't hurt. :)
Anonymous
Jeudi 9 Octobre 2014 à 20:48
Ok!I can test it.
Anonymous
Jeudi 9 Octobre 2014 à 22:42
Here it is. http://pastebin.com/vyedPEv2
But now it's working very strange. After removing icm Lightroom shows pictures, but I can't edit. And can't see detailed 100% zoom, only smooth zoom w/o details.
Jeudi 9 Octobre 2014 à 22:51
Well, like I said, you need it because of your distro. That is something that cannot be helped. But as along as I can write something to check to see if it is needed, this won't be an issue. Thanks for posting that.
Anonymous
Vendredi 10 Octobre 2014 à 7:20
Can you explain, where is trouble with my distro? I want to know, maybe I can fix it to avoid same errors in the future?
Vendredi 10 Octobre 2014 à 7:36
It is not just with your distro. You have to remember that this is written for Windows, not Linux. This is simply a glitch from the process of running it on Linux. As explained earlier, it is not just you; some distro's just need the colour profile set up. I mean, it is not going to light your computer on fire, and is easily fixable. I am just trying to figure out how to script it in a proper manner. The thing is, I do not know what is wrong with ANY distro that causes this issue. I have tested it on Kubuntu 14.04, and it works without any extra problems. I am trying to figure out a solution. As a comparison, this script has been downloaded almost 3,000 times and this has only been reported 2 times, so I am just trying to narrow down which distro's need the colour profile for this. Be patient; I will take care of it. :)
Lundi 20 Octobre 2014 à 9:25
Thanks for the icm fix info Dr. Fail.
Anonymous
Samedi 5 Décembre 2015 à 2:18
On my Fedora 23 install first launch failed. Once I copied in the sRGB.icc it started working!
Anonymous
Samedi 5 Décembre 2015 à 2:19
For what's worth the command used was "cp /usr/share/color/icc/colord/sRGB.icc ~/PlayOnLinux\'s\ virtual\ drives/Lightroom54/drive_c/windows/system32/spool/drivers/color"