Forums

playonmac won't open

Auteur Réponses
Flyseyes108 Mercredi 1 Mai 2013 à 16:30
Flyseyes108Anonymous

I open it and it says "playonmac can't run because of a bad language setting on your computer, to solve the problem open a terminal and type: defaults write -gAppleLocale en_US" I'm sorry I'm kinda computer retarded and have no idea what that means.  

Thanks In advance for any response
Flyseyes
Ronin DUSETTE Mercredi 1 Mai 2013 à 18:03
Ronin DUSETTE
Admin

It says exactly how to fix it in the terminal:

playonmac can't run because of a bad language setting on your computer, to solve the problem open a terminal and type: defaults write -gAppleLocale en_US

Citer


So, open your terminal (it should be in Applications or system applications or something like that) and open the terminal (if you cannot find it, google it).

Now, once the terminal is open, type this:


defaults write -gAppleLocale en_US


and press enter. That will fix it.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Flyseyes108 Jeudi 2 Mai 2013 à 4:15
Flyseyes108Anonymous

thank you very much for the help I will try it. Like I said i'm somewhat computer retarded
Flyseyes108 Jeudi 2 Mai 2013 à 4:17
Flyseyes108Anonymous

typed in exactly that about 5 times and got this message "Rep argument is not a dictionary
Defaults have not been changed."
Ronin DUSETTE Jeudi 2 Mai 2013 à 4:37
Ronin DUSETTE
Admin

Hmm. i dont know. Im not a mac guy. Its basically saying that your computer is set to the wrong language. What language is your mac set to?

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Flyseyes108 Vendredi 3 Mai 2013 à 6:14
Flyseyes108Anonymous

english. i'm from he states
Flyseyes108 Vendredi 3 Mai 2013 à 6:14
Flyseyes108Anonymous

the*
Ronin DUSETTE Vendredi 3 Mai 2013 à 17:34
Ronin DUSETTE
Admin

Hmm. Thats odd. I have seen this problem a bunch of times, and simply opening a terminal and using "defaults write -gAppleLocale en_US" fixes it. Hopefully someone with a little more mac experience can chime in.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Gabe0323 Mardi 11 Juin 2013 à 4:29
Gabe0323Anonymous

I had the same problem as you did but i think it is because i copied default message from this site. What i did to solve the problem was open terminal, click on the shell menu, then the new command option, then copied letter for letter, caps for caps, the message that was written on the pop up message from Playonmac. It worked after that. Hope this helps! 
Ronin DUSETTE Mardi 11 Juin 2013 à 10:16
Ronin DUSETTE
Admin

Well, you dont copy the whole message. Just the command that its telling you to run.

For clarification, that is:


defaults write -gAppleLocale en_US

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
jinko17bro Dimanche 30 Octobre 2016 à 3:28
jinko17broAnonymous

Okay I did everything and it still doesn't work. What do I do?

 

By the way it says:

"Could not write domain Apple Global Domain; exiting"

Edité par jinko17bro

Vous êtes ici: Index > PlayOnMac > playonmac won't open