League of Legends crash after loading screen


Auteur Réponses
sullengenie Mercredi 9 Octobre 2013 à 9:45


I'm running Ubuntu 13.04 (Unity), PoL 4.2.1, and Wine 1.7-LeagueOfLegends. I can load up the launcher and client just fine. I create a custom game and get into the loading screen, which takes a minute to start, as seems to be standard. Once the loading screen gets to 100% my cursor jumps to the middle of the screen, and I get a bug splat.

I'm not sure what hardware specs are relevant, but my processor and graphics card are as follows (and I'll be happy to add any more information that could be helpful):
4th Generation Intel Core i7-4750HQ Processor
Intel Iris Pro Graphics 5200 with 128 MB eDRAM

Here is a pastebin of the debug log:

Thanks in advance for any kind of help you can give.

petch Mercredi 9 Octobre 2013 à 12:45

err:d3d:resource_init Out of adapter memory
Can the game run with 128MB? At least make sure you're not using a compositing window manager, or other features that use video memory...
sullengenie Mercredi 9 Octobre 2013 à 15:19

Hmm, I suppose it's possible that I'm out of memory. From lspci, it looks I have 256MB of video RAM:

lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation Crystal Well Integrated Graphics Controller (rev 08) (prog-if 00 [VGA controller])
Subsystem: CLEVO/KAPOK Computer Device 7410
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
Expansion ROM at [disabled]
Kernel driver in use: i915

I feel like this should be enough, but I'll try running it from a less resource-intensive desktop to see if that helps.

Edit: I tried to run it in Openbox, and got the same result.

Edité par sullengenie

sullengenie Mercredi 9 Octobre 2013 à 16:21

I manually set my graphics memory to 256MB, and I can get in game now. Thanks a bunch for your help.