Forums

Installer POL (dépendances)

Auteur Réponses
volkmar Mardi 3 Juin 2008 à 9:53
volkmarAnonymous

Bonjour,

J'essaie de faire un ebuild Gentoo pour POL et j'ai beaucoup de soucis avec les dépendances et de façon générale, avec l'installation.

Voici les dépendances que quelqu'un a mis sur POL (ancienne ebuild) :
python
wxGTK-2.8.*
gtk+
lynx
unzip
cabextract
binutils
xterm
wine
imagemagick
lzma-utils
wxpython

Tout d'abord, la liste est-elle exhaustive ?
Je trouve que lynx n'a pas vraiment a être ici pourtant dans un sujet sur le forum, ça semble corriger le problème de quelqu'un : y'a moyen d'avoir des infos ?

Enfin, lors de l'install, j'ai les problèmes suivant :
Error: unable to open display localhost:0.0
> c'est dommage que X soit nécessaire à l'install

File "/usr/lib/python2.5/string.py", line 290, in split
return s.split(sep, maxsplit)
AttributeError: 'NoneType' object has no attribute 'split'
> vous sauriez d'où vient le problème ?

Merci pour toutes les infos
Quentin PÂRIS Mardi 3 Juin 2008 à 17:01
Quentin PÂRIS
Admin

Lynx ya plus besoin

Pour python je vois pas ... Essais avec python 2.4
Aymeric P. Mardi 3 Juin 2008 à 21:59
Aymeric P.
Admin

Salut,
Voici un message qui a été dit sur le chan

polytan> cela serait possible de dire à Tinou que sous gentoo, il suffit de wxpython et wxgtk en version 2.6 ?

Citer

Il y a quelque temps déjà.

Sinon il y a un sujet a propos de l'install sous gentoo dans cette section (le sujet doit être au fin fond du forum maintenant)

Former member.
Quentin PÂRIS Mardi 3 Juin 2008 à 22:33
Quentin PÂRIS
Admin

wxpython et wxgtk 2.6 fout vraiment la merde sur POL. Crois moi mulx
volkmar Mercredi 4 Juin 2008 à 13:56
volkmarAnonymous

Avec python 2.4 le problème est le même.
Sous Gentoo, wxGTK et wxPython sont en 2.8 en stable. Cela fonctionne en 2.8 ?

Pourquoi ne pas faire une doc avec les dépendances claires parce que c'est très vague à l'heure actuelle :s
Quentin PÂRIS Jeudi 5 Juin 2008 à 18:36
Quentin PÂRIS
Admin

Donc ouai il faut wxpython2.8

Je pense qu'il te manque la librairie string de python mais je sais pas dans quel paquet elle est
volkmar Mardi 10 Juin 2008 à 13:48
volkmarAnonymous

Ca me semble assez improbable que la librairie string de python ne soit pas dans le core de python.
D'autant plus que python est très utilisé sous Gentoo donc l'installation doit être plutôt complète.
Quentin PÂRIS Mardi 10 Juin 2008 à 16:27
Quentin PÂRIS
Admin

J'ai corrigé le bug pour la prochaine version normalement.
volkmar Mardi 10 Juin 2008 à 23:41
volkmarAnonymous

J'ai corrigé le bug pour la prochaine version normalement.

Quote from Tinou

Ce serait possible d'avoir le patch pour tester ?
volkmar Mercredi 11 Juin 2008 à 9:57
volkmarAnonymous

Finalement, j'ai vu que la 3.0.2 a suivi de peu ton message et j'ai donc fait une ebuild Gentoo pour cette version et ça marche très bien !

Ce soir, je fais valider l'ebuild par l'équipe du Sunrise Overlay puis je pourrais vous envoyer un petit texte expliquant comment l'installer (pour mettre sur le site).
A quelle adresse email pourrais-je envoyer ça ?
Quentin PÂRIS Mercredi 11 Juin 2008 à 11:51
Quentin PÂRIS
Admin

tinou@playonlinux.com :-)

Super merci beaucoup en tout cas :-)
Aymeric P. Mercredi 11 Juin 2008 à 18:52
Aymeric P.
Admin

@volkmar si tu souhaite recevoir un mail (de ma part) a chaque nouvelle version (pour par exemple de rappeler que tu as un devoir de packageur ) donne moi ton adresse (par message privée)

Former member.