SimCIty 4 Deluxe won't install

Auteur Réponses
Quax Mercredi 5 Février 2020 à 14:31

Hi all, my first post here, so hello everybody! I'm running Ubuntu for some years now, and now wanted tto get SC4 Deluxe running on Linux. I bought the software on Amazon and downloaded the installation files to my NAS drive. When trying to install SC4 using PlayOnLinux, I use the "Use files from hard drive" option (or similar - I'm Austrian thus running the german version of PlayOnLinux). I then select the "setup.exe" file from the downloaded SC4 files and hit install. However, the installation process runs into an error stating the "SimCity4.exe" cannot be found, asking whether it is installed in the proper directory. Now I'm clueless how to come around this. Has anyone already installed SC$ via PlayOnLinux using the install files (not the CD)?





Dadu042 Mercredi 5 Février 2020 à 15:04

Quax Mercredi 5 Février 2020 à 17:14

Well that doesn't do anything except getting a useless starter. If I browse the wineprefix-directory, I would expect to see the SC4 installtion, but there is nuthing but the "normal" windows directories. Do the install files need to be stored locally on the PC? As I have them on a NAS currently.


Edit: or is it that I don't understand how POL works? So far I understood that POL would install the game under the ".Playonlinux/wineprefix" directory, so I alway select the "Windows" setup.exe once POL askes me to select the file. Am I wrong here?

Edité par Quax

magnesium Mercredi 5 Février 2020 à 23:20

the version you have might be from the cd.

wine setup.exe

does it ask you for the disc?

Quax Jeudi 6 Février 2020 à 19:10

Well I also tried that using the original disks. It worked up until somewhere amidst the first CD, it then seemingly hung up - at least the installation process didn't move forward for over half an hour. I didn't see the progress bar anyway, but I could watch the names of the plugins changin in the titlebar of the Win installer.


I would even buy the Stean version of SC4 if I could be sure it can be installed. However I doubt this, as anthing that seems to be easy to install for anyone else turns out to end in disaster on my end :-)

magnesium Jeudi 6 Février 2020 à 20:31

ive got the original SC4deluxe cds, and ripped them to .iso long ago.  pc no longer has a disc drive.

i just tested the PoL script with my mounted isos, and after copying the 'no-cd' exe the game is working fine.

Quax Jeudi 6 Février 2020 à 21:50

Ah .. I see .. will try



magnesium Jeudi 6 Février 2020 à 22:28

this is what worked for me.

create image files from the cds

put cd1 in the drive

cat /dev/sr0 > SC4DELUXE1.ISO

then put cd2 in the drive

cat /dev/sr0 > SC4DELUXE2.ISO

now mount the images (change USER)

sudo mkdir /media/USER/drive1
sudo mount SC4DELUXE1.ISO /media/USER/drive1 -o loop
sudo mkdir /media/USER/drive2
sudo mount SC4DELUXE2.ISO /media/USER/drive2 -o loop

in Pol,
install a program, select sim city 4 deluxe
use cd-roms
select drive1

i dont see a progress bar, but can see the filenames changing as its copying them
after a couple minutes the installer finishes and virtual desktop closes by itself.

click next, then point to drive2

copy/paste nocd



Edité par magnesium