Forums

[Anno 1404] Administrateur au lancement

Auteur Réponses
Arnaud Vendredi 30 Octobre 2009 à 15:38
ArnaudAnonymous

Bonjour tout le monde,

lors de mon premier lancement de ANNO1404 (fabuleux jeu s'il en est), on me demande d'avoir les droits administrateurs afin de pouvoir jouer...

Comment y remédier? Je ne vais quand même pas lancer le jeu en root si?

Berillions Vendredi 30 Octobre 2009 à 17:09
Berillions

Salut Arnaud,

Si je ne raconte pas de bêtise, tu n'as pas les droits en execution juste après l'installation du jeu.
Pour vérifier, va dans le dossier d'installation (si tu as PoL 3.7, clic-droit sur Anno1404 -> Ouvrir le dossier d'installation) et si tu remarques un cadenas sur l'executable du jeu (Anno4.exe), c'est que tu n'as pas les droits.

Donc en root :
cd "/home/Ton_Nom/.PlayOnLinux/wineprefix/Anno1404/drive_c/Program Files/Ubisoft/Related Designs/ANNO 1404"
chmod +x Anno4.exe

Et ca devrait fonctionner.

Edité par Berillions


Arnaud Vendredi 30 Octobre 2009 à 17:41
ArnaudAnonymous

Bonjour,

normalement, le chmod +x est déjà fait...

Je vais vérifier ça et vous tient au courant.


Merci
Berillions Vendredi 30 Octobre 2009 à 18:08
Berillions

Je ne peux pas plus t'aider car je n'ai plus le jeu...

Mais le plus simple en faite, c'est de faire en root :
chmod 777 "/home/Ton_Nom/.PlayOnLinux/wineprefix/Anno1404/drive_c/Program Files/Ubisoft/Related Designs/ANNO 1404"

Puis clic-droit sur ANNO 1404 -> Persmission, rajouter "Lecture, Ecriture" aux 3 catégories puis de cliquer sur "Appliquer les permissions aux fichiers inclus"

Je sais que c'est contraignant mais heureusement que tous les jeux ne sont pas comme ca...

Edité par Berillions


Aymeric P. Vendredi 30 Octobre 2009 à 20:28
Aymeric P.
Admin

Salut
@Berillions: Pourquoi le faire en root, que je sache PlayOnLinux fonctionne avec les droits de l'utilisateur, Wine aussi.
Donc le dossier est accessible par l'utilisateur courant pour faire le chmod.

De plus ta commande chmod ne change que le dossier spécifier et pas l'ensemble des fichiers et dossiers.
Si cette commande est obligatoire pour que le jeux fonctionne il faut l'inclure dans le script !

A+

Former member.
Berillions Vendredi 30 Octobre 2009 à 22:06
Berillions

@Mulx, Ok mais avec ce que j'ai expliqué, j'ai spécifié qu'il fallait cliquer sur "Appliquer les permissions aux fichiers inclus" dans les permissions du dossier ou l'on a effectué le chmod.

Arnaud Dimanche 1 Novembre 2009 à 20:10
ArnaudAnonymous

~/.PlayOnLinux/wineprefix/Anno1404/drive_c/Program Files/Ubisoft/Related Designs/ANNO 1404$ ll
total 68M
-rwxrwxrwx 1 arnaud arnaud 15M 2009-05-25 16:36 Anno4.exe
-rw-rw-rw- 1 arnaud arnaud 528 2009-10-30 15:15 BenchMark.xml
drwxr-xr-x 3 arnaud arnaud 4,0K 2009-10-30 14:54 bin
drwxr-xr-x 4 arnaud arnaud 4,0K 2009-10-30 15:15 data
-rw-rw-rw- 1 arnaud arnaud 51M 2009-05-25 16:36 dvm.dll
-rw-rw-rw- 1 arnaud arnaud 55 2009-10-30 15:15 Engine.ini
-rwxrwxrwx 1 arnaud arnaud 600K 2009-04-01 17:29 gu.exe
drwxr-xr-x 2 arnaud arnaud 4,0K 2009-10-30 14:59 maindata
drwxr-xr-x 9 arnaud arnaud 4,0K 2009-10-30 14:54 Resources
drwxr-xr-x 2 arnaud arnaud 4,0K 2009-10-30 14:54 support
-rw-rw-rw- 1 arnaud arnaud 1,5M 2009-05-25 16:36 TagesClient.dat
-rwxrwxrwx 1 arnaud arnaud 452K 2009-05-23 13:54 TagesClient.exe
drwxr-xr-x 2 arnaud arnaud 4,0K 2009-10-30 14:54 tools

Citer


Je crois que c'est on ne peut plus clair...

Mais toujours le message d'erreur. Il faut être assimilé "Administrateur"
Aymeric P. Dimanche 1 Novembre 2009 à 22:56
Aymeric P.
Admin

Salut,
Je pense que le problème vient de Wine et/ou de l'application, mais pas des droits d'accès aux fichiers.
Est ce que tu peux essayer en utilisant une autre version de Wine pour lancer le programme ?
Sinon il faut peut être simuler un autre système d'exploitation (plus récent ou plus vieux).
Sur la page de Wine pour cette application il est souvent dit "dbghelp.dll needs to be set native in winecfg.
", peut être que ça résoudra le problème...

Ce ne sont que des idées et pas une réponse.
A+
Aymeric
(Wine AppDB)

Former member.
Arnaud Dimanche 1 Novembre 2009 à 23:23
ArnaudAnonymous

Bonjour,

j'ai utilisé une autre version de Wine, idem. Le jeu? Je l'ai déjà installé sur le disque dur Vista...
J'ai changé le système d'exploitation par XP (au cas ou), j'ai également vérifié que la DLL dbghelp soit présente, ce qui est manifestement le cas...

Je pense que le problème vient du système de protection TAGES :(

Peut-être le port 1100 qu'il utilise est bloqué / fermé, n'autorise pas TAGES a communiquer certaines données au serveur, mais comment savoir si le souci vient bien de là? Je ne sais pas :(
Emocaplin Lundi 25 Février 2013 à 18:28
EmocaplinAnonymous

(EDIT: désolé pour le déterrement de topic, mais je souhaitais à rendre cette solution publique :) )

Bonjour,

Ayant eu récemment l'exact même problème de pilotes TAGES sur mon beau jeu Anno 1404, je n'ai pas réussi à trouver sur le net de solution valables.

Mais (car heureusement il y a un mais), j'ai décidé de patcher mon jeu à la dernière version et le jeu démarrait enfin !

Je te conseille donc de faire de même en téléchargeant les patchs 1.1 et 1.2 (qu'il faut appliquer un à un), en espérant que c'est le nœud du problème chez toi !

Cordialement, Emocaplin :)

Edité par Emocaplin