Forums

Rapport de bug

Prefix Backup plugin by Mulx

Auteur Réponses
Jump to the page: 1 - 2
billou Dimanche 8 Novembre 2009 à 11:22
billou

Hello, je viens rapporter quelques problèmes de conception, concernant le préfix backup, qui permet de sauvegarder un préfixe, pour le restaurer par la suite avec un simple paquet pol.

Pour ce faire, j'ai effectué un test avec un script simple, celui de 7zip (mais j'ai également testé avec d'autres)

Il se trouve que j'ai deux ordinateurs, sur lequel je voudrais installer le même jeu... Et simplement restaurer le préfixe ferait gagner du temps sur les manips.

Hors c'est impossible, j'ai fait le test, et bien que la restauration soit effectuée, le préfixe restauré ne peut fonctionner qu'avec la session utilisateur originale.

Exemple avec deux sessions, une nommée test1, l'autre test2 :

1 : Je fait un backup avec le plugin prefix backup sous POL, qui sera sauvegardé dans /tmp

2 : Je change de session, pour passer sur test2 et je lance POL

3 : Je tente d'installer le backup via l'installation d'un paquet POL

4 : La restauration s'effectue avec succès, mais impossible de lancer 7zip

5 : Je tente d'ouvrir alors le dossier d'installation depuis POL, ce dernier m'amène dans le dossier d'installation de la session test1

6 : Je vais manuellement dans le dossier d'installation du 7zip restauré dans la session test2, le préfixe est bien présent.

7 : Je vais jeter un oeil sur le script permettant d'executer le préfixe restauré dans la session test 2, je tente de le lancer et j'obtiens :

test2@ordinateur:~$ '/home/test2/.PlayOnLinux/configurations/installed/7-zip'
wine: /home/test1/.PlayOnLinux/wineprefix/7zip is not owned by you

8 : Je jette un oeil au script en question dont le contenu est :

#!/bin/bash
export WINEPREFIX="/home/test1/.PlayOnLinux/wineprefix/7zip"
export WINEDEBUG="-all"
cd "/home/test1/.PlayOnLinux/wineprefix/7zip/drive_c/Program Files/7-Zip/"
wine "7zFM.exe" $@

9 : Je tente de remplacer ce qui n'a pas été corrigé, à savoir passer test1 en test2 et là je réessaie de lancer le script, et ça fonctionne.


Voilà, j'espère que j'aurais été assez clair pour que les problèmes puissent être résolu et le plugin corrigé =)


Edit : Le lien vers le topic officiel du plugin : http://www.playonlinux.com/fr/topic-2329-plugin_Prefix_Backup.html

Edité par billou

Aymeric P. Samedi 14 Novembre 2009 à 23:02
Aymeric P.
Admin

Ah oui,
Effectivement spa normal ça.

J'essayerais de corriger ça dans le courant de la semaine.

J'avoue ne pas avoir du tout penser à l'hypothèse où la backup ne serait pas restauré par le même utilisateur.
Vu que j'ai deux machines avec le même nom d'utilisateur j'ai jamais eu de soucis.

Former member.
billou Lundi 16 Novembre 2009 à 10:22
billou

Merci MulX =)

Faut dire que forcément, ça sera plus pratique, surtout pour accélerer les procédures d"installation de jeux en réseau, et en simplifier l'installation sous Nux.

Par contre, juste un petit souci, il semblerait que le plugin ne se lance pas toujours dans le cas de préfixes créé à l'arrache, sans script.

J'ai installé Oddworld l'exode d'abe via un script non officiel, ça avait fonctionné, mais pour l'odyssée d'abe, que j'ai installé manuellement, d'un via un clic droit sur le préfixe, impossible d'accéder au dossier correspondant au préfixe (rien ne se passe), de deux, ton plugin ne fonctionne pas :-/
billou Lundi 23 Novembre 2009 à 3:27
billou

Toujours rien en vue? :(
Aymeric P. Mardi 24 Novembre 2009 à 18:28
Aymeric P.
Admin

Concernant le premier problème c'est en théorie corrigé, merci de signaler si j'ai fait n'impot' quoi, mais je ne pense pas.

Concernant le deuxième, pas trop compris, mais je ne peux malheureusement pas tester.

Former member.
billou Mardi 24 Novembre 2009 à 23:11
billou

Salut, je viens de tester ta mise à jour, ça ne fonctionne pas.

Une fois le pol créé, quand je le restaure, j'ai une entrée "export" dans PlayOnLinux et rien d'autre, et y'a rien dans ce lanceur créé (le fichier "export" est vide)

J'aurais aimé que ça soit prêt pour l'install party ubuntu le 28, mais j'imagine que ça ne sera pas le cas, dommage.
Aymeric P. Jeudi 26 Novembre 2009 à 18:54
Aymeric P.
Admin

Mais si, Mais si !
J'ai retrouvé un PC sous Linux, j'ai scouaté cette après midi, et voilà, là ça devrait être bon :)
Je n'ai fait mes tests qu'avec une seule application d'installé, mais je pense pas que ça pause de problème si il y a plusieurs lanceurs.

Former member.
billou Samedi 28 Novembre 2009 à 22:47
billou

J'ai testé, le paquet pol est créé, (testé avec WorldOfGoo version Windows, que j'avais payé le jour des "soldes" ^^ )

Voilà le résultat de A à Z :

ubuntu@ubuntu:~$ playonlinux
PlayOnLinux v3.7.2

Checking python :                     [ Ok ]

(python:372): Gtk-WARNING **: Theme directory 96x96/action of theme icons_dream-blue has no size field

Running install menu
Gestionnaire de paquet PlayOnLinux 3.7.2

(python:554): Gtk-WARNING **: Theme directory 96x96/action of theme icons_dream-blue has no size field

/usr/share/playonlinux/playonlinux-pkg: line 63: [: trop d'arguments


En fait je sélectionne le *.pol à installer, je clique sur suivant... Et rien !

Retour sur l'interface POL, rien ne se passe, rien d'installé.

Tu pense pouvoir trouver le problème?

Edité par billou

Aymeric P. Dimanche 29 Novembre 2009 à 10:26
Aymeric P.
Admin

Euh, je viens de refaire un test avec Notepad++ (j'ai pas WoG - surtout qu'il existe pour linux, et j'ai pas une connexion Internet super rapide), bref je suis désolé, mais j'ai aucun problème chez moi.

Je pense savoir pourquoi, le nom de ton paquet pol créé contient au moins un espace ?

Former member.
billou Dimanche 29 Novembre 2009 à 15:02
billou

Oui, et je viens d'essayer de multiples fois sur plusieurs logiciels jeux, le changement d'utilisateur/PC fonctionne bien, mais effectivement, le problème que j'ai cité ne fait apparition que dans les préfixe dont le nom contient un ou plusieurs espaces.
billou Samedi 5 Décembre 2009 à 1:06
billou

up?
Berillions Samedi 5 Décembre 2009 à 9:16
Berillions

Bah crées des prefix qui n'ont pas d'espace et ton problème sera résolu...

Quentin PÂRIS Samedi 5 Décembre 2009 à 13:49
Quentin PÂRIS
Admin

Ouai en principe, je sais pas si c'est toujours écrit sur la doc, mais les préfixes ne doivent pas contenir d'espaces
billou Samedi 5 Décembre 2009 à 14:35
billou

Pourtant dans les faits, certains préfixes créés à partir des scripts mis à disposition par le projet POL, contiennent des espaces ! :-/
Quentin PÂRIS Lundi 7 Décembre 2009 à 12:59
Quentin PÂRIS
Admin

Euh tu peux me dire quels scripts please ?
billou Lundi 7 Décembre 2009 à 14:56
billou

World of Goo version windows en est un exemple, j'ai aussi vu pour Mozilla firefox 1.5, en gros, tous les préfixes dont les noms apparaissant dans POL, contiennent un ou plusieurs espaces.

Et y'en a un bon paquet. proposé dans le dépôt des scripts.

Edité par billou

Quentin PÂRIS Lundi 7 Décembre 2009 à 16:42
Quentin PÂRIS
Admin

Ah non ya pas d'espace dans Mozilla Firefox 1.5

Le prefixe s'apelle bien Firefox1.5
billou Mardi 8 Décembre 2009 à 16:31
billou

Le préfixe (nom du dossier) s'appelle effectivement Firefox1.5, ça je suis d'accord, mais ce n'est pas ça qui fout le bordel.

Le problème se situe au niveau du nom du script dans ce dossier là :

~/.PlayOnLinux/configurations/installed

C'est de ça que je parle, c'est ça qui empêche le bon fonctionnement de la restauration du paquet POL créé à partir du plugin prefix backup, quand le nom du script contient un espace. (celui là même qui laisse apparaître le nom dans la liste de POL)

C'est un peu confus j'avoue... On a tendance à appeler ce qui est listé dans PlayOnLinux des préfixes, alors que ce sont des scripts qui utilisent des préfixes, et wine... Enfin bref, j'espère que c'est plus clair, le problème ne vient pas des dossiers correspondants à chaque préfixe, mais du nom du script du préfixe, qui s'il contient un espace, empêche la restauration du backup sous forme de paquet *.pol.

Je viens à l'instant de refaire un test avec Mozilla Firefox 1.5, quand je laisse tel quel le nom du script, avec espaces, rien n'est restauré, quand je vais dans le dossier "installed" pour renommer le script et en enlever les espaces, que j'en fait un backup et que je tente de le restaurer, ça fonctionne.

Edité par billou

Aymeric P. Mardi 8 Décembre 2009 à 21:04
Aymeric P.
Admin

Hum étrange, il me semblait avoir pris en compte ce problème.

Peut tu lancer POL, puis le script depuis une console.

Si il y a des messages d'erreurs, poste les ici.

Merci d'av'.

Former member.
billou Mercredi 9 Décembre 2009 à 4:29
billou

Pour la restauration en laissant les espaces dans le nom des scripts (ici avec firefox 1.5)

billou@my-laptop:~$ playonlinux -v
PlayOnLinux v3.7.2
Checking python :                     [ Ok ]
Running install menu
Gestionnaire de paquet PlayOnLinux 3.7.2
/usr/share/playonlinux/playonlinux-pkg: line 63: [: trop d'arguments

Citer


Pour la restauration, une fois le script renommé (sans espaces) :

billou@my-laptop:~$ playonlinux -v
PlayOnLinux v3.7.2
Checking python :                     [ Ok ]
Running install menu
Gestionnaire de paquet PlayOnLinux 3.7.2
Opening /tmp/MozillaFirefox1.5.pol
Extracting /tmp/MozillaFirefox1.5.pol...
Running ...
Cleaning ...

Citer



Autre chose étrange d'ailleurs, en laissant le script avec espace, le backup (impossible à restaurer) fait 8,6Mo, tandis qu'en renommant afin de supprimer les espaces, le backup (qui se restaure sans soucis) fait 9Mo
Simple coïncidence ou c'est le signe que quelque chose cloche quelque part?


Edit :

Autre "erreur" remarquée, n'affectant pas vraiment le prefixe firefox 1.5 (renommé pour être sans espaces) restauré, le script ne dispose d'aucun droit d'exécution (ni propriétaire, ni groupe, ni autres) à contrario des autres scripts, ce qui ne l'empêche toutefois pas de s'exécuter correctement, si je le lance via l'interface PlayOnLinux.

Après avoir chmodé un peu le script pour ré-activer le droit d'exécuter ce dernier par le propriétaire (moi :p) voici le résultat obtenu, via le terminal :

billou@my-laptop:~$ '/home/billou/.PlayOnLinux/configurations/installed/MozillaFirefox1.5'
wine: configuration in '/home/billou/.PlayOnLinux/wineprefix/Firefox1.5' has been updated

Citer

Edité par billou

Vous êtes ici: Index > PlayOnLinux > Rapport de bug