Forums

[Bugs] Problèmes multiples

Actualisation, Installation et Options

Auteur Réponses
Whidou Samedi 6 Mars 2010 à 21:18
WhidouAnonymous

Bonjour,

J'ai récemment installé PoL 3.7.3 sur mon ordinateur portable équipé d'Ubuntu GNU/Linux 9.10 (kenel 2.6.31-20-generic), Python 2.6.4 et pywxgtk 2.6 et 2.8, mais certains bugs que je n'avais jamais rencontré auparavant sont apparus, et persistent même après plusieurs réinstallations du logiciel :

- Lorsque j'actualise le dépôt via Fichier > Actualiser le Dépôt, Une boîte de dialogue sans texte s'ouvre, seulement munie d'un bouton "Suivant". Le cliquer ferme la fenêtre mais ne semble pas actualiser quoi que ce soit. La sortie affiche juste
Running update menuCe qui a l'air normal.

- Lorsque j'essaie d'installer un Logiciel en cliquant sur Installer ou en passant par Fichier > Installer, l'Assitant d'installation s'ouvre mais ne me laisse le choix qu'entre "Installation manuelle" ou "Installer un paquet .pol". Je ne peux pas accéder à la liste des applications. La sortie affiche
Running install menuCe qui a également l'air normal.

- Lorsque je tente d'accéder à un élément du menu Options ou au Gestionnaire de Plugins, rien ne se passe mais j'obtiens le message d'erreur suivant en sortie :
Running options
Traceback (most recent call last):
File "/usr/share/playonlinux/python/options.py", line 480, in <module>
app = PlayOnLinuxApp()
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7978, in __init__
self._BootstrapApp()
File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7552, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "/usr/share/playonlinux/python/options.py", line 472, in OnInit
self.frame = MainWindow(None, -1, _("PlayOnLinux Settings"))
File "/usr/share/playonlinux/python/options.py", line 423, in __init__
self.onglets.Internet(_("Internet"))
File "/usr/share/playonlinux/python/options.py", line 145, in Internet
self.OffLineCheck.SetValue(1)
AttributeError: 'Onglets' object has no attribute 'OffLineCheck'
Ce qui est déjà moins normal.

J'ai installé et réinstallé PoL par le dépôt deb.playonlinux.com et la totalité de ses dépendances sont satisfaites.

Sauriez-vous comment je pourrais régler ce problème ?

Merci d'avance.
Quentin PÂRIS Samedi 6 Mars 2010 à 21:27
Quentin PÂRIS
Admin

Étrange que tu es ce problème la.

Il semblerait que POL fonctionne en mode hors ligne (ancien mode qui n'est plus fonctionnel)

Tapes : rm $HOME/.PlayOnLinux/configurations/options/offline pour régler le problème
Whidou Samedi 6 Mars 2010 à 21:34
WhidouAnonymous

Ça marche, merci beaucoup.