Starcraft II install problems

Auteur Réponses
Quafadas Jeudi 2 Décembre 2010 à 21:49


Any help or clarification much appreciated :-). I have purchased (optimistically) SC2, in digital download form. When I press the install, going through the installer, it appears to install instantaneously (doesn't download anything), and places an icon on my desktop (and in play on linux). Neither works ( no surprise as 7Gb doesn't download quite that quickly!!!). I have tried removing the install and then re-installing... without sucess.

I have only ubuntu, no other nasty windows installs... 'about' tells me it's 'You are using Ubuntu 10.04 LTS - the Lucid Lynx - released in April 2010 and supported until April 2013.' I believe I have the 64-bit install - is this a problem?

I believe I have the latest version, PlayOnLinux 3.8.6, of this software. Have tried a few things now... installing as unsupported package, standard script, etc etc.

Is there any other help I can offer here?

Any help greatly appreciated,
Kind Regards,
GNU_Raziel Jeudi 2 Décembre 2010 à 23:20

What do you mean by downloading ??
I saw the digital installer once, it's a full client of 7Gb, not only a small executable.
Perhaps you talk about the online installer, if it's the case, forget it, download the full one, it's aviable in , torrent form.
Quafadas Jeudi 2 Décembre 2010 à 23:45


Hmmm, think we are talking at cross purposes... perhaps I should describe my process more carefully - I know that the download is 7Gb, however I don't think it starts it - I never see the Blizzard downloader that I see in some of the online talks.

- I open PlayOnLinux
- Press Install
- type starcraft
- select Starcraft II wings of Liberty
- New dialog opens
- Press forward
- choose digital download
- select the exectuable downloaded from the blizzard website on my desktop called 'StarCraft_2_EU_en-GB.exe'
- it says 'intsallation in progress'
- Asks me for graphics card memory
- asks about shortcuts
- tells me it's been installed sucessfully.

Elapsed time - 30 seconds... doesn't feel right... perhaps my mistake is selecting the GB.exe file from the blizzard website. I'll have a look around for the torrent you describe... is that the right strategy?

Thanks for looking at this,

Kind Regards,

GNU_Raziel Vendredi 3 Décembre 2010 à 1:48

hhhuummmm...I made a small modification to the POL installer, test and tell me if it's better.

Be also sure that your exe is working because last time I tried Digital install, it worked like a charm.
Quafadas Vendredi 3 Décembre 2010 à 9:17

Opened play on Linux,
Updated the repository
install starcraft...
There is now a screen which says don't press next until the game is installed, otherwise you'll have to redo it. However there is no evidence of any installation going on. Looking in the system monitor I can't see any process activity on either POL or see any evidence of a child thread with the download started etc...

I've got two versions of the installer from the Blizzard website... one called;
Both appear to have exactly the same number of bytes in...

I'll try and test the exe by running it wine in wine through the console and running it from there...
Quafadas Vendredi 3 Décembre 2010 à 9:26

Copied executable to c:\\ on wine and renamed for ease.
run in console via; #wine c:\\SC2.exe

This strategy yields the blizzard downloader window, and subsequently a nasty looking exception - 'The program SC2 has encountered a serious problem and needs to close."
Clicking through it gets me to a directory selection, I can't make a new folder (button doesn't work), so I've simply clicked on a random folder.
At this stage i have a window for the Blizzard downloader (which appears to have crashed) - the system monitor tells me it's a 'zombie' thread so I force kill it, and am back to the start again (apparently!). Thanks for your continued help and interest...

GNU_Raziel Vendredi 3 Décembre 2010 à 12:56

I've reverted back last change since it's not the problem.

Apparently there is a problem with latest Ubuntu Kernel and Blizzard Updater.
Please try this command before installing :

echo 0 | sudo tee /proc/sys/kernel/yama/ptrace_scope

Be also sure that the installer in on a linux partition, not a FAT32 one or an NTFS one.

Also note that ATI/AMD make game unplayable (even the installer hang) and Intel GMA cards do not work at all for this game.

So if you're using Nvidia card, be sure to use latest driver available (260.19.21) and if you're using AIT/AMD card, try the latest fglrx driver (10.10 I think), people had some luck installing/launching SC2 with it.
Quafadas Vendredi 3 Décembre 2010 à 14:53


After some trouble I think I've got the lastest nvidia drivers installed and working. The graphics card is a GeForce 8400GS (I'm not expecting much from it, but I believe it should work).

I still can't start the download. The echo command above produces the following results...

simon-desktop:~$ echo 0 | sudo tee /proc/sys/kernel/yama/ptrace_scope
[sudo] password for simon:
tee: /proc/sys/kernel/yama/ptrace_scope: No such file or directory

Kind Regards,
Quafadas Vendredi 3 Décembre 2010 à 15:10

Another update. After the above I've got to the stage of being able to see the downloader by installing the package manually... I can't see that the POL script initiates anything.
Life is not perfect as it asks me for a directory (I can't create one so I've opted for 'temp') and the picture says 'grats. You broke it' this page does not exist or a horrible error has occured.'

Still, it appears to be downloading so I think I'm going to leave it and see what it throws up next (am not all that hopeful!)

Kind Regards,
Quafadas Dimanche 5 Décembre 2010 à 17:42

This is just a nightmare.

By 'installing a package manually' I've finally manage to actually see the blizzard downloader, download and install the game. However it doesn't run - I suspect this is because WINE is incorrectly configured. SC2 appears as a shortcut on the desktop, but it isn't the list of programs in POL.

The POL script is still unsucessful (tried launching it again). Installation completed happens in about 5 seconds (not right)...

Does anyone have an ideas?

Kind Regards,
Quafadas Dimanche 5 Décembre 2010 à 18:34

Am giving up... looks like SC2 is a windows only game for me :-(.
GNU_Raziel Dimanche 5 Décembre 2010 à 18:55

I'm sorry for you...Since I cannot reproduce your bug I cannot help more.
morimando Jeudi 17 Février 2011 à 17:45

I got it running. Well, crudely so:
Every time the percentage (of downloaded data) freezes, I kill the Blizzard Downloader process (killall BlizzardDownloa)
After several kills (StarCraft launcher restarts the Downloader), the download is complete.
I daresay this is a very bad workaround.
I noticed that the timespan for which the Downloader works seems random, though it seldomly exceeds 10 secs. (It works although wine says it crashed, some seconds after that, it crashes for real)
Also: It always crashes when only about 100kbytes are left to download and immediately after it reaches 0.0KB
betwixt killing the Downloader I had to remove 24160-torrent and -dl file, to make StarCraft launch again (it crashed)