Call of Duty: Black Ops won't install or run

Auteur Réponses
geekzilla Mardi 15 Février 2011 à 4:01

My post is almost identically related to this one:

I am having the hardest time trying to install the DVD version of COD Black Ops. I have tried using Ubuntu / Kubuntu 10.04 and 10.10 and 32 and 64 bit. I've also tried the newest version of POL 3.8.8 as well as earlier versions...all the same result.

The DVD version of COD Blacks Ops automatically installs Steam right from the start. The install seems to go perfect with the exception of never being prompted to install DirectX at all even at the end, although it is on the disc. I go back and install it manually from the disc and also tried through winetricks.

Here's the problem. After the install completes you have the game listed in Steam and in Playonlinux. Where are you supposed to run the game from...Steam or POL? Regardless neither work. When I run the game from POL I get an error that states "The program BlackOps.exe has encountered a serious problem and needs to close. We are sorry for the inconveniece. This can be caused by a problem in the program or a deficiency in wine. You may want to check for tips about running this applicaiton. If this problem is not present under Windows and has not been reported yet, you can report it at"

When I attempt to run the game from Steam I first get a message stating "Completing Installation...1%. But it never gets past 1%. Then I get an error message that states: "Incomplete Installation of Call of Duty: Black Ops (2)."

Does anyone know what I'm doing wrong here? I've even tried wiping the local data out of Steam and downloading the game from Steam with no success. As I type this I'm using Kubuntu 10.04 LTS. I have different boxes with different distro's so switching around isn't an issue. My hardware is above standard and shouldn't be an issue either. Any suggestions are welcome.
geekzilla Mardi 22 Février 2011 à 2:17

No one? Really?
soilure Mercredi 2 Mars 2011 à 4:50

Geek, have you had any luck? I'm getting the same thing. I tried installing it with Wine instead of POL and it runs like arse.

geekzilla Mercredi 2 Mars 2011 à 19:44

Sorry, no new info. I've tried everything I can think of. I'm surprised no one has a solution for this. I know other people have got it to work with Ubuntu 10.04 and 10.10. There has to be more people that have run into this issue.
jwiesmann Samedi 5 Mars 2011 à 21:30

you may try this: