Forums

The Elder Scroll III - Morrowind

Jeu principale

Auteur Réponses
Jump to the page: 1 - 2 - 3
Tutul Vendredi 29 Octobre 2010 à 16:58
Tutul
Modérateur

Lors du démarage du script, on rencontre déjà un message d'erreur qui n'empeche pas l'application de fonctionner (donc pas dérangerant). Ensuite, lors du lancement de l'installation, on à un message d'erreur de wine qui s'affiche mais qui ne bloque rien :
Le programme winemenubuilder.exe a rencontré un problème sérieux et doit être fermé. Nous somme désolés pour le désagrément subi. Enfin, si on lance le jeu, on a une fenêtre qui apparait : Impossible de trouver un lecteur de CD-ROM/DVD sur cet ordinateur. et le programme se plante or le CD est affiché sur le bureau et il est correctement utilisé par le script pour l'installation. Serait-il possible que le problème vienne du lecteur ou c'est wine qui n'aime pas le CD °_°
Sur PC, je n'ai jamais vu ça avec ce jeu (et c'est le même CD).
Pour toute question sur la machine utilisé, demandé à Machallan (c'est chez lui qu'on a tester). Merci d'avance.

PS : le script se trouve dans Testing si vous voulez allé le voir.

Edité par Tutul


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Quentin PÂRIS Vendredi 29 Octobre 2010 à 17:00
Quentin PÂRIS
Admin

Salut,

Est ce que POL est à jour ?
Tu peux me donner la liste des fichiers sur le CD ?
Tutul Vendredi 29 Octobre 2010 à 17:09
Tutul
Modérateur

Machallan va tester se soir (ou les jours prochain) avec la nouvelle version et sinon sur le cd il y a :

-AutoRunMorrowind.exe
-DX81frn.exe
-DX81NTfrn.exe
-Setup.exe
DrvMgt.dll
-layout.bin
-Setup.bmp
-ikernel.ex_
-data1.hdr
-setup.inx
-Secdrv.sys
-autorun.inf
-Setup.ini
-data1.cab
-data2.cab
-Le dossier des videos du jeu
-Le dossier avec le manuel du jeu en format pdf
-Le dossier d'installation de l'éditeur avec :


-Setup.exe
-layout.bin
-setup.bmp
-ikernel.ex_
-data1.hdr
-setup.inx
-Setup.ini
-data1.cab
-data2.cab


Les installations se passe sans problème mais on à le même soucis que si on installe sans le script (application non supportée).

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Quentin PÂRIS Vendredi 29 Octobre 2010 à 17:21
Quentin PÂRIS
Admin

On dirait que vous n'avez pas le CD officiel, c'est pour ça que ça ne marche pas
Tutul Vendredi 29 Octobre 2010 à 17:27
Tutul
Modérateur

Ce CD est ma copie du CD original de Morrowind (qui commençait à se faire vieu donc abimé), mais sa ne devrait pas faire sa normalement. Et sur PC il fonctionnait parfaitement il y a 3 mois (temps depuis lequel je n'ai plus de PC).

Edité par Tutul


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Quentin PÂRIS Vendredi 29 Octobre 2010 à 17:32
Quentin PÂRIS
Admin

Oh excuse moi !

Je m'étais fixé dans la tête que vous essayez Oblivion ! Donc je trouvais ça bizarre qu'il y ai des fichiers de Morrowind dans le CD d'Oblivion :S

Donc pour ton problème regarde si tu peux faire quelque chose au niveau de "Configurer cette application" -> "Configurer wine" (En gros vérifies que les lecteurs sont bien mis)
Tutul Vendredi 29 Octobre 2010 à 17:36
Tutul
Modérateur

On va tester et je vous dirait quoi plus tard. Merci :D

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Machallan Lundi 1 Novembre 2010 à 22:59
Machallan

Bon...
Il y a de gros gros progrès!

J'ai lancé le configurateur de Wine, réglé le CD comme CD et non comme détecté automatiquement, appliquer, ne PAS fermer le configurateur, sinon il perd les réglages... Lancement du jeu, fonctionne seulement en plein écran donc avec XQuartz de PoM... Pas de problème notable, jusqu'au menu... Les choix sont absolument illisibles et le curseur ne ressemble à rien... Comme je connais le menu pat coeur, je clique sur nouvelle partie... Pas de problèmes jusqu'à ce qu'on soit dans le jeu en lui-même... Image caca, pixels de couleurs partout => Ma carte graphique semble modérément compatible avec XQuartz... Bon, ça reste testable malgré tout... Je vais jusqu'à la trappe de sortie du bateau et au lieu du chargement de zone BAM! Morrowind a rencontré une erreur et doit fermer BlaBlabla...

Il faudrait que quelqu'un puisse le tester avec une carte graphique compatible

( \_/ )
(='.'=) Memento Mori Per Non Amnes Vivere
(")_(")
Suivez-moi si j'avance!
Tuez-moi si je recule!
Vengez-moi si je meurs!
Quentin PÂRIS Lundi 1 Novembre 2010 à 23:43
Quentin PÂRIS
Admin

Quelle carte graphique ?

Sinon essais de "Forcer le serveur X11 Apple" et regler le jeu en mode fenêtre dans le configurateur de wine
Machallan Mardi 2 Novembre 2010 à 14:06
Machallan

950 GMA sur mon portable, Je vais tester sur l'IMac de bureau... Peut-être que cette carte là est compatible

Rien à faire, il tien à son mode plein écran, dans les options via le Launcher du jeu on peut régler plein écran ou fenêtré mais en fenêtré, il ne veut plus se lancer du tout, que ce soit avec X11 ou Xquartz

je teste et je ferais suivre le rapport

( \_/ )
(='.'=) Memento Mori Per Non Amnes Vivere
(")_(")
Suivez-moi si j'avance!
Tuez-moi si je recule!
Vengez-moi si je meurs!
Quentin PÂRIS Mardi 2 Novembre 2010 à 14:35
Quentin PÂRIS
Admin

Pour le mode fenêtre, utilise "Fix OSX OpenGL - Disable fullscreen" dans le menu install. Le jeu n'y verra que du feu.

Il y a souvent des problèmes avec les cartes GMA j'ai remarqué
Machallan Mercredi 3 Novembre 2010 à 10:44
Machallan

J'ai réussi à le faire démarrer en mode fenêtre Le menu reste illisible, que ce soit avec X11 ou Xquartz, pas de changement notable avec XQuartz, au premier changement de zone il plante et l'image est toujours aussi dégeu... Avec X11, il plante à la génération du tout premier intérieur (pour ceux qui connaissent, il y un rêve puis on se retrouve dans le bateau prison. Le rêve se déroule correctement mais tout de suite après, erreur, Morrowind.exe a rencontré un problème et doit fermer...



Uploaded with ImageShack.us

Avec Xquartz, au moment de l'erreur




Uploaded with ImageShack.us

Même problème avec le TESCS; que je le lance avec X11 ou XQuartz


EDIT:Hum, désolé pour la taille de la première photo...

Edité par Tinou


( \_/ )
(='.'=) Memento Mori Per Non Amnes Vivere
(")_(")
Suivez-moi si j'avance!
Tuez-moi si je recule!
Vengez-moi si je meurs!
Quentin PÂRIS Mercredi 3 Novembre 2010 à 11:17
Quentin PÂRIS
Admin

Déjà n'utilise pas l'icône du bureau pour commencer

T'as moyen de tester avec autre chose qu'une carte GMA ?
Tutul Vendredi 5 Novembre 2010 à 23:23
Tutul
Modérateur

Si sa ne fonctionne pas, il faudra peut-être regler le programme graphique.
Quand penssez-vous ???

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Quentin PÂRIS Samedi 6 Novembre 2010 à 19:24
Quentin PÂRIS
Admin

Tu peux essayer la version de wine 1.2.1-cxg ?
Machallan Dimanche 7 Novembre 2010 à 11:06
Machallan

Je vais voir... J'éditerai ce message quand il y aura du neuf

( \_/ )
(='.'=) Memento Mori Per Non Amnes Vivere
(")_(")
Suivez-moi si j'avance!
Tuez-moi si je recule!
Vengez-moi si je meurs!
Tutul Dimanche 7 Novembre 2010 à 11:57
Tutul
Modérateur

Si sa marche, Tinou il faudra que vous (les admin) modifiés la version de wine demandé pour les scripts.

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Quentin PÂRIS Dimanche 7 Novembre 2010 à 12:00
Quentin PÂRIS
Admin

Il faudrait que tu test ton script avant que je le valide (Et si je pouvais avoir la confirmation qu'il marche sous linux ce serait vraiment impec)
Tutul Dimanche 7 Novembre 2010 à 12:11
Tutul
Modérateur

Je vais voir pour cela.
Pour le checkexist c'est bien comme ça ???
Tu as une recommandation pour tester sous linux (quelle OS est le meilleur pour cela selon toi ???), Tribunal et Bloodmoon n'ont pas été tester sous mac ni Linux (il faudra attendre pour eux).

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Quentin PÂRIS Dimanche 7 Novembre 2010 à 12:17
Quentin PÂRIS
Admin

Je pense que ta fonction doit marcher oui mais c'est plus simple de faire un

[ ! -e $REPERTOIRE/wineprefix/$PREFIX ] && POL SetupWindow_message "Le jeu n'est pas installé" && POL_SetupWindow_Close && Exit

(Avec les traductions)

Sinon POL fonctionne sur toutes les distribs normalement. Moi perso je le test sur ubuntu depuis le début mais caninical commence un peu à faire n'importe quoi. Donc je te conseille quand même Ubuntu, mais tu peux avoir des surprises sur la dernière version (Télécharges bien POL depuis le site officiel, ne prend pas la version fournit avec ubuntu)