Forums

Can't open MS Office 2007 documents from file manager

Auteur Réponses
Jump to the page: 1 - 2
linuxdudeguy Mercredi 31 Aoüt 2011 à 15:39
linuxdudeguyAnonymous

Yep I get

$ /home/../.playonlinux/wine/linux-x86/1.2.3/bin/wine winepath -w $PW
bash: /home/../.playonlinux/wine/linux-x86/1.2.3/bin/wine: No such file or directory

How is that possible ? ;)
Quentin PÂRIS Mercredi 31 Aoüt 2011 à 15:56
Quentin PÂRIS
Admin

Try

$HOME/.playonlinux/wine/linux-x86/1.2.3/bin/wine winepath -w $PWD
linuxdudeguy Mercredi 31 Aoüt 2011 à 16:15
linuxdudeguyAnonymous

Sorry I tried that again, the line should be /home/./PlayOnLinux/wine/../ now I get nothing when I type that in. I also tried opening a file with a name with no spaces and it opens !

But any file name with spaces doesn't open.

I tried that new one I get

$HOME/.PlayOnLinux/wine/linux-x86/1.2.3/bin/wine winepath -w $PWD
err:mshtml:check_version Could not open VERSION file
err:mshtml:check_version Could not open VERSION file
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/../.wine' has been updated.
Z:\\media\\sda7\\Documents

Just updated to 4.0.11 had to run the command again, now I can't open any files from file manager.

But running this opened the file with no spaces from the command line

$ playonlinux --run "Microsoft Word 2007" "$(winepath -w $PWD)/Document.docx"

Edité par linuxdudeguy

linuxdudeguy Mercredi 31 Aoüt 2011 à 17:02
linuxdudeguyAnonymous

OK this looks more promising

$ playonlinux --run "Microsoft Word 2007" "$(winepath -w $PWD)\\Document.docx"
err:menubuilder:WinMain unknown option -a
err:menubuilder:WinMain unknown option -r
[POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.2.3, x86
[POL_Wine_SetVersionEnv] Message: "/home/../.PlayOnLinux//wine/linux-x86/1.2.3" exists
[POL_Wine] Message: Running wine-1.2.3 WINWORD.EXE Z:\\media\\sda7\\Documents\\Document.docx
rm: cannot remove `*': No such file or directory
[POL_Wine] Message: Wine return: 0

This opened the document.

Edité par linuxdudeguy

linuxdudeguy Mercredi 31 Aoüt 2011 à 17:17
linuxdudeguyAnonymous

I tried this command again since the path looks right now and I get

$ playonlinux --run "$PWD/Document.docx"
bash: /home/../.PlayOnLinux/shortcuts//media/sda7/Documents/Document.docx: No such file or directory
rm: cannot remove `*': No such file or directory

What the hell is going on ?
devauda Vendredi 2 September 2011 à 9:52
devaudaAnonymous

Hi linuxdudeguy,

Do you have any solution on this problem?
linuxdudeguy Mercredi 14 September 2011 à 7:52
linuxdudeguyAnonymous

Hi linuxdudeguy,

Do you have any solution on this problem?

Quote from devauda


Yep, install Ubuntu. It just works, open with the option "Open With Microsoft Office Word".
bruschetti Mercredi 9 Novembre 2011 à 23:47
bruschettiAnonymous

I have the same problem. When I run

playonlinux --run "Microsoft Word 2007" DOCUMENT


which: no shasum in (/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin)
which: no shasum in (/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin)
which: no shasum in (/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin)
[POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.2.3, x86
[POL_Wine_SetVersionEnv] Message: "/home/diego/.PlayOnLinux//wine/linux-x86/1.2.3" exists
[POL_Wine] Message: Running wine-1.2.3 WINWORD.EXE /home/diego/comillas.docx
rm: no se puede borrar «*»: No existe el fichero o el directorio
wine: cannot find L"C:\\\\windows\\\\system32\\\\winemenubuilder.exe"

and the document opens in blank in a new document.

Any help?
simon Lundi 28 Novembre 2011 à 23:04
simonAnonymous

I have the same problem,

I installed Office 2007 with PlayOnLinux succesfully and it runs great. I used

playonlinux --run "Microsoft Word 2007" z:%f

in the custom open with... command to be able to launch my .doc files with a double click in my file manager. It works well for filenames without spaces, but when the filename contains a space, it tries to open each word as a separate file.
ex: My Doc Document.doc Word tries to open My , Doc , Document.doc and gives a file not found error for each.

Is there any syntax to express whatever %f links to as one file?

Thanks

Edit: I'm running lubuntu 11.10, DE is LXDE and file manager is PCmanF

Edité par simon@ledx.com

Unkuiri Mardi 6 Mars 2012 à 18:20
Unkuiri

Hi, Ihad the same problem and found wht seems to be the solution...

Go to your "~/.PlayOnLinux/shortcuts" folder and open the shortcut you want to change, in my example "Microsoft Office Powerpoint 2007" and change:

$@

Citer


to:

"$(echo "$@" | sed -e 's:C:Z:' -e 's:/*/:\\\\:g')"

Citer


Now You can use:

playonlinux --run "Microsoft Word 2007" Z:%F

Citer


It works for me on ubuntu 11.10

I also created a .desktop file on /usr/share/applications with this (this is for Powerpoint I named it mspowerpoint.desktop without spaces to avoid problems):


[Desktop Entry]
Encoding=UTF-8
Name=Microsoft Office Powerpoint 2007
GenericName=Game
Comment=PlayOnLinux
Type=Application
Exec=/usr/share/playonlinux/playonlinux --run "Microsoft Office Powerpoint 2007" Z:%F
Icon=/home/unkuiri/.PlayOnLinux//icones/full_size/Microsoft Office Powerpoint 2007
Categories=PlayOnLinux;
Name[pt_PT]=Microsoft Office Powerpoint 2007

Citer


Edité par Unkuiri

linuxdudeguy Vendredi 6 Juillet 2012 à 5:26
linuxdudeguyAnonymous


Thanks Unkuiri,


That worked for most files except ones with a capital C in the filename. The error always shows instead of 'Colour.doc' file couldn't open. It says 'Zolour.doc' couldn't open. That's why it's not opening the file correctly.


Weird. Any idea why it's happening ?

Unkuiri Lundi 30 Juillet 2012 à 14:10
Unkuiri

Hi,
The solution is a simple one, just change 's:C:Z:' to 's;C:;Z:;'
Sorry, the error was mine..hope this helps, let me know if that works..
Quentin PÂRIS Lundi 30 Juillet 2012 à 17:54
Quentin PÂRIS
Admin

This problem is fixed for 4.1.4
linuxdudeguy Mercredi 8 Aoüt 2012 à 12:01
linuxdudeguyAnonymous

Hi,
The solution is a simple one, just change 's:C:Z:' to 's;C:;Z:;'
Sorry, the error was mine..hope this helps, let me know if that works..

Quote from Unkuiri

Yeah it's working  ;  )

Thanks alot Unkuiri.