Forums

Stacraft 2 installation impossible

Auteur Réponses
maxwellskunk Vendredi 30 September 2011 à 9:20
maxwellskunkAnonymous

Bonjour,

J'ai installé SC2 il y a plusieurs mois avec POL sans aucuns problèmes, il fonctionnait a la perfection mais après le patch 1.4 le jeu ne se lançait plus! J'ai donc voulu le réinstaller et la "runtime error" a 52% de l'install.

Depuis j'ai tout tenté, je suis repartit sur un système neuf (pour d'autres raisons), nouvelle install de POL, retéléchargemen des sources d'install SC2 mais toujours a 52% "microsoft visual c++ runtime library runtime error this application has requested the runtime to terminate it in an unusual way"

J'ai cherché cette erreur mais je n'ai trouvé aucune réponse valable.

Si quelqun a déja eu le problème et a une solution, ca serait sympa de nous en faire part :)

Maxwell

Ubuntu 10.04 LTS
POL 4.0.12
SuperPlumus Vendredi 30 September 2011 à 19:11
SuperPlumusAnonymous
Admin

Bonjour,

Il y a peut-être une piste sur le site suivant : http://jeffhoogland.blogspot.com/2010/07/howto-starcraft-2-on-linux-with-wine.html

En bref, il semblerait que il faut que Wine simule Windows XP ou Windows 7, je sais pas, c'est pas très clair.

Donc, je vous propose de tenter d'exécuter ce script (qui est le même que celui accessible par le bouton Installer -> Jeux -> Starcraft II, à part la modif pour la version de Windows) :

#!/bin/bash
# Date : (2010-04-08 10-00)
# Last revision : (2011-08-28 21:00)
# Wine version used : 1.3.3, 1.3.11, 1.3.17, 1.3.25, 1.3.26, 1.3.27
# Distribution used to test : Debian Testing x64
# Author : GNU_Raziel
# Licence : Retail
# Only For : http://www.playonlinux.com

[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"

TITLE="StarCraft II Wings of Liberty"
EDITOR="StarCraft II Editor"
PREFIX="SC2_WoL"
WORKING_WINE_VERSION="1.3.27"
GAME_VMS="128"

# Starting the script
rm "$POL_USER_ROOT/tmp/*.jpg"
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/starcraft2_wol/top.jpg" "http://files.playonlinux.com/resources/setups/starcraft2_wol/left.jpg" "$TITLE"
POL_SetupWindow_Init

# Starting debugging API
POL_Debug_Init

POL_SetupWindow_presentation "$TITLE" "Blizzard Entertainment" "http://eu.starcraft2.com/" "GNU_Raziel" "$PREFIX" 

# Setting prefix path
POL_Wine_SelectPrefix "$PREFIX"

# Downloading wine if necessary and creating prefix
POL_System_SetArch "auto"
POL_Wine_PrefixCreate "$WORKING_WINE_VERSION"
 
# Choose between DVD and Digital Download version
POL_SetupWindow_InstallMethod "DVD,LOCAL"

# Installing mandatory dependencies
POL_Call POL_Install_vcrun2005 # Fix "Zeratul Missions" crash
POL_Call POL_Install_gecko # Fix "Updater" crash - part 1
POL_Wine_InstallFonts # Fix "Custom map" crash

Set_OS "winxp"

if [ "$INSTALL_METHOD" == "DVD" ]; then
	# Asking for CDROM and checking if it's correct one
	POL_SetupWindow_message "$(eval_gettext 'Please insert game media into your disk drive\\nif not already done.')" "$TITLE"
	POL_SetupWindow_cdrom
	POL_SetupWindow_wait_next_signal "$(eval_gettext 'Waiting for users commands...')" "$TITLE"
	VALID_UID=`id -g`
	VALID_DEVNODE=`mount | grep "$CDROM" | awk '{print $1}'`
	POL_Call POL_Function_RootCommand "sudo umount '$CDROM' && sudo mkdir -p /media/PlayOnLinux/ && sudo mount -o ro,unhide,uid=$VALID_UID $VALID_DEVNODE /media/PlayOnLinux/ ; exit"
	CDROM="/media/PlayOnLinux"
	# Removed since it cause error with some foreign languages
	#POL_SetupWindow_check_cdrom "Installer Tome 1.MPQE"
 
	# Copying DVD files to HDD & starting installation
	cd "$HOME"
	mkdir -p "$POL_USER_ROOT/tmp/SC2_WoL/"
	POL_SetupWindow_wait_next_signal "$LNG_WAIT_COPY" "$TITLE"
	cp -r /media/PlayOnLinux/* "$POL_USER_ROOT/tmp/SC2_WoL/"
	POL_Wine start /unix "$POL_USER_ROOT/tmp/SC2_WoL/Installer.exe"
	POL_SetupWindow_message "$(eval_gettext 'Click on "Forward" ONLY when the game installation is finished\\nor you will have to redo the installation.')" "$TITLE" 
else
	# Asking then installing DDV of the game
	cd "$HOME"
	POL_SetupWindow_browse "$(eval_gettext 'Please select the setup file to run:')" "$TITLE"
	SETUP_EXE="$APP_ANSWER"
	POL_Wine start /unix "$SETUP_EXE"
	POL_Wine_WaitExit
fi

# Asking about memory size of graphic card
POL_SetupWindow_VMS $GAME_VMS

## Fix for this game
POL_Wine_OverrideDLL "native,builtin" "mshtml" # Fix "Updater" crash - part 2

# Set Graphic Card information keys for wine
POL_Wine_SetVideoDriver

# Performance Tweak
POL_Wine_Direct3D "UseGLSL" "disabled"

# Sound problem fix - pulseaudio related
[ "$POL_OS" = "Linux" ] && Set_SoundDriver "alsa"
[ "$POL_OS" = "Linux" ] && Set_SoundEmulDriver "Y"
## End Fix

# Cleaning temp
if [ -e "$WINEPREFIX/drive_c/windows/temp/" ]; then
	rm -rf "$WINEPREFIX/drive_c/windows/temp/*"
	chmod -R 777 "$POL_USER_ROOT/tmp/"
	rm -rf "$POL_USER_ROOT/tmp/*"
fi

# Making shortcut
POL_Shortcut "StarCraft II.exe" "$TITLE" "$TITLE.png" ""
POL_Shortcut "StarCraft II Editor.exe" "$EDITOR" "$EDITOR.png" ""

POL_SetupWindow_Close
exit


Instructions :

1) Supprimez le disque dur virtuel existant (à moins que il soit déjà supprimé) de l'installation ratée (c'est plus sur) : Cliquez sur Configurer (dans PlayOnLinux) -> Cliquez sur SC2_WoL dans la partie gauche -> Cliquez sur Supprimer.

2) Copiez le script ci-dessus, puis collez-le dans un fichier, donnez le nom que vous voulez au fichier.

3) Menu Outils (dans playonlinux) -> Exécuter un script local -> Sélectionnez votre fichier.

Si ce script ne marche pas, changez juste la ligne Set_OS "winxp" en Set_OS "win7" puis re-supprimez le disque dur virtuel comme expliqué au point 1, et réessayez l'installation.

En espèrent que ça marche, et si ça marche, ce serait gentil de préciser si il faut utiliser winxp ou win7.

Edité par SuperPlumus

GNU_Raziel Vendredi 30 September 2011 à 20:21
GNU_Raziel

Par defaut, wine est réglé en win XP SP3 et de plus, je n'ai aucun souci pour installer le jeu sur ma machine ni sur celle de mes amis (Mint 11, Debian Testing, Fedora 15, ect...), donc ca ne viens pas de la.

Edité par GNU_Raziel

maxwellskunk Lundi 3 Octobre 2011 à 19:42
maxwellskunkAnonymous

Merci pour le script SuperPlumus!

Ca a l'air de fonctionner pour l'instant, SC2 se met a jour...

On verra ce que ca donne :)
maxwellskunk Lundi 3 Octobre 2011 à 20:31
maxwellskunkAnonymous

Désolé, j'ai parlé trop vite, je n'avais pas vu la fenêtre en arrière plan :)
Toujours cette erreur avec "win7" mais beaucoup plus tôt...
SuperPlumus Jeudi 6 Octobre 2011 à 11:40
SuperPlumusAnonymous
Admin

On peut aussi essayer de tester avec une version de Wine plus ancienne.

Tu peux essayer de changer sur le script ci-dessus, la ligne :
WORKING_WINE_VERSION="1.3.27"


tu peux essayer de mettre d'autres versions de Wine à la place de 1.3.27, notamment les valeurs suivantes suivantes :

1.3.20
1.3.10
1.2


Pour faire ces tests, retire la commande suivante du script (c'est celle qu'on a tenté avant):
Set_OS "winxp"


Et surtout, il est important de faire le ménage entre les différents tests comme indiqué dans mon premier message.

Edité par SuperPlumus

maxwellskunk Vendredi 7 Octobre 2011 à 17:05
maxwellskunkAnonymous

J'ai passé pas mal de temps sur IRC avec les gars de Wine a faire des tests dans tout les sens mais sans succes.

C'est vraiment la dernière chose que je voulais faire mais je vais me réinstaller un Win XP sur une partition :(

J'ai du passer au moins 10 heures sur ce problème, j'ai réinstallé un Ubuntu tout neuf, testé pleins de versions de wine, des scripts POL mais toujours pareil.

Merci en tout cas pour votre aide, je pense refaire l'essai pour la prochaine LTS 12.04 !