Forums

Prince of Persia SOT : Options graphiques inaccessibles

Auteur Réponses
blackestmajor Samedi 5 Novembre 2011 à 23:30
blackestmajorAnonymous

Bonjour à tous,

Je viens d'installer Prince of Persia : Sands of Time via le script Playonlinux. Il s'agit de la version DVD commercialisée dans le pack 5 jeux pour les 25 ans d'Ubisoft.

Je peux jouer au jeu mais impossible d'aller dans Options -> Graphisme. Le jeu affiche une fenêtre Microsoft Visual C++ Runtime Library : Assertion Failed concernant le programme POP.EXE. Il y'a plusieurs choix comme ignorer, abandonner etc mais aucun ne marche, on doit fermer la fenêtre. Le mode debug n'affiche rien de spécial.

Du coup je ne peux jouer au jeu qu'en 640*480, c'est dommage car le jeu est fluide et parfaitement jouable une fois qu'on a réglé les problèmes de fog dans hardware.ini.

Je tourne sous Ubuntu 11.10 (sous 10.04 même problème) en 64 bits, ma carte graphique est une Geforce 8600 GT et j'ai les derniers pilotes nvidia installés.

Merci d'avance de votre aide

GNU_Raziel Dimanche 6 Novembre 2011 à 15:31
GNU_Raziel

Je pense qu'en installant vcrun2005 cela devrait fonctionner, cela peut être fait depuis le menu "configurer" de PoL.
blackestmajor Lundi 7 Novembre 2011 à 20:19
blackestmajorAnonymous

Merci à toi.
J'ai essayé mais ça n'a rien changé :( Par contre il y'a du nouveau

Je viens de vérifier deux ou trois trucs à propos de mes pilotes graphiques, suite à une mise à jour maintenant j'ai le message suivant au lancement:

"Une erreur est survenue lors de l'analyse de la configuration de votre materiel (Result not found: directx/numd3dadapters). Lancer quand même le jeu ?"

Je réponds oui, il me demande comme à chaque fois si je veux lancer le mode sans échec, que je réponde oui ou non j'obtiens ça:

"Le jeu s'est arrêté de manière inattendue. Consultez le fichier readme.txt etc..."

Je sens comme un souci vis à vis de la détection de ma carte graphique. J'ai les derniers pilotes 285.05 activé et utilisé dans Ubuntu.

Pour info j'ai essayé de faire tourner la version PS2 via un émulateur, le plugin de rendu opengl refuse de se lancer... D'où ma suspicion par rapport à un problème de pilotes.
GNU_Raziel Lundi 7 Novembre 2011 à 21:13
GNU_Raziel

Oui il y a surement un souci au niveau des pilotes, essai de les déinstallés completement avant de les remettre, la mise a jour depuis la version précédente à surement foirée.
blackestmajor Lundi 7 Novembre 2011 à 22:53
blackestmajorAnonymous

Bon j'ai desinstallé et réinstallé les pilotes, désinstallé et réinstallé plusieurs fois le jeu, playonlinux, wine... Fouillé partout sur le net, mais rien à faire. L'accélération graphique est activée (testé avec glxinfo et glxgears), mais toujours ce message d'erreur... Je ne comprends pas :(
blackestmajor Lundi 7 Novembre 2011 à 22:54
blackestmajorAnonymous

Bon j'ai desinstallé et réinstallé les pilotes, désinstallé et réinstallé plusieurs fois le jeu, playonlinux, wine... Fouillé partout sur le net, mais rien à faire. L'accélération graphique est activée (testé avec glxinfo et glxgears), mais toujours ce message d'erreur... Je ne comprends pas :(
blackestmajor Jeudi 10 Novembre 2011 à 17:26
blackestmajorAnonymous

J'ai du nouveau, j'ai trouvé l'origine du problème et une solution.
En fait il s'agit d'un bug répertorié ici: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/852873

En gros ça empêche le bon fonctionnement d'opengl dans les applis 32 bits dans un système 64 bits. Wine et donc playonlinux est touché, ainsi que des émulateurs comme PCSX ou PCSX2, et même les émulateurs de jeux 2D qui utilisent OpenGL pour le rendu.

La solution consiste à précéder chacun des programmes concernés des deux lignes suivantes (soit par un script bash, soit en lancant le programme dans un terminal)

export LD_LIBRARY_PATH=/usr/lib32/nvidia-current
LD_PRELOAD=/usr/lib32/nvidia-current/libGL.so.1

Valable si le driver est nvidia-current. Du coup Prince of Persia Sands of Time fonctionne nickel, à ceci près que la manette n'est pas reconnue mais je vais chercher une solution.

Merci à toi GNU_Raziel en tout cas de t'être penché sur mon problème :)
Quentin PÂRIS Vendredi 11 Novembre 2011 à 19:33
Quentin PÂRIS
Admin

Comment je peux faire pour régler ça avec PlayOnLinux ?

J'ai peur que ces commandes posent problème

Edité par Tinou

blackestmajor Dimanche 13 Novembre 2011 à 20:14
blackestmajorAnonymous

Je ne pense pas qu'il faille régler quoique ce soit dans Playonlinux, juste charger ces commandes avant de le lancer, en attendant que le bug soit corrigé.
Quentin PÂRIS Dimanche 13 Novembre 2011 à 21:13
Quentin PÂRIS
Admin

Il faudrait voir ce que ça donne pour les autres distribs'

Mais j'aime pas intégrer ce genres de bidouilles dans POL. En même temps si POL ne marche pas du tout avec ubuntu 64...