Race Driver Grid Not Starting

Auteur Réponses
toutwid Dimanche 4 Mars 2012 à 10:11

Using the latest POL I install Grid and patch the game (tried 1.2 and 1.3 patches) but the game doesn't run. I also tried the recommended tweaks and still no joy.

I am getting an internal error - invalid parameters recieved

unhandled exception 0x80000003 at address 0x12a4437 (thread 9)
can't attach process 0008: error 5

Any ideas what may be the cause of this?


I should probably add I am using the latest POL on Xubuntu 11.10 with Nvidia drivers 280.13

Edité par toutwid

Dadu042 Mercredi 15 Janvier 2020 à 14:01

I also has this kind of issues in 2020 with the retail DVD v1.0 and newer Wine versions.  I wrote a new script.

booman Jeudi 16 Janvier 2020 à 23:49

Whoa, those Nvidia drivers are a bit old.  I'm on Nvidia 415 which are considered old.

Also, I think Grid requires Vulkan and DXVK to run.

Make sure you have Vulkan installed in Linux and you may want to try Grid in Steam with Proton.  It handles just about everything to run it.

Here is a possible workaround if its not launching:

You need to rename "Grid_dx12.exe" to "Grid_dx12.exe_bak" and then "Grid.exe" to "Grid_dx12.exe". This trick is to avoid the game to load the DirectX12 and use DirectX11 (DXVK). After this change the game works correctly.


† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained