Forums

Diablo III Latest Patch Problems

Plays for a couple of minutes then kicks you

Auteur Réponses
vsrz Mercredi 6 Juin 2012 à 1:56
vsrzAnonymous

Hi All,

I know similar topics have been posted several times but the errors I'm seeing are a bit different than what's been reported.

Title says it all. Seems like the latest patch might attempt some BitTorrent connections on launch but not entirely sure if this has anything to do with it.

If I wait long enough it doesn't let me in the game but I can sometimes get in and play for a couple of minutes then eventually it says you've been removed from the game. When you try to go back in and "Resume Game" it errors out.

I can play other games just fine, just not this one.  It ran just fine before the patch. I've also wiped/reinstalled the game completely to eliminate anything I might have done inadvertently.

Here's the my playonlinux.log

www.vsritual.com/playonlinux.log

I'm running BackTrack 5R2 (Ubuntu 10.04).

Thanks for your time guys.

Edité par vsrz

doff Mercredi 6 Juin 2012 à 3:03
doffAnonymous

I am having the same exact problem.

Was working great for Days once you guys helped me fix the sound problems.

Here is the log hope it helps.

http://pastebin.com/h6Z19pXP

Running Debian Wheezy 3.2.0-2-amd64

With  Nvidia 295.53-1 0 Drivers.

Edité par doff

vsrz Mercredi 6 Juin 2012 à 6:36
vsrzAnonymous

Hi again,

Many users are complaining about this same issue on the Wine Bugreports. You can view the comments here:

http://bugs.winehq.org/show_bug.cgi?id=30849

Thanks!
Quentin PÂRIS Mercredi 6 Juin 2012 à 12:53
Quentin PÂRIS
Admin

Shi...

Really I hate Blizzard for Diablo III's DRM.

I will continue to check the bug tracker
Falmarri Jeudi 7 Juin 2012 à 10:22
FalmarriAnonymous

This fixed the problem for me

http://us.battle.net/d3/en/forum/topic/5592457019?page=3

Specifically:

setarch i386 -3 playonlinux
Quentin PÂRIS Jeudi 7 Juin 2012 à 12:30
Quentin PÂRIS
Admin

Currently building another wine version with Alexandre Juillard's patch

It will be named wine-1.5.5-DiabloIII_v3

Hope it will fix the problem
vsrz Jeudi 7 Juin 2012 à 16:20
vsrzAnonymous

Thanks Quentin. I found the workaround on the bugzilla forms then tried Alexandre's patch. Everything seems stable now.

Again it's working fine with the wine-1.5.5-DiabloIII_v3 patch on BackTrack 5R2 (Ubuntu 10.04 3.2.6-x86_64).


Thank you!