Het forum

League Of Legends - FPS / Frame Rate issue

a choppy 40fps?

Auteur Antwoorden
CJRamze Dinsdag 12 Maart 2013 om 16:04

Hi guys
Sorry if this is a duplicate topic, I've attempted to use the search function however (For some odd reason) it just loads a blank page and wont allow me to go any further.

Now I'm brand new to play on linux and I'm very impressed with the system, I installed the beta version of League of Legends and all went swimmingly, Patched and up to date.

Logged in and set it and noticed it was Jittery, Now I'm new I dont know the acceptable level for Windows games running linux (or whats to be expected)

Anyway, I get a contstant 40fps, it honestly doesn't look that smooth, looks more like 10-15 fps however the counter in the top right doesn't move from 40fps.

Its not unplayable but I thought I'd get smooth gameplay considering my setup.

I have

Ubuntu 12.10 x64 with Gnome 3
4.5Ghz i5 2500K
8GB DDR3 1600mhz
Nvidia GTX 690 4GB
120GB SSD 500mb R/W

Any suggestions. Again, sorry if I've missed something on the forums my search function just wont work
xpander Dinsdag 12 Maart 2013 om 16:51

turn off vsync from the game.
go to playOnLinux LoL prefix configuration and set tue UseGLSL disabled (to boost perf)

install jupiter applet or similar and force your CPU to go performance when gaming (instead of ondemand)

i have weaker PC

AMD phenom II x4 955 @3,6ghz

8GB DD3 @ 1600mhz


Arch Linux x64, MATE destkop

and i get around 60 fps most of the time.. huge action drops to 50 sometimes.

but its really smooth

Aangepast door xpander

CJRamze Dinsdag 12 Maart 2013 om 17:18

Hi Xpander,
Thanks for the information.
I will try those bits when I get home and post a progress report.

Many Thanks
Atrytone Zondag 14 Juli 2013 om 21:09

Thanks so much for the tip about Jupiter, xpander. Since it's not supported I used the alternative found here: http://askubuntu.com/questions/304270/alternative-to-jupiter-applet

It made a huge difference!

Aangepast door Atrytone

GrovRutaN Woensdag 28 Augustus 2013 om 23:40

Wow, thanks alot for that suggestion. Huge improvement !!!
Pie Vrijdag 3 Januari 2014 om 0:01

This was helpful, can this be applied to Debian? I'm running Mint with Cinnamon and I have it installed but it minimizes when I try to run it