Het forum

[GW2] Freezes system at patch 1.5.28 and up

Auteur Antwoorden
Jump to the page: 1 - 2 - 3 - 4 - 5 - 6 - 7
Incarnated Zaterdag 26 October 2013 om 1:15
IncarnatedAnonymous

Also ugh i'm sorry I feel so stupid I'm not even sure if this is important that I left out. I have 4.2.1 PoL, but my distro says there is a previous version in their store. Does that make a difference?
Ronin DUSETTE Zaterdag 26 October 2013 om 1:20
Ronin DUSETTE

I dont get it. That makes no sense, because I do that over here, and it throws an error, but I cant see exactly what is going on over there, so I just dont know.

And no. Do NOT use the version that is available through Ubuntu. Its outdated. 4.2.1 is fine. That is the most recent version.

The only thing I can say is either play it on windows, upgrade your hardware, or find another game to play. hahaha.

The script shows the error on my side, there is no reason it would be missing on your side.

Also, this game is HUGE. How did you download and attempt to install the WHOLE game that fast? That wasnt even 5 minutes since your last post, so in that time, you downloaded the whole game, deleted the virtual drive, ran the installer, installed it, had it crash, and posted? In 5 minutes. I dont believe that. haha

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Incarnated Zaterdag 26 October 2013 om 1:22
IncarnatedAnonymous

Lol it's good you don't. The thing is the Launcher does NOT load which is why I can't access the game/download the game. It all on the launcher to even play GW2 unlike WOW where all you have to do is hit WoW.exe and just the game loads >.
Ronin DUSETTE Zaterdag 26 October 2013 om 1:24
Ronin DUSETTE

I dont know what to tell you. lol.

I dont mean to sound like a jerk. Im not trying to. hhaha. dont take offense.

Its something you may have to wait for to get fixed.

I got to go. Just got off work. Let me know if you figure anything out.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Incarnated Zaterdag 26 October 2013 om 1:27
IncarnatedAnonymous

Thanks man, I think ill just go back to windows for a while. Maybe something will be fixed later on. I cant tell you how much of a help you've been and i'm sorry if i've wasted any of your time. You have been very helpful and can't thank you enough.
Ronin DUSETTE Zaterdag 26 October 2013 om 1:33
Ronin DUSETTE

hahaha. No problem, man. I get, well, flustered sometimes... Its part of my charm ;)

Sorry if I was being curt. I just dont like it when I cannot fix something. hahaha.

Again, let me know if you figure anything else out, and Ill do what I can to help. No hard feelings? hahaha

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Incarnated Zaterdag 26 October 2013 om 5:09
IncarnatedAnonymous

No none at all I just ask if you would leave this post up so others can see and try and use it to help them out :). Also I just went to win 7 and am just trying to make it as linux like as I can (mainly due to compatibility and you can't really update a motherboard video card on a laptop too well.) So I figured I may give it a go on my main desktop which is definitely more than enough power and memory to run just about anything. And again no hard feelings at all I understand getting flustered ohh way too well. That's why I came here I figured someone with more expierence could help, but sadly its just hardware not software(well primarily :P)


But underline to all of this as you said the script if under 516mb virtual memory it's not going to work. I may have to wait a while or just get a stronger laptop in the future(in that aspect). And again thank you for all your help and no hard feelings at all :)


P.S. Maybe some other noob will realize on how to debug now as well :P
Ronin DUSETTE Zaterdag 26 October 2013 om 17:09
Ronin DUSETTE

Of course. I dont remove posts. Thats why I dont answer questions privately, and I prefer most errors to be reported here. It makes it available for other users to search and find answers, if they are so inclined. :D

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Incarnated Zondag 10 November 2013 om 3:17
IncarnatedAnonymous

I GOT IT! Finally have figured it all out. I must go into Configure Wine --> Graphics and then check Emulate a Virtual Desktop. And it runs just as if it was on Windows for me!

Aangepast door Incarnated

booman Maandag 11 November 2013 om 2:15
booman

Seriously? I couldn't have been that simple!
So Virtual Desktop allows you to play Gears of War 2?


After all of those library and d3d errors and 32-bit stuff?
I don't get it.
But if it works... then it works!
Crazy because I found out pretty early that games just run better and are easier to troubleshoot with virtual desktop.

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained