Het forum

UnderRail, LMDE2, Error: no suitable graphics card found

Help me play the Mole People game!

Auteur Antwoorden
CroMagnon Zondag 3 Juli 2016 om 6:28


I reposted this from the Manual Installations subforum because I just realized I have no idea if I should have posted it there. I've never used WINE or POL before now. This is the first game I've ever tried to install with either one. So, I have no idea if my problem is WINE or POL or Debian Jessie or my hardware, or the game itself.

I've included quite a bit of information here in hopes that someone experienced will find it useful. However, I don't have debug logs due to many reinstalls of POL and WINE. I think I will try again and get logs while I wait for a response.

Greetings (again), and with great humility and lowly need of aide do I beseech ye who are wise in my struggle against my netbook. I am ashamed before humanity!

I have tried around 5 or 6 times to install the latest GOG version of UnderRail. The game seems to install okay, but attempts to run it fail with this error:

"No suitable graphics card found. Could not find a Direct3D device that supports XNA Framework Reach profile."

I tried the exact instructions and components from this post:


Before I go into more detail, here are my specs:

Linux version: 

LMDE2 (Linux Mint Debian Edition 2, based on Debian Jessie)

Kernel: 4.5.0-0.bpo.2-amd64

MultiArch appears to be set up fine.

POL Version: 

4.2.10. For the first install, I used POL 4.2.5 (stable) from the Jessie repository. Then, I installed 4.2.10. With both versions, the problem behaved the same.

For my first 2 or 3 attempts, I had Wine 1.8.2 32bit and 64bit installed from Debian Backports. 

Computer Specs:

Lenovo S21E netbook

CPU: Intel Celeron N2840 Dual Core 2.16GHz

RAM: 2 Gb

GPU: Intel Atom Processor Z36xxx/Z37xxx Series - using i915 driver provided by Jessie package xserver-xorg-video-intel version 2:2.21.15-2+b2.

Error messages:

I've uninstalled and reinstalled POL several times, and do not have debug logs at the moment. Upon request, I can do it all again to get debug logs.

For every install (in POL and using WINE/wineprefix alone), I get the "Runtime Error 69:445" message before the install finishes. I've read that this is not always a problem.

But, I have never once had the UnderRail game icon show up in the POL main window. The only way I can try to play it is to go to Configure, choose the virtual drive, and then run an .exe.

So, again, I get this:

"No suitable graphics card found. Could not find a Direct3D device that supports XNA Framework Reach profile."


In addition to the components listed in the POL forum link above, I have also tried installing:

XNA3.1 plus the suggested components.

XNA4.0 plus suggested components.

Both XNA versions plus the components.

D3DFull plus the components.

WindowsVideoDriver plus the components, and possibly one or both XNA's at the same time (I don't remember clearly. "No suitable brain cells found.")

And, I forget whatever other combination I tried.

To start over clean, I deleted the virtual drive after each attempt.

In addition to WINE 1.8, I also used the POL WINE Manager and tried WINE versions 1.8.2, 1.9.1, and I think 1.9.3.

The last thing I tried was the WINEPREFIX method from this post on the GOG forums:


That results in the same error, and I tried various combinations of components with that, as well.

I'm curious whether LMDE2/Debian Jessie require things I don't know about to make WINE and POL work nice. I'm aware Ubuntu and regular Mint are more friendly for this.

I'm hoping I just need to do something with POL. If this is an issue with LMDE2 stuff, just point me vaguely in the right direction if no one wants to get into helping with that.

Whoever can help with this, I know that much of this information may or may not be immediately useful, so I'll try whatever anyone suggests as long as it doesn't result in fire and as long as the conclusion isn't like the end of the movie "Pi".

I'd just like to add that this is why robots should be distrusted and regarded as evil.

Thank you for your time.

CroMagnon Maandag 4 Juli 2016 om 9:50

So no one even has an offhand or quick suggestion? There's no force of nature requiring that every single thing I said must be analyzed before replying.

Some small tip may be all I need to get it working, even if someone doubts their tip will work.

Daviot Maandag 4 Juli 2016 om 12:30

I've had relatively good luck with Linux Mint (Ubuntu base) and GoG games, and looking up the stats, your integrated Intel HD GPU is theoretically capable of handling "DirectX 11, Shader 5.0" so that shouldn't be a limiting factor.

Steam lists the following sysrequirements for Underrail:

        OS: Windows XP SP3
        Processor: 1.6GHz
        Memory: 2 GB RAM
        Graphics: GPU that supports shader model 2.0
        DirectX: Version 9.0c
        Storage: 3 GB available space


My brief guess is that the program isn't explicitly being told to use DirectX and is trying to run the game without it, to your above error message.  Here's what I would try for lack of knowing:

Start with PoL and a manual install with the recommended depencies from the Underrail thread, install it as you have, and then click "Configure" and navigate to your prefix.  Click the Wine tab and then "Configure Wine".

1. Check what OS you're imitating.  If plain XP isn't working, try Vista or 7; might be less hassle than trying to install service packs within a prefix.  A 32-bit prefix should be sufficient given the original system requirements.

2. Under the "Libraries" tab, try creating an override for DirectX9c and dotnet, set to "Native" (i.e. use the Windows blob instead of the Wine version).

3. Under the "Graphics" tab make sure "automatically capture the mouse" is checked, allow window manager to decorate, allow window manager to control.  You may also try emulating a virtual desktop to see if that helps.

Extra. If/when you do get things working, there's an easy way to make the executable show up in both PoL and your desktop.  From the main PoL screen, hit configure, select your prefix, and in the first tab, there's the giant button that reads "Make a new shortcut from this virtual drive".  Point it to your game's main executable.  Bam.

CroMagnon Maandag 4 Juli 2016 om 16:29

Thank you very much for the reply!

Unfortunately, it didn't work. It did clarify some things for me about how to troubleshoot in POL, though.

First, with a fresh install of POL, I tried the method from the post along with your suggestions. I then tried various combinations of different Windows versions with and without the overrides, and with the overrides set to "native then builtin", and then I tried it with one set to native and then the other set to "native and builtin", and vice versa.

The graphics settings for mouse capture and the two window manager options were set correctly, as well as a virtual desktop.

If and when you have any other ideas I will excitedly try them as hard as I can.

Here is a pastebin link to my debug log:


CroMagnon Maandag 4 Juli 2016 om 17:04

Annnd I forgot to put this into the terminal before installing dotnet:

sudo echo "0" > /proc/sys/kernel/yama/ptrace_scope


I've tried the original method a few times while not forgetting that. But, since I forgot that part, I haven't yet tried your suggestions correctly.

Some people say this universe is just a simulation.

Aangepast door CroMagnon

CroMagnon Maandag 4 Juli 2016 om 18:30

Install corrected. Same results.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com