Het forum

League of legends not installing correctly? Mint 18.

Auteur Antwoorden
Asaddc Zaterdag 17 September 2016 om 20:23

I decided to download league, and after the install I ran into an error message just opening in a loop, it wouldn't disappear. To combat this issue I had I configured in wine to make it seems like its windows 10, instead of XP. Everything was perfect, I was downloading the files in the league client, and I waited about an hour or two, and the same error message decided to come back, however it wasn't in a loop. I just came up once this time and that was it. I can't seem to download and play league properly, and would really love to.


I am running Linux Mint 18 "Sarah", I also have a AMD cpu and graphics card, if that would be of any help to fix this issue.

Asaddc Vrijdag 23 September 2016 om 3:09

I wish someone knew the problem ;/

HEaRiX Zondag 25 September 2016 om 12:20

No support... for nothing... I tried 4 games, 4 programms with PoL and/or Wine, nothing worked... how can anybody say "use linux, its fine, everything you can do in windows you can do on linux"... nope I couldn't do anything since I switched...


I got the same problem like you... no solution...

Asaddc Maandag 26 September 2016 om 20:51

I was following a few videos on youtube with POL and it seemed fine with them, not sure why its not working with us..


What is your graphics card and cpu?

Asaddc Maandag 26 September 2016 om 21:01

And I have to agree with you man, I also just recently switched to linux, althouh its only on my laptop, and I wanted to mainly do programming work on it, I wanted to play a light game here or there to kill time, such as league, and of course it doesn't work! :(

BloodyIron Woensdag 28 September 2016 om 18:55

Fret not friends, there are those of us fighting the good fight! We can't be everywhere, but we're trying to help as much as we can.

While, I can't necessarily walk you through all the steps that worked for me, since I didn't do the best job documenting them, rest assured it is achievable! Here's what I can tell you about my existing setup for LoL:

  1. WINE 1.9.12-staging (CSMT on, EAX also on but probably not needed)
  2. Windows XP
  3. A bunch of library adjustments (outlined below), this is found in Wine configuration
  4. GLSL disabled, all the rest under "Display" (in POL) set to default
  5. No launch flags



  1. *d3dx9_24, through *dx3dx9_40, (_41 I guess not required), *dx3dx9_42 & _43 -> All set to "(native, builtin)"
  2. *dnsapi -> "(builtin, native)"
  3. *msvcr80 & *msvcr90 -> "(native, builtin)"


Now, it is likely there are things I'm missing here (like which components I installed). So, I'm sorry this is incomplete, however this is working with the current version of the game. Please stay strong! Nobody is getting paid here, so not everyone can make the time to answer all the questions.


Try these out, and share your outcomes please :) Also, it's a good idea to refer to the winehq pages for further guidance too.

iiwii Donderdag 29 September 2016 om 2:11

What error are you getting? pol uses 32bit packages.

I needed some extra packages to get it working for me in mint, you might need to get 32bit video dirvers.

For example for me to get it working with my intel card I used,

apt-get install libtxc-dxtn0 libtxc-dxtn-s2tc0:i386 p11-kit:i386

Lauch Playonlinux > Tools > Playonlinux debugger

Click on Virtual drives > League of Legends

launch the game and look at the output. read it try to make sense of it, if you need help post it here so other can take a look at it.

Aangepast door iiwii

Asaddc Donderdag 29 September 2016 om 9:01

I just tried to re install league again and the same thing happens. Just to calrify the error isn't coming up in playonlinux, its coming up in the actual league patcher. I download the patches up to about 46% or so, and when I get to "Applying patches" I get a "An error occured" bug splat from the league patcher. I never had any sort of issues from when I tried installing league on my windows OS. I am using the same laptop.