Het forum

[ Astuce ] Un son PARFAIT pour Trackmania Nation !

Auteur Antwoorden
BlondVador Zaterdag 31 Mei 2008 om 8:25
BlondVador
Moderator

Bonjour à tous,

Après les difficultés qu'ont rencontrés plusieurs personnes (dont moi) pour avoir un son PARFAIT sur Trackmania Nation, j'ai enfin la solution pour que vous puissiez jouer comme sous Windaube et même mieux !

Si vous avez déjà essayé de modifier votre son avec l'ancienne dll OpenAL32.dll, remettez l'ancienne sinon l'astuce ne fonctionnera pas.

Récupérez cette dll :
http://www.dllbank.com/zip/w/wrap_oal.dll.zip

Décompactez l'archive et copiez-collez la dll dans le dossier racine du jeu. Acceptez de remplacer l'ancienne dll par la nouvelle.

Et vous voila avec un son impeccable !

Source :
http://forum.ubuntu-fr.org/viewtopic.php?id=222456

Aangepast door BlondVador


Quentin PÂRIS Zaterdag 31 Mei 2008 om 18:41
Quentin PÂRIS
Admin

Intégré dans POL ! Merci encore !
Sylvain_07 Zondag 21 Februari 2010 om 23:34
Sylvain_07Anonymous

Bonsoir,
j'ai essayer votre dll : ça ne marche pas mieux chez moi : un jours j'ai du son, le lendemain j'ai du son une minute et plus rien...

BlondVador Maandag 22 Februari 2010 om 10:30
BlondVador
Moderator

Quel pilote audio utilisez-vous ?

Sylvain_07 Maandag 22 Februari 2010 om 12:38
Sylvain_07Anonymous

le premier jours que je l'ai installé : j'avais mis Esound ( tous mes autres jeux fonctionent avec celui là)

ça marchait avec quelques coupure .

le lendemain je démarre du son une minute.

j'ai changé : j'ai mis ALSA : ça a marcher se jours là.
le lendemain je redémarre : idem que la veille du son une minute.
j'essaye OSS : et paf ça marche ce jours là.
hier je relance le jeu et hop une minute de sont et plus rien.

je re essaye ALSA : idem une mitnute de son, Esound : rien du tout,
Jack et NAS : le jeu ne se lance pas.

a chaque fois je configure bien les options du son du lanceur en fonction du pilote définit dans wine.

PS : j'ai TMUF
et une carte son PCI sound Blaster audigy
BlondVador Maandag 22 Februari 2010 om 13:02
BlondVador
Moderator

Essayez de lancer le jeu avec une version différente de Wine.

Si ça ne fonctionne pas, essayez de lancer le jeu dans un terminal et copiez-collez l'intégralité de ce qui s'affiche ici.

Sylvain_07 Maandag 22 Februari 2010 om 19:56
Sylvain_07Anonymous

Re, j'ai essayer différentes version (1.1.37, 38 , la version system (1.1.39) et dont la 1.1.19 :
voici ce que celà donne si je configure le pilote audio Wine sur ALSA et ALSA Software on CA0106 [CA0106] (hw:0,0)


sylvain-sa@Sylvain-SA:~$ cd /media/L2/Program-Wine/TMU
sylvain-sa@Sylvain-SA:/media/L2/Program-Wine/TMU$ WINEDEBUG=-all env WINEPREFIX="/home/sylvain-sa/.PlayOnLinux/wineprefix/TMUnited" wine "Z:\\media\\L2\\Program-Wine\\TMU\\TmForeverLauncher.exe"
sylvain-sa@Sylvain-SA:/media/L2/Program-Wine/TMU$ AL lib: alsa.c:388: Could not open playback device 'hw:0,0': Périphérique ou ressource occupé


Citeer




du son 1 minute ou 2 et plus rien

Aangepast door Sylvain_07

BlondVador Maandag 22 Februari 2010 om 21:27
BlondVador
Moderator

Ton périphérique audio est occupé. Bizarrement, il est occupé à partir d'un certain moment d'après ce que tu me dis...

Possèdes-tu plusieurs cartes sons ?

Si non, quel mixeur de sons utilises-tu en générale pour ta distribution ?

Sylvain_07 Maandag 22 Februari 2010 om 22:41
Sylvain_07Anonymous

Ma carte mère possède une carte son intégrée mais elle est désactivée.

quel mixeur? le gestionnaire de volume?
si c'est de celà que tu écris : je ne sait pas : c'est le gestionnaire de volume qui est installé par défaut dans Ubuntu Karmic 64.

je viens de parcourir la logitèque pour essayer de glaner plus d'info : il n'y figure pas.
BlondVador Dinsdag 23 Februari 2010 om 16:36
BlondVador
Moderator

Essaye d'activer ta carte son (pour cela je t'envoies vers la doc' d'ubuntu parce que ça diffère d'une carte à une autre).

Essaye d'utiliser Alsa comme pilote de son général.

Sylvain_07 Dinsdag 23 Februari 2010 om 18:59
Sylvain_07Anonymous

je l'ai désactivée volontairement ( dans le bios) car j'utilise ma carte sound blaster qui offre un son de meilleur qualité.

BlondVador Dinsdag 23 Februari 2010 om 20:40
BlondVador
Moderator

Ah, tu ne me l'avais pas signalée c'est pour ça ^^.

Normalement, les Sound Blaster gèrent les sons multicanaux... Non vraiment, je ne vois pas le soucis :/.

Va falloir attendre un pro ou essaye sur un autre forum, là ça dépasse mes faibles compétences désolé.

Sylvain_07 Dinsdag 23 Februari 2010 om 23:46
Sylvain_07Anonymous

Bonsoir, j'ai essyer plusieur chose : dans mes paramètre audio ubuntu : j'ai modifier ma configuration de mes haut parleur : j'ai configurer comme si j'avais du 2.1 au lieu du 5.1, dans wine j'ai décoché tous les pilote son ( je n'en ai laissait aucun de coché) .
j'ai comme l'impression qu'il y a un petit progrés : j'arrive à avoir du son un peu plus longtemp.
par moment le sont gresille fortement puis reviens.
ça marche une ou 2 courses : puis de nouveau plus rien.
c'est un peu mieux mais pas encore ça.

j'ai désactivé les chargement des musiques, Doppler et EAX, mais ça ne change pas grand chose.

sinon je me suis aperçu d'aure chose : dans les option vidéo avancée du lanceur TMUF : ma carte vidéo n'est pas reconnue correctement : elle est reconnue avec seulement 386 Mo de RAM alors qu'en réalité j'en ai 1024.
dans le serveur X nvidia elle est bien reconnue correctement.
je me suis dit peut être que je surcharge trop les graphiques et que j'ai une incidence sur le son : j'ai baisser au mini le rendu graphique ça en change rien.
BlondVador Woensdag 24 Februari 2010 om 11:21
BlondVador
Moderator

Ah merci pour tes tests.

Pour ta carte graphique, je peux faire quelque chose, bien que ce ne soit pas ton problème principal. Avec le plug-in Advanced Wine Configuration que je t'ai fait télécharger pour Excessive Speed, choisis Trackmania United Forever puis "VideoMemorySize" et configure sur 1024.

Pour ton son, j'ai vraiment du mal à comprendre d'où ça peut venir...

Essaye ceci :
Lance la configuration de ton jeu et dans l'onglet "Peer-to-Peer" décoche tout.

Tu n'auras pas la musique des serveurs en jeu mais peut-être arriveras-tu à garder ton son...

Sylvain_07 Woensdag 24 Februari 2010 om 18:53
Sylvain_07Anonymous

Bonsoir,
aucun changement pour le son.
en tous cas il y a bien un effet 5.1 et 2.1 : car j'ai essayer de remettre en 5.1 et j'ai du son juste une minute vore à certain lancement pas du tout.

alors que si je reste en 2.1 (tant pis pour mes anceinte 5.1) j'ai du son pendant plusieurs courses, me si le son craquille .
on diraut que ça craiquille de plus en plus en plus et qu'un moment ça craque tellement que le son se coupe.

je pensait que peut être le son de la course + les moteurs = trop de son : et essayer en désactivant tous simplement les musiques afin de ne garder que les son moteur et Pneu.

mais à priori pas d'option pour désactiver la musique. ( car lorsque je me met en spectateur : replay , suiveuse ou libre le son ne bugg pas)

Ou alors il faut que j'essaye un autre pilote pour ma carte son.
pourtant normalement j'ai bien installé le pilote recommandé pour ma carte son (CA0106)

d'autant que je n'ai pas de soucis de son avec d'autre jeu wine : sous civ 4 complete aucun pb (l'autre jours j'y ai joué une aprés midi complète ça n'a jamais buggé une seule fois).
sous excessive speed j'ai d'autres soucis mais pas de soucis de son.
ADSL TV pas de pb de son.




Sylvain_07 Woensdag 24 Februari 2010 om 20:29
Sylvain_07Anonymous

Re,
Pour mon Pb de son après différent test : je progresse :

jusque là le mon bureau de wine n'était pas émulé : je n'avais pas cocher la case : emuler un bureau virtuel pour trackmania. ( contrairement à civ 4 ou excessive speed ou les 2 jeux ne se lancent pas du tout si je n'émule pas un bureau virtuel) : vu que niveau graphisme pas de soucis comme celà je 'navais pas pensé a essayer celà jusque là.

j'ai donc cocher la case émuler un bureau virtuel.
ben pour mon problème de son ça y fait drôlement : il y a encore quelques gresillement par moment, mais rien de comparable jusque là et le son ne ne coupe plus.

j'ai le jeu dans une fenêtre au lieu de plein écran, mais c'est quand me bien plus agréable avec du son.
pour ce qui est du 5.1 : il faudra repasser aussi : si je me reconfigure en 5.1 : le son ressaute aussi au bout de à peine une minute : même pas le temps de lancer une course.

donc pour le moment le réglage optimal pour un fonctionnement pas trop mal pour moi est :

émulation d'un bureau virtuel 1440*900 ( si je monte plus haut en bureau virtuel le jeu a tendance à laggé)
et configuration de mes haut parleur en 2.1 au lieu de 5.1
et aucun pilote audio de coché dans Wine.

il faudrait des retours sur d'autre utilisateurs de cartes sound blaster notament sous ubuntu.

enfin j'espère que ce coup si ce sera stable et que demain les réglages qui marchent aujourd'hui continuerons à marcher.

je vous confirme celà dans 3 ou 4 jours.


Aangepast door Sylvain_07

BlondVador Donderdag 25 Februari 2010 om 9:59
BlondVador
Moderator

Bon, il semblerait que tu as trouvé une solution, c'est une bonne chose ;).

Désolé de ne pas avoir pu mieux t'aider.

Sylvain_07 Donderdag 25 Februari 2010 om 21:05
Sylvain_07Anonymous

De rien .

enfin bof mes réglages aujourd'hui ça n' a pas marché du tonnerre.

finalement je crois que la solution ultime c'est de lancer des mp3 à coté pour avoir de la musique.
c'est ce que j'ai fait ce soir. lol
Sylvain_07 Zaterdag 27 Februari 2010 om 20:32
Sylvain_07Anonymous

Aujourd'hui avec le smise à jours ubuntu on a eu de mises à jours de bibliothèques pour wine.

j'ai donc à la suites des mise à jours j'ai donc refait en réactivant le son dans trackmania avec ma sortie son paramétrée en 5.1 ; ça a trés bien marchait : je viens de jouer plus d'une heure 30 et pas de soucis .

je croise les doigt pour que la mise à jours de ses bibliothèques ai résolut mon pb.

Mais d'une autre cotés combiens de fois un jours ça à marché et plus les jours suivant que je ne serait pas étonné non plus si demain ça ne marche plus.

en attendant j'en profite se soir...
Sylvain_07 Maandag 1 Maart 2010 om 0:11
Sylvain_07Anonymous

Bon ben c'est quand me asse galère le son avec trackmania.
Si hier ça a bien marché aujourd'hui c'est moins bien :
pour le son il marche bien, par contre pas mal de lag que je n'ai pas eu hiers. j'ai beau baisser ma résolution toujours des lag à endrois fixes sur les courses.

ce que je n'avais avant.

j'ai donc désactivé le son et là plus de lagg.
donc à choisir 800/600 avec son et lag fréquent
ou 1920/1200 sans son et sans lagg , ben je choisit la seconde, tant pis pour le son : je met des mp3 avec Rhythmbox, et finalement on s'y fait