Het forum

Error installing components

Auteur Antwoorden
staticgerbil Woensdag 29 September 2021 om 7:27


I am running Play On Mac 4.4.3 on Big Sur 11.6 and I am unable to use the "Install components" UI to... install components.

I have tried installing many different components including gecko, dotnet, directx, dxvk and all of them give me a message saying

"An error happened during download.
Do you want to retry?"

I have also tried running scripts I have found on this website to install those same components using Tools -> Run a local script without success.

I have also tried using the Play On Mac Console to run commands like...

POL_Download_Resource "https://github.com/doitsujin/dxvk/releases/download/v1.9.1/dxvk-1.9.1.tar.gz" "09058abcd44d72a7555fac0a2254351a"

which results in repeated output like this...

[POL_Download_Resource] Message: Downloading resource https://github.com/doitsujin/dxvk/releases/download/v1.9.1/dxvk-1.9.1.tar.gz
cat: dxvk-1.9.1.tar.gz: No such file or directory
[POL_SetupWindow_question] Message: question answer: False

Manually entering that url into my web browser does get me the file, so the link is valid.

Does anyone have any ideas on solving this one?  For the most part I have been able to manually install components I need by finding appropriate windows installers and just running them with wine in my prefix but I'd love to be able to have the convenience of this Play On Mac UI.

Thanks for any help.

Dadu042 Zondag 3 October 2021 om 17:56

I think it's because of https intead of http frown.


A workaround is to copy the file into the folder 'ressources' (see: https://wiki.playonlinux.com/index.php/The_PlayOnLinux_Filesystem ).


Note: this kind of issue should be reported in the function's thread ( https://www.playonlinux.com/en/app-4398-POL_Install_DXVK_191.html ).

Aangepast door Dadu042