Het forum

Microsoft URLs have moved

Can't download libraries

Auteur Antwoorden
fhew Dinsdag 21 December 2021 om 6:05

I'm trying to install the 'Reflex' R/C Simulator. 

Their FAQ says it runs under PlayOnLinux but you have to install the directplay and directx9 libraries.

[I'm using POL v 4.4 on Fedora 35 (also tested and fails on F33 with its version of POL).]

So using the GUI I selected POL_Install_directplay and POL_Install_directc9, both return with the same error:


An error happened during download.


Obviously, because that URL no longer exists (same for the directplay library).

I've reviewed the entries in this forum for similar 'not found files', but none have helped.



Quentin PÂRIS Dinsdag 21 December 2021 om 8:45
Quentin PÂRISAnonymous

You're correct.

We need to find another URL where the file is hosted to fix the script

fhew Dinsdag 21 December 2021 om 15:23

OK, but where are the scripts located?

I tried looking for them, but so far, have come up empty.


Dadu042 Dinsdag 21 December 2021 om 19:21

On this website: Supported sofware -> Functions.

Aangepast door Dadu042

fhew Woensdag 22 December 2021 om 1:25

Thanks for your responses, but...

I was expecting to find them on my system so that the appropriate thing is executed when I select 'install this library'.

So, If I have to fetch this bash script, I think I read that I have to execute it manually via Tools->Run a local script?

  • Does this alter the install of POL on my computer so that the 'install some libraries' option works from now on? 
  • Do I still have to use the 'install some libraries' option?
  • Or do I have to do the 'Run local' every time I want a new POL based application? 

Basically... where is the documentation that describes this methodology?



fhew Donderdag 23 December 2021 om 1:41

I think my previous assumptions were all wrong, and so I still don't know what to do with an altered file mentioned in the earlier response.  I have found a version of the file at a new location (https://download.microsoft.com/download/8/4/A/84A35BF1-DAFE-4AE8-82AF-AD2AE20B6B14/directx_Jun2010_redist.exe) but:

 - What do you need to calculate and replace the old check value? (although if the file is the same, it shouldn't need changing)

and more importantly...

- How/where to install the new version of the file on my machine and/or how to execute it?

I did find a copy of the file in a hidden subdirectory of my home tree (/home/fhew/.PlayOnLinux/tmp/POL_Install_directx9) but editing that and trying to install the library using the usual 'install a component' mechanisms results in that file being replaced by the original from somewhere, somehow. 

Where is that original file that I need to update?


fhew Donderdag 23 December 2021 om 3:34

Upon further investigation and a session with Wireshark, I see that the POL_Install_directx9 file (and other POL functions) are downloaded from the other side of the world on every request, overwitting any local copy in your ~/.PlayOnLinux/tmp directory.  So any changes to references to new locations must be changed on that remote server.

codrus Dinsdag 11 October 2022 om 20:18


It's been nearly a year and PlayOnLinux is still trying to download directx_feb2010_redist.exe from the wrong url. Could you please update it to https://download.microsoft.com/download/8/4/A/84A35BF1-DAFE-4AE8-82AF-AD2AE20B6B14/directx_Jun2010_redist.exe since the installer errors out and stops! Even when you have gotten the download yourself... Why doesn't it ask?



Quentin PÂRIS Zondag 16 October 2022 om 12:55
Quentin PÂRISAnonymous

Fixed. Can you try?

anekfor Woensdag 30 November 2022 om 13:00

how to locate new urls? forpc.onl minecraft pocket edition pc

Aangepast door anekfor

benyaminl Maandag 5 December 2022 om 12:01

@anekfor, use the URL, put it in web.archive.org, and check if the dependencies is cached by wayback machine, and if it does, download the script, fix the install location, repeat the installation as it's

PlayOnLinux for rest of life. Thanks for the maintainer!