Het forum

The Witcher installing patch 1.4 - problems with registration

Auteur Antwoorden
Loreno Woensdag 24 November 2010 om 18:46

I installed The Witcher from DVD. I downloaded patch 1.4 and 1.5 and ran the script "The Witcher 1.5" from POL. First, it asks me for 1.4 patch. I click "Browse" and I select exe of 1.4 patch. Than the installator runs and asks me to register game first, so I run The Witcher, i choose "Register game" and I click Log in. When I write my Login and password i click "Log in". Than I get message: "internetexception 12037" and I can't log in. What should I do to install 1.4 patch?
GNU_Raziel Woensdag 24 November 2010 om 19:52

I've modified POL Installers so it will use wine 1.2.1 now, game reported platinum with this version.

You can manage wine version using POL to assign wine 1.2.1 to The Witcher and retry registration.
Loreno Donderdag 25 November 2010 om 17:37

I clicked Tools--Manage Wine versions. I added 1.2.1 to the list of installed versions and, in "My applications" tab, I changed wine version for The Witcher to 1.2.1.

But the problem is still actual. I get the same error when I click Log in.
What's wrong?
GNU_Raziel Vrijdag 26 November 2010 om 11:34

Hhhmmm...Are you an Ubuntu 10.10 user ? If yes, there is some kernel Ip protections you MUST disable to get registration to work, as for StarCraft 2, like this :

echo 0 | sudo tee /proc/sys/kernel/yama/ptrace_scope

It may be not the only one needeed to be disabled but since I do not use Ubuntu 10.10 I cannot help more on this.

Be also sure that you do not block with a firewall the ports that this game use to connect to the register server (I don't know them precisely but it can be easily found on the ofiicial game forum I think).

Aangepast door GNU_Raziel

Loreno Vrijdag 26 November 2010 om 19:45

Sorry, I forgot to write about my OS - I've got Ubuntu 10.04 32bit.
I'll try to find info about those ports