Het forum

League of Legends

Auteur Antwoorden
Jump to the page: 1 - 2 - 3 - 4 - 5 - 6 - 7 - 8
BlondVador Zondag 24 Juli 2011 om 14:04
BlondVador
Moderator

Merci bacatta pour tes informations.

J'vais voir c'que j'peux trouver sur ton premier lien.

Tuto :
http://na.leagueoflegends.com/board/showthread.php?t=973373

Aangepast door BlondVador


BlondVador Zondag 24 Juli 2011 om 19:10
BlondVador
Moderator

Je bloque au même endroit que sous Arch' mais avec un erreur différente...

Quentin PÂRIS Maandag 22 Augustus 2011 om 14:10
Quentin PÂRIS
Admin

J'ai réussi à avancer

Version de wine utilisée : 1.3.26-LeagueOfLegends
Paquet POL_Call installé : vcrun2005, d3dx9, AdobeAir, ie6, wininet, wintrust
Set_Managed Off
Lancer lol.launcher.exe, puis dans la foulé lollauncher.exe


J'arrive alors à me connecter, a me balader un peu dans les menus mais ça plante quand je cherche à jouer
bacatta Woensdag 7 September 2011 om 10:05
bacattaAnonymous

du nouveau ici: http://www.codeweavers.com/compatibility/browse/name/?app_id=6282;tips=1

Distribution : Fedora x64
Version de la distribution : 15
Carte graphique : Nvidia Geforce GTX460
Pilote de la carte graphique : 280.??
BlondVador Zaterdag 10 September 2011 om 21:57
BlondVador
Moderator

J'avais mis la source de ton lien sur ce topic en page 2.

http://na.leagueoflegends.com/board/showthread.php?t=648031&highlight=linux

Ca n'avait pas vraiment fonctionné pour moi. Sur ton topic ils recommandent la 1.1.27...

J'ai pas trop le temps pour essayer en ce moment mais si quelqu'un peut ça serait sympa :).


bacatta Maandag 19 September 2011 om 21:04
bacattaAnonymous

J'ai essayé mais sans succès :(

J'ai patché et compilé un wine 1.3.27 32bits. J'ai pu télécharger et installer le jeu sans problème depuis la version dispo sur le site officiel.
J'ai installé les dépendances via PoL (vcrun2005, adobeair, ie6 et d3dx9) + désactivé GLSL (tjs avec PoL).
Au lancement j'ai une petite image "League of Legends" au milieu de l'écran et puis plus rien ne se passe... au bout de quelques minutes d'impatience je kill donc le tout :/

Distribution : Fedora x64
Version de la distribution : 15
Carte graphique : Nvidia Geforce GTX460
Pilote de la carte graphique : 280.??
bacatta Zaterdag 24 September 2011 om 23:38
bacattaAnonymous

...
Lancer lol.launcher.exe, puis dans la foulé lollauncher.exe


J'arrive alors à me connecter, a me balader un peu dans les menus mais ça plante quand je cherche à jouer

Quote from Tinou


Merci pour l'astuce, j'en suis en fait au même point.

Distribution : Fedora x64
Version de la distribution : 15
Carte graphique : Nvidia Geforce GTX460
Pilote de la carte graphique : 280.??
BlondVador Maandag 10 October 2011 om 15:22
BlondVador
Moderator

Je repars à l'assaut, j'ai trouvé un topic sympa :
http://ace-client.net/index.php?id=3&tx_mmforum_pi1[action]=list_post&tx_mmforum_pi1[tid]=1120

J'essaye ça tout de suite.

Aangepast door BlondVador


BlondVador Dinsdag 20 December 2011 om 0:28
BlondVador
Moderator

Un p'tit up, ça semble être sur la bonne voie :

As mentioned in the Wine reviews, the way to run the official Client works. It patches. It runs. It plays matches.

Wine 1.3.33 or higher required. I tried 1.3.29 and I got GnuTLS errors when I tried to login.

Required DLLs:
-d3d9x (D3D in Wine doesn't work at the moment... it used to)
-vc2005
-wininet

IE6 is not required. The ACE client is not required. I'm getting about 15FPS in a tutorial match on a 9800GTX+ card.

Steps to run:
1. cd ~/Install-Directory/Riot Games/League of Legends/RADS/system
2. wine "rads_user_kernel.exe" run lol_launcher $(ls ../projects/lol_launcher/releases/) LoLLauncher.exe
3. Have fun!

I had to load the launcher multiple times after playing the first time. It seems the launcher is randomly unable to verify I am on the latest version and won't let me click on the Play button. After several start attempts it finally lets me hit Play.

Citeer


Ayant une veille bécane, je n'ai pas essayé, déjà que sur mon Windows ça galère..

http://appdb.winehq.org/objectManager.php?sClass=version&iId=19141

ulukyn Zondag 25 December 2011 om 22:18
ulukyn

J'ai tester mais par manque de temps je n'ai pas pu pousser les tests à fond.

En gros, avec wine 1.3.35 et d3d9x, vc2005, wininet le jeu se lance (parfois faut le quitter puis relancer pour pouvoir cliquer sur JOUER comme ça avais déjà été remarqué).
Une fois dans la fenêtre principale j'ai juste créer une partie d’entraînement et jouer 5min.
Avec une GTX 550 Ti je tourne à 20fps par défaut (mais y a ptêt moyen d'optimiser ça).

Je poursuivrai les test quand j'aurai plus de temps :)
BlondVador Donderdag 29 December 2011 om 20:12
BlondVador
Moderator

Donc ça semble être à peu près jouable à présent. C'est de bonne augure :).

Quentin PÂRIS Vrijdag 30 December 2011 om 18:09
Quentin PÂRIS
Admin

C'est le caractère aléatoire du truc qui me fait un peu peur
BlondVador Dinsdag 3 Januari 2012 om 18:21
BlondVador
Moderator

Dans tous les cas, pas de script tant que c'est pas réellement stable, encore un peu de patience donc :p.

aurelienbis Zaterdag 9 Juni\ 2012 om 23:55
aurelienbisAnonymous

Du nouveau ? Depuis PlayOnLinux j'ai installé 1.5.5-LeagueOfLegend.
Que faut-il faire ensuite ?
Merci
petch Zondag 10 Juni\ 2012 om 1:19
petch
Developer


Utiliser l'installeur dans la catégorie "En Test" ?

Aangepast door petch

FullMetal48 Vrijdag 29 Juni\ 2012 om 11:21
FullMetal48Anonymous

Sinon le jeu a l'air plus stable avec le précompilé wine-1.5.5-LeagueOfLegends (merci aux développeurs =) ). Sinon il y a toujours le bug de la boutique et le crash à la fin d'une partie.
nicoxxl Vrijdag 29 Juni\ 2012 om 13:35
nicoxxlAnonymous

Je suis sous archlinux, ça marche pas (impossible de se connecter) et je n'arrive pas à suivre ce que vous dites.
Je galère depuis plusieurs jours à le faire marcher donc pour ce bug spécifique, je vous propose de vous caler sur mon thread.
FullMetal48 Vrijdag 29 Juni\ 2012 om 15:00
FullMetal48Anonymous

Je suis sous archlinux, ça marche pas (impossible de se connecter) et je n'arrive pas à suivre ce que vous dites.
Je galère depuis plusieurs jours à le faire marcher donc pour ce bug spécifique, je vous propose de vous caler sur mon thread.

Quote from nicoxxl


sinon tu install PlayOnLinux et tu passe par lui pour installer LoL, ce sera plus facile pour toi
P.S.: Pour info, le jeu se trouve dans la section "test"
nicoxxl Vrijdag 29 Juni\ 2012 om 19:00
nicoxxlAnonymous

Déjà fait bien 10 fois dans la semaine, ça marche pas, je bug toujours sur le "impossible de se connecter sur PVP.net"