Het forum

Empty Game List/Not connected to the Internet message

Was Empty Game List POL 4.0.14

Auteur Antwoorden
Jump to the page: 1 - 2
omgimdrunk Woensdag 30 November 2011 om 8:32

Two notes from the staff, before reading more: 1) be sure you have the latest version of PlayOnLinux! 2) don't say only "doesn't work for me", read a bit the first page and try to provide a bit more information (such as network provider, wget output, dig results, using IPv6). Thanks :-)

I have seen this option come up in a few posts, I have tried the suggestions from:

wget -q "http://repository.playonlinux.com/version2.php?v=4.0.7" -T 10 -O- 

to renaming it.

I just can't seem to make this thing load the game list.

Aangepast door MulX

Quentin PÂRIS Woensdag 30 November 2011 om 13:19
Quentin PÂRISAnonymous

Does POL tell you that he cannot connect to the internet? (Btw, hello, thank you and goodbye wouldn't be too much)
omgimdrunk Woensdag 30 November 2011 om 18:53

I apologize for the lack of formalities, IRC and Forums usually request to skip the BAS salutation etiquette and just get down to brass-tax.

Hello! Thank you for creating one of the most useful applications for linux gamers!

Here is some output of the application being run:

$ ./playonlinux
rm: cannot remove `*': No such file or directory
[install_plugins] Message: Checking plugin: Offline PlayOnLinux...
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: Transgaming Cedega...
[install_plugins] Message: Checking plugin: Wine Import...
[install_plugins] Message: Checking plugin: Wine Look...
[install_plugins] Message: Checking plugin: Screen Capture...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
Exception in thread Thread-2:
Traceback (most recent call last):
File "/usr/lib64/python2.7/threading.py", line 552, in __bootstrap_inner
File "mainwindow.py", line 84, in run
File "mainwindow.py", line 61, in real_check
self.WebVersion = self.LastVersion()
File "mainwindow.py", line 58, in LastVersion
return os.popen('wget -4 -q "'+os.environ["SITE"]+'/'+fichier_online+'.php?v='+os.environ["VERSION"]+'" -T 30 -O-','r').read()
IOError: [Errno 4] Interrupted system call

Thank you for reviewing. :D

Quentin PÂRIS Woensdag 30 November 2011 om 18:57
Quentin PÂRISAnonymous

Can you type wget -4 -q http://repository.playonlinux.com/version2.php?v=4.0.14 -T 30 -O- in a terminal?
omgimdrunk Woensdag 30 November 2011 om 19:11

Yes sir,

ls -l
total 120
-rw-rw-r-- 1 jimmy jimmy 16768 Nov 19 20:59 CHANGELOG
-rw-rw-r-- 1 jimmy jimmy 35147 Nov 19 20:59 LICENCE
-rw-rw-r-- 1 jimmy jimmy 4563 Nov 19 20:59 TRANSLATORS
drwxrwxr-x 4 jimmy jimmy 4096 Nov 19 20:59 bash
drwxrwxr-x 5 jimmy jimmy 4096 Nov 19 20:59 etc
drwxrwxr-x 4 jimmy jimmy 4096 Nov 19 20:59 lang
drwxrwxr-x 2 jimmy jimmy 4096 Nov 19 20:59 lib
-rwxrwxr-x 1 jimmy jimmy 2286 Nov 19 20:59 playonlinux
-rwxrwxr-x 1 jimmy jimmy 1218 Nov 19 20:59 playonlinux-bash
-rwxrwxr-x 1 jimmy jimmy 1154 Nov 19 20:59 playonlinux-pkg
-rwxrwxr-x 1 jimmy jimmy 1087 Nov 19 20:59 playonlinux-shell
-rwxrwxr-x 1 jimmy jimmy 1154 Nov 19 20:59 playonlinux-url_handler
-rwxrwxr-x 1 jimmy jimmy 1471 Nov 19 20:59 playonmac
drwxrwxr-x 2 jimmy jimmy 4096 Nov 19 20:59 plugins
drwxrwxr-x 3 jimmy jimmy 4096 Nov 30 01:23 python
drwxrwxr-x 4 jimmy jimmy 4096 Nov 19 20:59 resources
-rw-r--r-- 1 jimmy jimmy 6 Nov 30 01:27 version2.php?v=4.0.7
omgimdrunk Woensdag 30 November 2011 om 19:19

maybe I am missing something, I noticed the version difference amd rm it.

Then when I run

wget -4 -q http://repository.playonlinux.com/version2.php?v=4.0.14 -T 30 -O-

No new file shows up in the dir
Quentin PÂRIS Woensdag 30 November 2011 om 19:25
Quentin PÂRISAnonymous

I just want to have the result of this command
omgimdrunk Woensdag 30 November 2011 om 19:37

No result, just goes to a new prompt
Quentin PÂRIS Woensdag 30 November 2011 om 19:43
Quentin PÂRISAnonymous

Can you remove the "-q" ?
omgimdrunk Woensdag 30 November 2011 om 19:52

wget -4 http://repository.playonlinux.com/version2.php?v=4.0.14 -T 30 -O-
--2011-11-30 12:52:02-- http://repository.playonlinux.com/version2.php?v=4.0.14
Resolving repository.playonlinux.com...
Connecting to repository.playonlinux.com||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6 [text/html]
Saving to: `STDOUT'

0% [ ] 0 --.-K/s 4100%[=====================================================>] 6 --.-K/s in 0s

2011-11-30 12:52:03 (1.60 MB/s) - written to stdout [6/6]
Quentin PÂRIS Woensdag 30 November 2011 om 20:24
Quentin PÂRISAnonymous

That's not normal. What can you see in "http://repository.playonlinux.com/version2.php?v=4.0.14" page ?
omgimdrunk Woensdag 30 November 2011 om 20:34

Quentin PÂRIS Woensdag 30 November 2011 om 21:49
Quentin PÂRISAnonymous

And you says that "wget -4 -q http://repository.playonlinux.com/version2.php?v=4.0.14 -T 30 -O-" does not answer "4.0.14" ??
omgimdrunk Woensdag 30 November 2011 om 22:27

No sir
Quentin PÂRIS Woensdag 30 November 2011 om 22:46
Quentin PÂRISAnonymous

Can you try without the "-4" ?
omgimdrunk Woensdag 30 November 2011 om 23:29

ok yes that returned 4.0.14
omgimdrunk Donderdag 1 December 2011 om 18:26

Any suggestions on what I should try next to get this working?
Quentin PÂRIS Donderdag 1 December 2011 om 21:44
Quentin PÂRISAnonymous

Yep, you have to modify all PlayOnLinux files and replace wget -4 by wget everywhere. It will be fixed in next version (I hope)
Aymeric P. Maandag 5 December 2011 om 23:25
Aymeric P.

Hi all :)

Quentin, may be we need to specify an user-agent to all wget commands.
From others previous problems reported, it doesn't seem to be a dns related bug neither an IPv4/v6.
I'm thinking that some provider are looking inside the layer 7 of all requests (like SFR, Orange, etc are doing on their EDGE network).
In case this isn't a well know browser they slowdown or simply block.
May be looking the HTTP Headers for people affected will also give us more information (with the "-S" option to wget).
By the way on my computer with a verbose output from wget I can't saw "4.0.14" but by redirecting the output to stdout and using tail, it's ok.

So, omgimdrunk (funny nickname ^_^)
could you post the output of :
wget -4 http://repository.playonlinux.com/version2.php?v=4.0.14 -T 30 -O /dev/stdout -S | tail
The "| tail" plus the "-O /dev/stdout" allow to be a bit more clear with the output, you could also redirect to a file using -O OutputToAFileSomewhereInMyComputerWhichContainTheOutputOfThisCrazyWget and paste the content after.

EDIT: Since there is more, and more message for this bug, I've change the topic title to more clear and push it to a post-it.

Aangepast door MulX

Former member.
buggyb Maandag 19 December 2011 om 12:03

I had the same problem "with empty games list", but it solved and looks like the FAQ:
1. I enabled add-on for off-line game's installation, it download something about 0.3 Mb and finished OK, I check "games list" - nothing, too bad!
2. And I forgot to disable "off-line" mod with add-on before making several next trying!
3. I turned it OFF, restart POL - it download updates on the next start, games descriptions are here, games list - OK (seems to be the very BASIC faq!)
Thank you for the fancy UI design and on-line support and help! =)

btw, it is PlayOnLinux 4.0.14 under Linux version 3.0.0-15-generic (Ubuntu 11.10 x86)

--- Be High & Free!

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com