"Refreshing PlayOnLinux" forever

Autor Odpowiedzi
Psy-Q Tuesday 14 February 2017 at 18:30

Running on Debian 9.0 (stretch, currently in testing) I used to be able to start PlayOnLinux just fine. I wanted to use it again yesterday after a dist-upgrade,  but now the main PlayOnLinux window shows an empty progress bar in the lower right and the status bar reads "Refreshing PlayOnLinux". This goes on forever as far as I can tell, I've let it run for hours.

Starting any games or programs doesn't work (the "Run" button can be pressed, but nothing happens). Pressing "configure" does bring up the configuration dialog, but I can't create any new virtual drives.

I tried moving the ~/.PlayOnLinux directory out of the way and starting fresh, but the same symptoms there. What could I try next?

Psy-Q Wednesday 15 February 2017 at 19:48

Solved it: It turns out the "netcat" package in Debian 9 now is a metapackage and pulls in both "netcat-openbsd" and "netcat-traditional". But PlayOnLinux doesn't work when "netcat-openbsd" is set as the system's netcat.

You can either use:

update-alternatives --config netcat

To set it to netcat-traditional or you can remove netcat-openbsd:

apt-get remove netcat-openbsd
rook2pawn Monday 13 March 2017 at 14:00

Thanks! Had the exact same issue using stretch/SID. I went with the remove netcat-openbsd, works wonderfully now. Kudos!

playonmacer Wednesday 18 April 2018 at 14:39

Hm Play on Mac seems to have stopped working with a similar issue. Maybe that's related since mac is based on BSD and comes with netcat.

m93a Thursday 6 June 2019 at 15:18

Hello, I'm on Ubuntu and I my POL also keeps loading forever (relevant AskUbuntu thread). The package netcat-openbsd is required by Ubuntu itself, but I also have netcat-traditional, which is required by POL. What should I do?

hirameki Wednesday 27 November 2019 at 18:26

It may occured by message mistake like URL below.

He said this bug caused by a blank {0<blank>} not {0}, it fails to display message and stop process to get list, and nothing change forever.
You can fix this problem by editing (in this case) file using msgunfmt/msgfmt command.(Linked in the blog)

I confirmed this problem and fix with editing file.

Change language setting to English may solve this problem. I think English message file not have this problem.

P.S> I registered this site today for reporting this.

Edytowane przez hirameki