Civilization IV: Complete Edition

Having some XML issues, anyone? ;)

Författare Svar
Jump to the page: 1 - 2
alcorsepol Wednesday 3 July 2013 at 23:06

Hello there!
Although I read the rules, this is still my first post, and I am still a little bit unsure if this is the right forum, but I have read around a bit and it seems ok :)

Anyway, so I know there is already an installer for Civilization IV and one for patching it to version 1.74, but I noticed there isn't a "complete" one for the Civilization IV: Complete package, so I decided to write one!

Now I have managed to install Civilization IV: Complete via my install script (Tried wine 1.4.1 and 1.6rc4 and the results is the same), and then also patch it with the latest Beyond The Sword patch (I didn't patch the main game or the first expansion, as that is usually not needed).

I have managed to play the game with Wine 1.4.1 before, but I didn't write down what I did back then, so I had to start from square one this time.

The first problem I'm facing, is that the game when loading (at the first splash screen), spams me with XML load errors (msxml3 was installed via pol directly after the Civ IV install was finished), but if I hold down enter for a few minutes, I can get passed them. And then the second issue is that ALL of the text in the whole game, is replaced with "TXT_KEY_<insert keyword here>", which I believe means that it can't parse the XML files that holds the text for the game. So my problem seems to lie with msxml3, but I can't figure out why it's not working.

I will try with installing plainly through wine now as well, and see where that leads me. But if anyone has an idea then I would greatly appreciate it! :)

Oh and, I am hosting all the patches on my own server, so the idea is that this install script will install Civ IV: Complete and then fully patch it, making it ready to play directly :D

Anyway so here's an image of the problem when entering the game

hangingman Thursday 4 July 2013 at 22:18

The Civilization IV Complete Edition here goes through the entire installation process and then returns to the beta test script and halts. It looks like a script error. A re-installation attempt is in process. It takes about two hours. I will post my results and difficulties here.
alcorsepol Thursday 4 July 2013 at 22:42

Using the following steps in Wine 1.6r4 (no POL), I was able to run the game with no problems.

* Install Civ IV: Complete, without any additions using Wine 1.6r4
* winetricks msxml3 d3dx9 msxml4 vcrun2003 quartz devenum corefonts lucida tahoma
* Update Beyond The Sword to latest version
* Run

Although if I did the same steps in POL (with .Net 1.1 instead of vcrun2003 as it doesn't exist among the packages), it didn't work, and I just kept getting XML errors.
I noticed that some dll-files (msxml.dll for example) in the POL extension were 0 byte, while the same files in my regular "main" wine extension (without POL), had content.
Although when I tried to copy them over, it became worse and it crashed completely instead, and didn't even get to the splash screen which did before.

I will collect all the required packages this time (vcrun2003 and so on), and try it one more time through POL and do it really as exactly as possible this time.

Also worth noting is that I made sure that all the override in winecfg were identical in both extensions, but that didn't make any difference.

The tests continue!
Somehow I don't feel satisfied until it successfully installs via POL so I can have it in the list with my other games xD

EDIT: Just did another quick test using POL and installing as identical as possible (still with .Net 1.1 though). No success, tests continue :)

* Wine 1.6r4
* Install d3dx9 .net 1.1 quartz devenum corefonts tahoma
* Install Civ IV
* Install msxml3+4
* Update
* Run -> Crash, XML error
* msxml3 -> built in
* Run -> Crash, XML load error (another error)

EDIT 2: Small update before I quit for today.
The setup above that didn't work, works if I download msxml3 and installs it manually to the extension.

There seems to be something fishy with the msxml3 that is installed via POL.
I'll rewrite my install script tomorrow and see if it works :)

Cheers for now!

Ändrat av alcorsepol

petch Friday 5 July 2013 at 0:53

PlayOnLinux uses the same version of msxml3 as winetricks (SP7). It uses the "native,builtin" override mode instead of just "native", I wonder if that could make a difference?
hangingman Friday 5 July 2013 at 2:11

Hi Alcorsepol

You are making better progress than I. The old beta Civilization IV script that uses Wine 1.1.43 was rerun twice. The last attempt produced a POL desktop icon for Civilization IV. It also produced the POL entry. The other three grames received a link on the desktop with out an icon. There is no entry in POL. I am no surprised by this as the script was intended for just Civilization IV.

Attempting to run the base Civilization IV results in a Wine error. The POL debugger shows

" wine: cannot find L"C:\\\\windows\\\\system32\\\\Civilization4.exe" "

So I copied the civilization4.exe and pasted it into the directory. Same results.

I will try your Wine setup. I agree with you entirely about wanting to use POL instead. I particularly like how Imperialism II works under POL. I would love to be able to clone the approach used there for other games.


alcorsepol Friday 5 July 2013 at 21:01

Oook guys, I managed to get a bit closer to the answer now :)

I have managed to get the script working with the following install methods

Wine version:  1.6.r4

1: Install Civ IV
2: Install Patch for BTS 3,19
3: Install msxml3 manually, (download the msi file and install, as the POL way just wont work, I tried every damn setting for it now and I can't get it to work).
4: set msxml3 -> native

I'm not sure if anything else is needed, but I have played for about an hour now and so far everything is working really well.

I'll finish the script like this and suggest it for testing in POL, but the problem with msxml3 really should be fixed. But for now I think it works really well (I'm already hosting all the files, and bandwidth wont be a problem on those servers so).
hangingman Friday 5 July 2013 at 21:43

If you would like a beta test, I am game.

has a statement that the 3.19 BTS patch is included in Civilization IV: The Complete Edition.
alcorsepol Friday 5 July 2013 at 21:47

If you would like a beta test, I am game.

has a statement that the 3.19 BTS patch is included in Civilization IV: The Complete Edition.

Quote from hangingman

Hmm strange, because it didn't load without the patch (the no DVD found issue).
Right now I'm having a small issue that I'm trying to solve :)

I can load the "Giant Earth Map Mod", but if I try to host a Multiplayer game with it, it crashes. Will see if I can solve it really quick and update the install script :)

EDIT: I'm currently getting an error, and it seems to be related to msvcr71.dll, but installing dotnet11 via POL and trying different overrides did nothing so.
I will keep digging into this until I solve it.

Here's the error (I'll probably post this on the wine page of Civ IV as well):

Ändrat av alcorsepol

hangingman Saturday 6 July 2013 at 0:41

The error results are way beyond my feeble abilities. I have not tried the multiplayer option. I did take a look at q4wine as a possibility but it wants the user to hunt down the wine libs. After several hours, I gave up and will uninstall it.
alcorsepol Saturday 6 July 2013 at 13:28

The error results are way beyond my feeble abilities. I have not tried the multiplayer option. I did take a look at q4wine as a possibility but it wants the user to hunt down the wine libs. After several hours, I gave up and will uninstall it.

Quote from hangingman

Well Civ crashes in the msvcr71.dll file as it breaks there and throws the exception, so I figured it would be a good idea to start there. And as suspected the error seems to be there, so I have been fiddling with the msvcr71 file now, and managed to get the mods working. I'm going to reinstall Civ IV now a few times with the new script, and make sure that everything is working, then I'll upload the script :-)

Cheers for now!
alcorsepol Tuesday 9 July 2013 at 1:55

The script has been posted for testing :)
hangingman Tuesday 9 July 2013 at 5:36

Super. I've copied the script and will start the first test tomorrow afternoon, 7/9. I will keep you posted on progress.
hangingman Tuesday 9 July 2013 at 21:58

The execution of the script was fast, probably due to the newer version of Wine. No problems there. Icons for Civilization IV, Warlords, and Beyond the Sword were present both on the Desktop and in Play On Linux's menu..

The desktop and Play On Linux lacked a Colonization icon.

A Desktop execution of the Civilization IV icon brought the game up. The Gnome Classic top and bottom panels overlayed the top and bottom of the Civilization IV screen area, including the main controls (Save, Load, etc...)

This forced a Cntl-Alt-Del to force a log out. One attempt needed a cold start to exit.

A very odd thing is that the mouse's position is assumed to be about 2cm off (lower). The cursor's position on the screen needs to be roughly 2cm above what you are trying to click on.

I will attempt Warlords and Beyond the Sword and get back to you with whatever In discover.


hangingman Tuesday 9 July 2013 at 22:10

Warlords and Beyond the Sword has the same issues. Neither game crashed on initial start. They came up just great.

I will wait on suggestions, new version, or whatever you direct.

alcorsepol Tuesday 9 July 2013 at 22:18

I got some technical feedback in another thread.
I'll update the script tomorrow morning (around 09:00 GMT+1) and re-upload it :)
hangingman Tuesday 9 July 2013 at 23:05

I am running about 5 hours behind you and so you will probably not see anything from here until the next day.

hangingman Saturday 13 July 2013 at 23:47

I got the full screen to overlay the top and bottom gnome panels.

monkeyking009 wrote "Go into wine configuration (winecfg) and disable "allow the window manager to control the windows" under the graphics tab. This should remove the unity launcher and panel in full screen mode."

It worked. I have no idea how to automate this during installation.


Ronin DUSETTE Sunday 14 July 2013 at 3:01

Its a registry entry. I dont remember which one, but you can add a .reg file during the install to facilitate this.

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Sunday 14 July 2013 at 8:30

Set_Managed "On"

But isn't that the default? I've always seen this used to disable management...
hangingman Sunday 14 July 2013 at 18:03

The disable "allow the window manager to control the windows" is not the answer. The act of changing this setting corrects the overlay problem for one session only. Using Gnome No Effects at login does correct the problem spanning all sessions.

The DVD has four games. Civilization IV, Warlords, and Beyond the Sword all get loaded to one common directory structure /cdrive/Program Files/2K Games/Firaxis/Sid Meier's Civilization 4 Complete. The fourth game Colonization gets loaded to /cdrive/Program Files/2K Games/Firaxis/Sid Meier's Civilization 4 Colonization. I believe this is why wine can not fine the game.