Trying to install skyrim

searched forums my issue isn't there

Författare Svar
gamelover85 Wednesday 30 April 2014 at 18:14


I get this error when trying to install skyrim

Error in source
Package installation will fail until you set /proc/sys/kernel/yama/ptrace_scope to 0

So I try to. It gave me this website to go to for instructions.

So I went to the website it told me to edit this


kernel.yama.ptrace_scope = 0

So I attempt to edit it. The OS tells me I don't own the file and can't save it. So, how do I own the file?

I have a steam account and my skyrim game is uploaded to it. I'd like to just download it from my steam account, I do have it on DVD but from past experience, even with the DVD it always wanted me to download it from my steam account. But I digress.

With this issue, its like a mountain to climb, and I got a feeling there are going to be several others to climb after I get over this one, if I do. Thank you.
izberion Wednesday 30 April 2014 at 18:23

You have to have root permission to edit the file.

Don't worry it has nothing to do with the game or Steam. That is a system file. It's telling you, your user doesn't have permission to edit the file. Try right clicking it and looking for an option to open as root, enter your password, and now you can edit and save it.

gamelover85 Saturday 3 May 2014 at 1:47

okay just a sec let me try that thanks for the help either way

Okay I tried it I clicked on properties and, in the permissions tab, it has NO option lol to change the permission. I can't run it under root. I'm stumped dude. No way for it to let me punch in my password. I'm the only user on this computer just so you know, nobody else uses it. So I assume I should be the owner... but then again I'm stupid when it comes to linux lol.... but at least i'm trying to learn it. I'm not a fan of windows.

Would it help if I told you that I'm using linux Zorin?

Ändrat av gamelover85

izberion Saturday 3 May 2014 at 7:31

It wouldn't be in proporties. When your right click is there no option to open as root or maybe a branch that says something about root options?

But I've never heard of that distro. Since it's Ubuntu based, you can try opening your terminal and entering:

sudo gedit /etc/sysctl.d/10-ptrace.conf

That's assuming you have gedit installed. It can be replaced with whatever text editor you have installed.

But what that command will do, is open that file as root, you just have to enter your password after entering it. Don't worry if the text for your password doesn't show up in the terminal, that's usually how it works.

Edit, save, done.

Ändrat av izberion

gamelover85 Saturday 3 May 2014 at 11:05

No there is no option in right-click menu. But what did work was the gedit suggestion. I opened the terminal pasted the command. Worked great. Thanks bunches your the best :)