Forum

Alan Wake runs but no in-game audio

Författare Svar
Jump to the page: 1 - 2
ayami Thursday 21 August 2014 at 20:36
ayamiAnonymous

I've installed Alan Wake on my Ubuntu desktop using POL and it runs fine, except that there is no in-game sound. The cinematics have sound, as does the opening splash page until the "press any key..." message. After pressing a key and going to the main menu all sound stops. If I start a new game the sound for the opening movie plays, but then once the first chapter starts all the sound is gone again.

I am using Alan Wake off a DVD, installed with the POL script, running in Wine through Steam, installed off the DVD rather than downloaded.

I'm using POL V. 4.2.2, downloaded from the repository. Ubuntu 14.04, with a NVIDIA graphics card (if that matters). Per the POL script for installing, it is using wine 1.5.0-raw3.

Everything runs fine, good framerate, keyboard and mouse work, but no audio in-game (but it is there in cinematics).

Thanks for any help.

booman Tuesday 26 August 2014 at 20:36
booman

There is a step-by-step guide on how to manually install Alan Wake here:  GamersOnLinux

I know that would mean starting over with the installation, but maybe there is something like a library that the script didn't install...

  • POL_Install_xact
  • POL_Install_d3dcompiler_43
  • POL_Install_d3dx9
  • POL_Install_vcrun2005

Othewise, definitely try a newer version of Wine like 1.7.24 or even stable 1.6.2

I have heard that dxfullsetup library can fix stuff like missing audio.

Strange that the game cutscenes has them but not the actual gameplay.

 

Try clicking "debug" when you launch and then post the output here.


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ayami Wednesday 27 August 2014 at 0:28
ayamiAnonymous

Thanks for the input, booman. Here is what I've done:

 

I followed that guide, with the addition of adding the Steam library since that is the version of the game I have. I also tried installing with wine 1.7.24 and 1.6.2, with a mix of 32 and 64 bit, and various libraries from that guide and as specified in the POL install script. In all these cases. The situation did change:

 

There was audio in game, but now none in the cinematics. Also, the mouse worked, but any keyboard activity caused the game to crash. However, the keyboard is fine in the Steam client; it only affects the game itself.

 

Following is the debug log immediately follow a crash from keyboard activity:

fixme:dbghelp:elf_search_auxv can't find symbol in module

fixme:dbghelp:MiniDumpWriteDump NIY MiniDumpWithHandleData

fixme:advapi:EventUnregister deadbeef: stub

– Repeated 4 times

fixme:msvcrt:__clean_type_info_names_internal (0x133a478) stub

fixme:msvcrt:__clean_type_info_names_internal (0x12e787c) stub

fixme:msvcrt:__clean_type_info_names_internal (0x132bf04) stub

fixme:msvcrt:__clean_type_info_names_internal (0xf98c0c) stub

fixme:msvcrt:__clean_type_info_names_internal (0xf1db04) stub

fixme:msvcrt:__clean_type_info_names_internal (0x3c0530) stub

fixme:msvcrt:__clean_type_info_names_internal (0x9de33c) stub

fixme:msvcrt:__clean_type_info_names_internal (0xa280c4) stub

fixme:msvcrt:__clean_type_info_names_internal (0x3fd6fc) stub

Setting breakpad minidump AppID = 108710

Steam_SetMinidumpSteamID: Caching Steam ID: 76561198145753396 [API loaded no]

fixme:imm:ImmReleaseContext ((nil), (nil)): stub

fixme:advapi:EventUnregister deadbeef: stub

– Repeated 9 times

 

As an experiment, I did a manual install with the components from the script: wine 1.5.0-raw3 (patched related to the input problem). This had the same result as install from the script, which looking at the online source I see has a line for "Set_SoundDriver "alsa""; I don't know if this might be related. I also on this install tried all the various libraries from the scripts and various guides, but that made no change: audio in cinematics, but not in-game.

 

Then I tried using Wine 1.5.9-raw3, so a newer version than the script but with the same patch, but that crashed when trying to login to Steam.

 

Per some suggestions elsewhere I also tried install additional DirectX libraries, as well as the DirectX installer provided with the game. None affected performance.

 

With the install from the script, this is the debug log through a brief session, including periods of no audio:

process 3580: Applications must not close shared connections - see dbus_connection_close() docs. This is a bug in the application.

[0826/144153:ERROR:network_change_notifier_win.cc(174)] WSALookupServiceBegin failed with: 8

[0826/144153:ERROR:gpu_info_collector_win.cc(103)] Can't retrieve a valid WinSAT assessment.

[0826/144209:ERROR:renderer_main.cc(227)] Running without renderer sandbox

[0826/144210:ERROR:renderer_main.cc(227)] Running without renderer sandbox

[0826/144211:WARNING:content_browser_client.cc(499)] No browser info matching frame process id 3 and routing id 1

[0826/144211:WARNING:content_browser_client.cc(499)] No browser info matching frame process id 3 and routing id 1

[0826/144211:WARNING:content_browser_client.cc(499)] No browser info matching frame process id 3 and routing id 1

[0826/144211:WARNING:content_browser_client.cc(499)] No browser info matching frame process id 3 and routing id 1

Setting breakpad minidump AppID = 108710

Steam_SetMinidumpSteamID: Caching Steam ID: 76561198145753396 [API loaded no]

IPC client is in my process, could/should be using an in-process pipe.IPC client is in my process, could/should be using an in-process pipe.Forced create of Win32Mutex but it already existed

Forced create of Win32Event but it already existed

Forced create of Win32Event but it already existed

[2014-08-26 14:41:52] Startup - updater built Aug 13 2014 14:18:40

[2014-08-26 14:41:53] Verifying installation...

[2014-08-26 14:41:53] Verification complete

[2014-08-26 14:42:53] Shutdown

 

So as it stands the closest to playable is still the script/1.5.0-raw3 install. All others crash or won't accept the keyboard. And no cutscene audio in the others.

booman Wednesday 27 August 2014 at 1:01
booman

Very important about the crash... You will need to disable the In-Game Community overlay
It is a problem with steam and not related to any version of Wine.

Steam Overlay

Steam overlay has been known to cause problems launching games.
Click Steam menu
Click Settings
twoworlds36.png 

Select "In-game"
Uncheck "Enable Steam Commuinty In-Game"
Click OK
twoworlds37.png 


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ayami Wednesday 27 August 2014 at 2:07
ayamiAnonymous

Ah, good progress! Disabling Overlay solves the keyboard crash in 1.7.x and 1.6.x. Now those versions run with in-game audio but no cut-scene audio. Disabling overlay makes for no change in 1.5-raw3 (script install). So I'm left with either ingame or cinematic audio, but not both.

booman Wednesday 27 August 2014 at 14:44
booman

Interesting, I'm surprised Wine 1.5.x actually runs Steam at all.  There was a point where an update broke all the Wine versions in Steam.  1.7.8 was the patched version and stable 1.6.2 also.  Anything newer than 1.7.8 worked as well, but anything older didn't.

Anyways, what is your setup for audio?  Are you using the integrated chip (AMD/Realtek/etc) or video card HDMI?

This may be a conflict between Alsa and Pulseaudio, but usually the symptoms are sporadic, scratchy audio or no sound at all.

This may be related to directx, but I don't see any error in you debug about it.

Go to Configure, click Install Components and try installing:

  • dsound
  • xact

or

  • dxfullsetup

† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Wednesday 27 August 2014 at 16:30
Ronin DUSETTE
Admin

"Very important about the crash... You will need to disable the In-Game Community overlay
It is a problem with steam and not related to any version of Wine."

 

If I am not mistaken, that issue has been corrected in newer versions of Wine. 

 

https://www.winehq.org/announce/1.7.8

issue 35030

 

You will probably need to request a Winebuild of wine 1.7.8 or higher with any needed patches, if there are any. 

 

I would try dsound first, as booman said, and then after that, I would check to make sure that you have all of your alsa 32-bit libs, as well as any "restricted" drivers for audio playback that your system might offer (like Ubuntu: sudo apt-get install ubuntu-restricted-extras ubuntu-restricted-addons).

Of course, a new, fresh manual install of Steam using Wine 1.7.8, and testing this again, whilst providing the full debug output (from start to finish).

Also:

"I'm using POL V. 4.2.2, downloaded from the repository. Ubuntu 14.04, with a NVIDIA graphics card (if that matters). "

Upgrade to 4.2.4. You can get it from our Download section. How are you running the audio to the speakers or whatever? HDMI or the onboard? Do you have the proprietary Nvidia drivers installed? You do not need to set the audio. You shouldn't have to do that. 

To me, it seems like a driver issue (if you are running audio through your graphics card), or some sort of missing library, but since we only have fractions of the debug output from the install and first run, it is hard to tell.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
ayami Wednesday 27 August 2014 at 16:47
ayamiAnonymous

More good developments:

I installed in wine 1.6.2, with dsound and xact, and was able to run with in-game sound and scratchy/echoed audio in cutscenes. It only works if wine is set to Windows XP; set to Windows 7 the cutscenes go silent again.

I am using the NVIDIA proprietary drivers. I have tests the audio through the HDMI and through a USB wireless headphones, and it has always been the same on both.

I installed more libraries to try and break it, including dxfullsetup, but it continued to work to this degree (good ingame sound and scratchy cutscene sound).

I will try your other suggestions and get back with more details.

booman Wednesday 27 August 2014 at 17:17
booman

Scratchy audio in cutscenese HAS to be pulseaudio.
Try this:

  1. Open /etc/pulse/daemon.conf
  2. change default-fragment-size-msec = 10
  3. to default-fragment-size-msec = 5

DJ - I am currently running Wine 1.7.24 with Steam and Assassin's Creed Brotherhood and the Overlay problem still exists.  I knew when I launched the game first time, then pressed ESC, and then it crashed.  As soon as I disabled overlay, it ran perfectly.


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Wednesday 27 August 2014 at 17:19
Ronin DUSETTE
Admin

"DJ - I am currently running Wine 1.7.24 with Steam and Assassin's Creed Brotherhood and the Overlay problem still exists.  I knew when I launched the game first time, then pressed ESC, and then it crashed.  As soon as I disabled overlay, it ran perfectly."

 

That is interesting. There must be a regression, or Steam just broke Wine again. Lol. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 27 August 2014 at 17:21
Ronin DUSETTE
Admin

It looks like it is a new bug, but a fix has been submitted, but not merged into this release. I am sure that the next bi-weekly release of Wine will have this fix included.

 

https://bugs.winehq.org/show_bug.cgi?id=35361


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
booman Wednesday 27 August 2014 at 17:25
booman

I haven't tried with Wine 1.7.25, so maybe the fix is there?

This would be super to use the overlay because some games like Borderlands 2 require the overlay to invite friends to your game.


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Wednesday 27 August 2014 at 17:27
Ronin DUSETTE
Admin

It looks like someone confirmed that 1.7.25 works with overlay, but some people are still reporting issues, so the bug is still open. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
ayami Wednesday 27 August 2014 at 17:42
ayamiAnonymous

For Alan Wake I installed the restricted add-ons and changed Pulse Audio's fragment size to 5, as suggested, but neither had any effect. I don't know if it helps, but the scratchiness is mainly a severe echo, many layers, that is rendering the sound pretty much unintelligable.

booman Wednesday 27 August 2014 at 17:58
booman

Dang, it was worth a try.  That is about the extent of my knowledge for pulseaudio.
There are some other things you can try, but they can affect other programs that use Pulseaudio too.

Have you tried installing another version of Nvidia drivers?

I have heard that newer/older versions of Nvidia can fix/break audio with HDMI


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
ayami Wednesday 27 August 2014 at 18:06
ayamiAnonymous

Oh, I already messed up this computer once by screwing around with video drviers, so I'd rather avoid that. I'll try some of DJ's other suggestions and do more research on the Pulse issue.

Ronin DUSETTE Wednesday 27 August 2014 at 18:08
Ronin DUSETTE
Admin

I have heard that about the HDMI audio, as well. To be honest, I have like, NEVER had an issue with Pulse being on my system. For instance, I run Ableton Live and Reason 5, using Pulse (most of the time, with winealsa outputting to jack, and jack outputting to pulse), and pretty much never have any audio issues. Which is why I am leaning toward something missing, in terms of a library or something. 

Can you run the program, and right after it starts goofing up, run

dmesg | tail

and see if it spits out any errors from the audio device. Post the results here, please. We will figure this out. lol. 

It is worth noting, that on winehq, I found :

 

HI, I fixed the audio issue installing directx from the game folder (Remedy Entertainment/Alan Wake/thirdparty/DirectX/DXSETUP.exe)

You can try that. Perhaps it has a particular version of it DX. 

For the keyboard issue, you need to use one of the patched Wine versions with the 'raw' patch. You can download these from a nice little list in: PlayOnLinux -> Tools -> Wine versions -> choose wine version, click the ">" button, and it should download and install it. Although, I do not see any very recent ones, so you may want to request that a newer version of Wine be built with that 'raw3' patch. At least that is what I was able to dig up. Hopefully this helps. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 27 August 2014 at 18:15
Ronin DUSETTE
Admin

 

Oh, I already messed up this computer once by screwing around with video drviers, so I'd rather avoid that. I'll try some of DJ's other suggestions and do more research on the Pulse issue.

 

sudo service lightdm stop
sudo pkill X
sudo apt-get install build-essential multiarch-support
sudo nvidia-installer --update -f
cd ~/Downloads
chmod +x nameofnvidiainstaller
sudo ./nameofnvidiainstaller

When it is done, you simply restart. If it fails for any reason, you can always:

 sudo apt-get install nvidia-current

Make sure, that when doing the install, if you are asked, to install the 32-bit libraries. 

Also, if you choose "Yes" when it asks if you want to build the driver with DKMS and it fails, re-run the installer, and choose no. The only thing is that you will have to run:

CTRL+ALT+F2
sudo service lightdm stop
sudo pkill X
sudo nvidia-installer --update -f

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
ayami Wednesday 27 August 2014 at 18:15
ayamiAnonymous

I saw that DirectX install suggestion also and have tried it across my different installations, but it hasn't helped anywhere.

dmesg doesn't show any activity, error or otherwise, when running the game.

Ronin DUSETTE Wednesday 27 August 2014 at 18:18
Ronin DUSETTE
Admin

hmmmmmmmm. I cannot remember how to check pulse/alsa logs. I am sure that they are located somewhere in /var/logs, but I have no clue. 

If you open POL, highlight the game in the main Window, and click "debug" to the left, could you post that output here? I am curious, if when debugging, it will spit out some more errors that are not usually spat to the terminal. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts