Tera.exe dies instantly after starting

The launcher is pretty much ok

Författare Svar
quaelgeist Sunday 14 September 2014 at 17:47

Hi Guys! Tera would be the final last reason why I would struggle with windows on my hard drive. Please help me to make it run! I will make pretty gifs for you to explain my error, because sadly, there is no crashlog or error output. That would help me. :(

What I did and what happended:

I told POL to install Tera, it downloaded Wine 1.7.17 64bit, asked me how fat is my GPU and how to install Tera. I aborted there, because I copied an existing TERA installation from a Windows hard-drive.

I copied the existing installation in my POL-drive to 

drive_c/Program Files (x86)/TERA

Replaced the existing tera-folder from the script with my own one.

I created a shortcut to Tera-Launcher.exe

Started Tera-Launcher I am from Europe and using the "Gameforge" Tera Launcher. European Retail version.

Downloaded all the updates which took a decade or two.

Logged in with my credentials

clicked play.

The Error:

An OSD or something with an Pink-Haired girl appeared. Disappeared after five seconds or so. And then there was nothing.

I can track "Tera.exe" with ksysguard. It starts shortly and then disappears.

this does appear in the debug-output when I click "play:"

err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": falsche ELF-Klasse: ELFCLASS64
err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": falsche ELF-Klasse: ELFCLASS64
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:gameux:GameExplorerImpl_VerifyAccess (0x1546b0, L"C:\\Program Files (x86)\\TERA\\Client\\Binaries\\TERA.exe", 0x2a2e78c)
fixme:win:EnumDisplayDevicesW ((null),0,0x2a2d478,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x2a2d218,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x2a2e918,0x00000000), stub!
fixme:msg:ChangeWindowMessageFilter 4a 00000001
fixme:dbghelp:elf_search_auxv can't find symbol in module
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)

And as promised, beautiful GIFs where you can track the error behaviour yourself:

(I think it would be annoying as f*ck to put an gif in here, so here is the link:   )


Does someone know that "error"? what can I do to identify that error? I have no idea anymore.

Ronin DUSETTE Monday 15 September 2014 at 1:26

Looks like you need the 32-bit version of libmpg. 


err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": falsche ELF-Klasse: ELFCLASS64

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
quaelgeist Monday 15 September 2014 at 13:38

Yeah, this had (probably) just something to do with the sound. I installed lib32-mpg123 and the error disappeared. But nothing changed. Game is still not starting.


quaelgeist Tuesday 16 September 2014 at 20:58

Here is the full debug-log created by POL. I commented 50.000 repeated lines. Can someone see any critical error in there?

I created a fresh POL device of Wine 32 and installed 

d3dx9 xact xinput winhttp

as recommended on wineHQ

Ändrat av quaelgeist

quaelgeist Friday 19 September 2014 at 0:26

I tried to change the GPU-driver from nvidia to nouveou, wich also did not help. Also bump!

Ändrat av quaelgeist