World of Tanks

How to install Aslain's Mod Pack on it

Författare Svar
drohr Saturday 29 November 2014 at 23:20

Ubuntu 14.10


I finally got WoT loaded on Ubuntu using PlayOnLinux with installed Wine and all the necessary layers it needs to run a Windows games. I have World of Tanks running .. graphics are .. not good until i find a good driver but i can play ok.


I run the game THROUGH PlayOnLinux, of course, and i am not familiar with how and where the game is loaded and where it is running from. I need to find the folder stucture so i can all some scripts and such to the game.


What i want to do is get Aslain's Mod Pack loaded on this. Anyone have any insights? Any solutions? 


Appreciate any help at all guys!




booman Wednesday 3 December 2014 at 0:52

I've never tried mods for World of Tanks, but it should be in your PlayOnLinux wineprefix folder:

/home/username/.PlayOnLinux/wineprefix/worldoftanks/drive_c/Program Files/World of Tanks

Somewhere in there...
Replace "username" with your login and the name of the wineprefix might be different.

Every time you install a game, PlayOnLinux will create another wineprefix with the name of the game.
So go poking around wineprefix and see if you can find the program files for your game

When you install a mod, you can probably download the mod, go to Configure, Miscellaneous Tab, click "Run a exe file in this virtual drive"

Then it should install in the proper place.

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
Loba74 Friday 23 January 2015 at 2:55

I have the same problem and the 1st thing I tried was installing the .exe through POL (Run exe...).

The problems begin right after choosing the installation file. Before I can see anything of the installation, POL shows me a window telling me that Wine seems to have crashed, but I should ignore the message, if the program runs anyway. The installation actually starts, but the 2nd problem comes up with the EULA. The window appears, but it's empty. The 2nd window after the EULA is empty too. Ok, now I'm not the guy who reads this things regularly, so clicking Continue continues actually the installation. But after choosing the installation folder, the installation crashes (it actually crashes not completely, but the routine can't continue due to the following error message):


Runtime Error (at 154:83):

OLE error 80040152, ProgID:


The only thing I can do is clicking OK, the folder choosing window reappears and I can repeat this game until eternity. The only other possibility is to cancel the installation. At least this works without any error message... ;)

Is somebody able to make use of this message? I suspect just one or a few modules to be added, but I can't determine which ones since my coding knowledge is kept within reasonable limits...

Hope for your answers, greez, Loba74


Ändrat av Loba74

booman Friday 23 January 2015 at 16:29

Sometimes installations require special DLLs and Libraries in order to install properly.

Since the error is something related to mxsml, try installing the Package:  msxml3

You can't run a "debug" with "run a .exe in this virtual drive" but you CAN put the exe in the World Of Tanks virtual drive, create a shortcut to it and then launch it with "debug"

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
Loba74 Friday 23 January 2015 at 22:36

Ok, 1st option doesn't work, either version 3, 4 and 6.

The alternative I'll try at the 1st possibility, I'll come back when I can find out more about the error. Or when I find a solution. smiley

Thanks and greez, Loba

booman Friday 23 January 2015 at 22:51

Ok, keep us updated.  I have a feeling that mods are just not going to work.  Maybe find out if mods can be installed by extracting folders from a zip instead of an exe.  Some mods are just game files in folders and all the exe does is install them to the proper folders.  So maybe you can do it manually instead of using an exe, but the modder will have to provide the files.

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
Loba74 Sunday 1 February 2015 at 14:37

Heureka!!! At least partial success!

I couldn't beat the mentioned OLE error. Extracting the .exe was not possible due to an all too new version of the installer, even not under a native Windows. So after not being able to load Aslain's, I tried other modpacks:

1. Diclovit's Modpack can be installed without errors, but the game keeps crashing with this modpack installed. 30 secs after starting a new round, the game closes, right together with PlayOnLinux and Wine. My programming knowledge is weak, so I didn't find out where it crashes. And I forgot to debug it before ultimately deleting it... *shame*

2. On the other hand, it will not be necessary, 'cause: Webium's Modpack finally works very fine under PlayOnLinux. It shows indeed an OLE error too while installing. Funnily it's exactly the same error message like Aslain's shows, just at another adress (110:93), and this installation continues without any further incident. Furthermore, I couldn't find a parameter what brings the game to a halt or let's it crash. Until now, all mods installed by the modpack are working very, very fine, even the included "Kriegstreiber" sounds. Astonishing! I didn't figure it to work with all the parameters!

It took me 3 days to figure this out; I don't even know anymore, how many times I restored the virtual drive from the POL vault in order to let's try this, let's try that... laugh

There's just one thing now that makes me curious: Why is the EULA window always empty? It was like that with all the three modpacks, independent of any errors. How I told already, I'm not the guy who reads this things regularly, I'm just curious about it.

Have a nice day and good fights to the WoT gamers! smiley


Edit: The game crashes too, but just once or twice a week. In fact, it's so rare, that I didn't manage yet to catch the error in the debugger... Guess, there are Windows users with more software incidents... ;) And even when I'm not able to find the error, I can live with that.

Ändrat av Loba74

booman Tuesday 3 February 2015 at 14:14

Awesome job!  Thats determination!  Its amazing what we will do to get a game running.

Strange that you get the OLE error for both modpacks and yet one works fine.  Since the Windows gamers get the same crashing twice a week or so, its probably fine.  I find that a lot as well.  Sometimes games crash and lots of mods can crash as well.  Just depends on the game, engine and modder.

Thanks for the update!

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
concorde_l Thursday 4 February 2016 at 19:46


Could anybody helps me to install WoT?

I've tryed with PlayOnLinux and I received this error:

File oes not match:

Local:   5343c1a8b203c162a3bf3870d9f50fd4

Server: bb25707c919dd835a9d9706b5725af58

What should I do?


petch Thursday 4 February 2016 at 20:24

Du är här: Index > PlayOnLinux > World of Tanks