Problems Changing Resolution in Supreme Commander

Supreme Commander - Forged Alliance is unusable after changing resolution

Författare Svar
xphere Thursday 20 August 2015 at 23:04

(First time posting here and I'm very very new to PlayOnMac. Forgive my ignorence. I'll try to get you all the relevant info the first time around here)


Software Hardware Details:

Macbook Pro 15-inch, Mid 2015

Intel Core i7


AMD Radeon R9 M370x 2048MB

Latest version of PlayOnMac using Wine 1.7.26

Software/Game : Supreme Commander - Forged Alliance


Thank you in advance for taking the time to read my post/question.



 I went through the PlayOnMac install wizard to install a non-listed program. I didnt do anything fancy (primarily because I have no fancy experience with PlayOnMac) The wizard asked for a setup file, it ran it, Supreme Commander installed apparently fine and when you run it, it performs very well. With one hitch, when you try to change the resolution from 1024x768 to anything else the results are just plain bad. Either game crashes or the game is mostly off screen or you just get an all black or all white screen. Playing this game at its default resolution is really not a very fun way to play it.


Things I've tried:

1. I went into Wine config for the app/game and changed the windows version from XP to 8. No resulting benefit.

2. I enabled Emulate a Virtual Desktop and set the size there to the resolution I wanted (2560x1440)  no change there either.

3. I went in to the appdata user directory and modified the games game.pref file to default to 2560x1440 but every time i launch the game the file reverts to 1024x768 thus defeating that effort.   :(

4. I've tried the script here:  and here

  - Unfortunately I can't use those because I dont have a CD ROM and i dont have a valid ISO to use. (i blame my retarded self for not creating an ISO from my scratched disk's. I only grabbed the files.)  I dont know enough about BASH or how to modify these scripts to tweak the above script either. So I'm at a loss for what my next step would be to try to make this work.

Thank you for your time. Please let me know what additional information I can provide.

Side note - I used the Star Wars - The old Republic installer in the listed menu and that works great. so at least I know my PlayOnMac install works.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to