Battlefield 2 Installation Issue

Författare Svar
CoolhandWarrior Monday 26 August 2019 at 10:52



Hi Guys,


Using BF2 on playonlinux for a while, i try to reinstall it recently, but it's a fail!

I try on Ubuntu and Debian and all the installation goes well, BF2, patch 1.41, 1.5, BF2hub.... all is ok and at the end it is impossible to launch it.

My last working installation was with this thread last february:


I try it with lot of differents wine version, but now it seems that i can't use old wine version(unable to open correct windows while installing)

And try it with my two differents CDRom (yes i have two CDkeys ;-)


That is the report of the bug, but i don't really know what to search? Is any one have an idea?


PS: I have still a working game on my laptop, i try to move it with vault but it fails to.




Unhandled exception: page fault on read access to 0x00000001 in 32-bit code (0x0032ed5a).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:0032ed5a ESP:0032ed4c EBP:0032ed38 EFLAGS:00010246(  R- --  I  Z- -P- )
 EAX:00000001 EBX:00000008 ECX:0032ed64 EDX:00000230
 ESI:00000230 EDI:00000000
Stack dump:
0x0032ed4c:  00000000 00000008 0032ed64 0032fd78
0x0032ed5c:  004013bb 004013bb 00000230 01d2802c
0x0032ed6c:  00da12c2 7b491400 00000008 0000000e
0x0032ed7c:  00000011 00000018 00000021 00000027
0x0032ed8c:  0000002d 0000002f 93929190 97969594
0x0032ed9c:  ffffffff 07e90480 fffffffd 07e90480
=>0 0x0032ed5a (0x0032ed38)
  1 0x7b490a5e K32EmptyWorkingSet+0x1d() in kernel32 (0x0032ed58)
  2 0x004013bb EntryPoint+0xffffffff() in bf2 (0x0032fd78)
  3 0x00401eaa EntryPoint+0xffffffff() in bf2 (0x0032fdc8)
  4 0x00402944 EntryPoint+0xffffffff() in bf2 (0x0032fe30)
  5 0x00402be8 EntryPoint+0xffffffff() in bf2 (0x0032fe78)
  6 0x00402c89 EntryPoint+0xffffffff() in bf2 (0x0032fe88)
  7 0x0083d61d in bf2 (+0x43d61c) (0x0032ff30)
  8 0x7b486fa2 call_process_entry+0x11() in kernel32 (0x0032ff48)
  9 0x7b488f35 start_process+0xb4() in kernel32 (0x0032ffd8)
  10 0x7b486fae start_process_wrapper+0x9() in kernel32 (0x0032ffec)
0x0032ed5a: xorb    0x0(%eax),%al
Module    Address            Debug info    Name (156 modules)
PE      330000-  354000    Deferred        bf2hbc
PE      360000-  379000    Deferred        zlib122
PE      380000-  3bc000    Deferred        novinthfx
PE      3c0000-  3fa000    Deferred        bf2voipserver
PE      400000-  af7000    Export          bf2
PE      b00000-  c83000    Deferred        dice_py
PE     2330000- 237d000    Deferred        bf2audio
PE     3690000- 38b0000    Deferred        bf2openal
PE     3e20000- 40bf000    Deferred        renddx9
PE     40c0000- 4102000    Deferred        textureatlasbuilder
PE     4110000- 4363000    Deferred        d3dx9_25
PE     4370000- 43b9000    Deferred        msvfw32
PE     43c0000- 43d3000    Deferred        pcregexp
PE     7e50000- 7f3d000    Deferred        pbsv
PE    10000000-10122000    Deferred        memory
PE    30000000-3006d000    Deferred        binkw32
PE    62340000-623a7000    Deferred        uxtheme
PE    62800000-6289d000    Deferred        usp10
PE    639c0000-63ae6000    Deferred        winmm
PE    64b40000-64b72000    Deferred        shcore
PE    65200000-655eb000    Deferred        ole32
PE    65980000-65997000    Deferred        version
PE    66640000-66689000    Deferred        msacm32
PE    66840000-6685d000    Deferred        msacm32
PE    66880000-66902000    Deferred        dxdiagn
PE    66cc0000-66e8d000    Deferred        ddraw
PE    67640000-676bb000    Deferred        msvcp71
PE    67940000-67a25000    Deferred        wbemprox
PE    68c40000-68d26000    Deferred        shlwapi
PE    6a300000-6a5cf000    Deferred        oleaut32
PE    6a900000-6aa40000    Deferred        setupapi
PE    6aec0000-6aecd000    Deferred        psapi
PE    6c0c0000-6c0f3000    Deferred        imm32
PE    6c2c0000-6c2e0000    Deferred        wsock32
PE    6cbc0000-6cc48000    Deferred        devenum
PE    6d5c0000-6d720000    Deferred        dsound
PE    6e680000-6e749000    Deferred        avifil32
PE    6e8c0000-6ebc0000    Deferred        comctl32
PE    6f3c0000-6f73a000    Deferred        quartz
PE    6fb40000-6fc62000    Deferred        d3d9
PE    6fdc0000-6ff48000    Deferred        rpcrt4
PE    70340000-703ac000    Deferred        mmdevapi
PE    70b80000-70bc4000    Deferred        msdmo
PE    70f80000-70f97000    Deferred        midimap
PE    71240000-7137b000    Deferred        kernelbase
ELF    7a800000-7a94c000    Deferred        opengl32<elf>
  \-PE    7a840000-7a94c000    \               opengl32
ELF    7b400000-7b853000    Dwarf           kernel32<elf>
  \-PE    7b430000-7b853000    \               kernel32
ELF    7bc00000-7bd57000    Deferred        ntdll<elf>
  \-PE    7bc30000-7bd57000    \               ntdll
ELF    7c000000-7c004000    Deferred        <wine-loader>
ELF    7caa5000-7cb34000    Deferred
ELF    7cb34000-7cb6d000    Deferred
ELF    7cb6d000-7cbac000    Deferred
ELF    7cbac000-7cbc3000    Deferred
ELF    7cbc3000-7cd46000    Deferred
ELF    7cd46000-7ce96000    Deferred
ELF    7ce96000-7d07b000    Deferred
ELF    7d0a9000-7d0bc000    Deferred
ELF    7d0bc000-7d0c3000    Deferred
ELF    7d0c3000-7d0e2000    Deferred
ELF    7d0e2000-7d0e9000    Deferred
ELF    7d0e9000-7d0ee000    Deferred
ELF    7d0ee000-7d11c000    Deferred
ELF    7d11c000-7d26b000    Deferred
ELF    7d26b000-7d280000    Deferred
ELF    7d282000-7d28c000    Deferred
ELF    7d28c000-7d2ac000    Deferred
ELF    7d2ae000-7d372000    Deferred        winex11<elf>
  \-PE    7d2d0000-7d372000    \               winex11
ELF    7d3cf000-7d3d9000    Deferred
ELF    7d3d9000-7d414000    Deferred
ELF    7d414000-7d461000    Deferred
ELF    7d461000-7d4a0000    Deferred
ELF    7d4a0000-7d563000    Deferred
ELF    7d591000-7d6a5000    Deferred        crypt32<elf>
  \-PE    7d5b0000-7d6a5000    \               crypt32
ELF    7d6a5000-7d7eb000    Deferred        ucrtbase<elf>
  \-PE    7d6e0000-7d7eb000    \               ucrtbase
ELF    7d7eb000-7d85b000    Deferred        dinput8<elf>
  \-PE    7d800000-7d85b000    \               dinput8
ELF    7d85b000-7d899000    Deferred        ws2_32<elf>
  \-PE    7d870000-7d899000    \               ws2_32
ELF    7d899000-7d8b3000    Deferred
ELF    7d8b3000-7d8e3000    Deferred        iphlpapi<elf>
  \-PE    7d8c0000-7d8e3000    \               iphlpapi
ELF    7d8e3000-7e304000    Deferred        shell32<elf>
  \-PE    7d920000-7e304000    \               shell32
ELF    7e304000-7e3f1000    Deferred        msvcr71<elf>
  \-PE    7e330000-7e3f1000    \               msvcr71
ELF    7e3f1000-7e4e7000    Deferred        msvcrt<elf>
  \-PE    7e420000-7e4e7000    \               msvcrt
ELF    7e4e7000-7e572000    Deferred        advapi32<elf>
  \-PE    7e500000-7e572000    \               advapi32
ELF    7e572000-7e6fc000    Deferred        gdi32<elf>
  \-PE    7e590000-7e6fc000    \               gdi32
ELF    7e6fc000-7e96b000    Deferred        user32<elf>
  \-PE    7e730000-7e96b000    \               user32
ELF    7e96b000-7e988000    Deferred
ELF    7e988000-7ea22000    Deferred        dbghelp<elf>
  \-PE    7e9a0000-7ea22000    \               dbghelp
ELF    7ee9c000-7eeb1000    Deferred
ELF    7eeb1000-7eecc000    Deferred
ELF    7eecc000-7efd2000    Deferred
ELF    7efda000-7f000000    Deferred        bcrypt<elf>
  \-PE    7efe0000-7f000000    \               bcrypt
ELF    e3de6000-e3f00000    Deferred
ELF    e48fb000-e4941000    Deferred        winealsa<elf>
  \-PE    e4910000-e4941000    \               winealsa
ELF    e4941000-e495f000    Deferred
ELF    e4977000-e498d000    Deferred        avicap32<elf>
  \-PE    e4980000-e498d000    \               avicap32
ELF    e498d000-e49e3000    Deferred        winspool<elf>
  \-PE    e49a0000-e49e3000    \               winspool
ELF    e49e3000-e4a26000    Deferred        dxgi<elf>
  \-PE    e49f0000-e4a26000    \               dxgi
ELF    e4c2b000-e6b44000    Deferred
ELF    e6b44000-e6c5d000    Deferred
ELF    e6c5d000-e6e25000    Deferred        wined3d<elf>
  \-PE    e6cb0000-e6e25000    \               wined3d
ELF    e7147000-e71a9000    Deferred
ELF    f7316000-f731e000    Deferred
ELF    f7342000-f73a8000    Deferred
ELF    f73b1000-f73b6000    Deferred
ELF    f73d6000-f73fb000    Deferred
ELF    f73fb000-f7488000    Deferred
ELF    f7488000-f74b4000    Deferred
ELF    f74b4000-f74bd000    Deferred
ELF    f74bd000-f74f8000    Deferred
ELF    f74f8000-f75db000    Deferred
ELF    f75db000-f75fb000    Deferred
ELF    f75fb000-f7627000    Deferred
ELF    f7627000-f762f000    Deferred
ELF    f762f000-f76be000    Deferred
ELF    f76be000-f76ca000    Deferred
ELF    f76ca000-f7775000    Deferred
ELF    f7775000-f7780000    Deferred
ELF    f7780000-f779d000    Deferred
ELF    f779d000-f77fc000    Deferred
ELF    f77fc000-f788d000    Deferred
ELF    f788d000-f78ea000    Deferred
ELF    f78ed000-f7911000    Deferred
ELF    f7918000-f794b000    Deferred        winepulse<elf>
  \-PE    f7920000-f794b000    \               winepulse
ELF    f7a01000-f7a0f000    Deferred
ELF    f7b11000-f7b17000    Deferred
ELF    f7b17000-f7cf5000    Deferred
ELF    f7cf5000-f7d16000    Deferred
ELF    f7d16000-f7d20000    Deferred
ELF    f7d21000-f7d29000    Deferred
ELF    f7d29000-f7d2e000    Deferred
ELF    f7d2e000-f7d39000    Deferred
ELF    f7d39000-f7d40000    Deferred
ELF    f7d44000-f7eff000    Dwarf 
ELF    f7f01000-f7f2b000    Deferred
process  tid      prio (all id:s are in hex)
00000008 start.exe
    00000009    0
0000000e services.exe
    00000023    0
    0000001a    0
    00000013    0
    00000010    0
    0000000f    0
00000011 plugplay.exe
    00000017    0
    00000016    0
    00000012    0
00000018 winedevice.exe
    00000020    0
    0000001f    0
    0000001e    0
    0000001d    0
    0000001c    0
    0000001b    0
    00000019    0
00000021 winedevice.exe
    00000026    0
    00000025    0
    00000024    0
    00000022    0
00000027 explorer.exe
    0000002c    0
    0000002b    0
    0000002a    0
    00000029    0
    00000028    0
0000002d bf2hub.exe
    0000002e    0
0000002f (D) C:\Program Files\EA GAMES\Battlefield 2\BF2.exe
    0000003d    0
    0000003a    0
    00000039    0
    00000038    0
    00000037    0
    00000035   15
    00000034   15
    00000033   15
    00000032    0
    00000031    0
    00000030    0 <==
System information:
    Wine build: wine-4.14
    Platform: i386
    Version: Windows 7
    Host system: Linux




Ändrat av CoolhandWarrior

CoolhandWarrior Thursday 17 October 2019 at 11:11

Lo all,


Quite buisy... this days...


While copying playonlinux folder on another PC, sometimes it works, some time not....

It work on my PC with debian

and don't work on my laptop with ubuntu....


I don't have any solution...


see you... :-)

Ändrat av CoolhandWarrior

Dadu042 Thursday 17 October 2019 at 12:00

Nice for the feedback.  Perhaps this may help a bit: How to Read Debug Logs .

CoolhandWarrior Saturday 8 February 2020 at 8:46

Thanks Dadu042!


Hi everyone,

Find the solution damn idiot!

Often switching from ubuntu to debian to other linux. Maybe ubuntu is more automated.

On my laptop for example, on debian, i install playonlinux, but i've just find out that only playonlinux is installed and all wine libraries are missing!

So i copied all my .playonlinux directory from my PC to my Laptop for example, next i install playonlinux by a wrong way, and in the settings of a game from my old directory i see wine 3.2 is installed, but it is not!

And it is quite difficult to understand because playonlinux open a window when you launch your game and say wine or playonlinux has crashed and can't launch your app

So the write way:

- install your graphic drivers

- install wine and playonlinux

-install your game by your CD or DVD

- or replace your .playonlinux directory by the one you have copied on your other computer



Ändrat av CoolhandWarrior

booman Wednesday 19 February 2020 at 16:28

Nice!  Glad you got it working.

I would like to add the following...


Install in this order:

  1. Stable Wine
  2. Xterm
  3. ia32-libs
  4. PlayOnLinux 4.3.4
  5. Overrides:  corefonts, d3dx9, tahoma
  6. Copy all files and cab files from CD/DVD ROMS into a folder
  7. Install from the folder with setup.exe
  8. only install patch 1.5 (includes no CD executable)


There is also a shader fix for those black squares that appear on the ground.

  1. Sign up on the Forum
  2. Download a new "" (attached at the bottom of the post)
  3. Navigate to the mods directory C:\Program Files\EA GAMES\Battlefield 2\mods\bf2\
  4. Rename (or delete at your own risk)
  5. Copy new to the same directory
  6. Delete the Battlefield 2 cache folder: Documents\Battlefield 2\mods\bf2
  7. Launch Battlefield 2 and run a simple singleplayer level to recompile shaders

Ändrat av booman

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
mastablasta Sunday 28 February 2021 at 20:48

I hope you don't mind attaching myself here. it's the most current BF2 on linux post i could find. I managed to install it well, however i have controls issue and i tried all sorts of things i could find online and could not resolve it.

install went fine as did the patching to 1.5. i then ran it and added mod that loads 64bit maps to single player (BF2ALL64). the mod switching runs fine and all. but the issue is that mouse on tank gun and anti air is super slow. so the tank turret turns only a little bit and then stops. it looks like the game thinks i am using that special controller they added support for in 1.5.

so i tried reseting controls to default, but it didn't help. mouse overried and virtual deskotp solved mouse issue on sleection screen but again it doesn't work on tank turret. i also tried to reset profiles. i tried increasing speed, increasing sensitivity, changing DPI on mouse, increasing controller sensitivity in game, disabling joystic in registry... nothing works. any ideas? i assume none of you had this issue since i can't find any post detailing it? i checked wineappdb, issues (similar) reported on windows etc. i just can't find any solution for this.

btw thanks for the shader fix. i think if you set terrain to low, it also resolves it.



booman Sunday 28 February 2021 at 21:13

Yeah, this is a common issue.  It ight still be related the the virtual desktop.

  • Make sure your game is in Fullscreen
  • Make sure Virtual Desktop is enabled
  • Make sure "Automatically capture the mouse in full-screen windows" is checked in the Graphics tab in Wine Configuration.

That may fix the issue.  Really sounds like the mouse is leaving the window while playing.  I noticed the tank cannon is definite slower, but you can also adjust the mouse controls for vehicles in-game too.

Maybe try a newer version of Wine:  6.0 64-bit or 6.3

Even staging versions might have a fix for it.

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
mastablasta Saturday 6 March 2021 at 9:45

in graphics tab settings all options have boxes checked.

staging has worse performance.

i went back to system and i tried cleaning all directx libraries. i made sure to run the game in same resolution and in full screen (and i am launching mod):

+modPath mods/bf2all64 +menu 1 +fullscreen 1 +szx 1280 +szy 1024

i removed the profies and recreated them.

the game runs really well and i seems that mouse settings for player (so oursite of any vehicle) are now taken into acocunt.

but tank turret and APC turret are still super slow or hardly moving. the funny thing is because the machinegun on tank (the one outside) is working well. also other MG like th eone in chopper, on boat all work. anti air allied is moving slow, but MEC and china is normal.

to me this look liek spearate setting is sued for specific turrets and i don't know wher eto find it. the .con files are a bit confiusing as you can see duplicated settings in various files. so it is hard to say which one is master. and also what they are actually setting. for example in game folder (not the one in documents) there are mod fodlers and in default game there is a special settings file ( that has two lines added for mouse setting
rem *** Additional variables***
game.setLandSeaKeyboardSensitivity 0.500000
game.setLandSeaMouseSensitivity 0.250000
game.setLandSeaMouseInvert 0

how is landsea suddeenly the same and what do these affect. the game is rather strange as it has so many copies of settings. if you ask me there should be onyl two - master setting (defaults) and user setting


mastablasta Monday 8 March 2021 at 13:56

more tests - i reinstalled (fresh install) with lower patch only (so only 1.41). same issue on single player, but:


- no issue on multiplayer (LAN)

- no issue on single player if resolution is set to 800x600.


anything i am missing here in the settings? i tunred off virtualdesktop as it showed better result. no mouse warping ovverid or simialr. i do have mouse acceleration in KDE settings. mostly i would switch to raw input when in games.


i moved the installed virtual disk to Kubuntu 20.04 but with AMD GPU chip. resolutuion was not stretched to fullscreen and the game crashed when loading. so i will do a fresh install over there as well when i have the time. just to see what's up. it would be good to have 1.5 patch working well as it has more maps.

booman Monday 8 March 2021 at 21:27

Have you just tried Battlefield 2 vanilla and tank turret movement?

I wonder if its the All64 mod that is causing the issue?

Fresh install is always a good idea, specially with wineprefixes and Wine.

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
mastablasta Monday 15 March 2021 at 10:30

so we did some more testing over the weekend and vanilla or modded is acting this way. as soon as i move to non native resolution i get the propper movement. so i gues i can lower the resolution and feel like a pro gamer doing it. :-D movement is also not an issue if i connect to local server. i think we ened to try the 1.5. patch again.


we also did some lan games with bots and i got huge ping spikes and network lag. this would cause movement of units back and forth and jeeps diving into ground or units standing while being reported killed. could this be something connected to direct play or something like that that could be missing? i checked and some people did have thi ssisue but on multiplayer servers.

i wonder it if would help if we ran dedicated server?

also (offtopic form Play on linux) shouldn't bots be joining coop lan game?

booman Wednesday 31 March 2021 at 1:06

That is a good question, must be something with 64 players and syncing over the network.

I've never actually tried a 64 player map with a mod that adds bots in Linux.

Not sure the limitations of Wine in this scenario... but I'm sure there is going to be some kind of bottleneck.

But yes, the bots should be joining if it is considered a co-op map by Battlefield 2

Hopefully they all retain their paths

† Booman †
Mint 21.3 64-bit | Nvidia 535| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained