[ISSUE] Lineage 2 High Five on Private Server

Maybe one of the only things that make me keep a Windows installation today

Författare Svar
Hexploder Tuesday 28 July 2020 at 19:50

Hi everybody, this is my first post here and also my first time using PlayOnLinux or even Wine besides some intents a few years ago, so my knowledge about this topic is a bit (more than a bit) low and also maybe my english doesn't help I will do my best to explain.

So, I always tryed to use Linux and stay on it but I always tend to play the most annoying games to run on Linux, today with PlayOnLinux, Lutris and Steam I know that the game is coming close to an end but this old games on private servers will always be an issue I guess. I just want Path of Exile and Lineage 2 to go full Linux today and I know that Path of Exile apparently works like a charm but didn't test it, today I need Lineage 2.


Information about my setting:

Distro: Pop! Os 20.04 | nvidia version

Full PC Specs: Ryzen 7 3700X | 32 Gb RAM 3200 Mhz (16x2) | ASUS ROG RTX 2060 | Gigabyte X570 AORUS ELITE | NVME Samsung EVO 970 Pro+

Desktop: KDE Plasma

So basically what have I done?.

I installed the game client with the official installer for the version needed in this private server, then I downloaded a "Pre-installed all parched" version of the game, because the game need to be patched for this particular server like any other private server, so the idea was to install the game, erase all files in

$HOME/.PlayOnLinux/wineprefix/l2h5/drive_c/Program Files/NCsoft/Lineage II/

And then put the preinstalled all patched version, I also tryed just patching what it was needed to be patched but same result.

Point of this game and everything is that when I ran the ../Lineage II/System/L2.exe first it start the "Hacking prevention software" the StrixPlatform, this apparently works because I see the splash and the progress bar in the bottom right but after that nothing happens, well PlayOnLinux says it crashed but testing it with Lutris or just Wine nothing happens, so I ran it in debug and found this errors:

[07/28/20 13:29:18] - Running wine-5.13 l2.exe (Working directory : /home/hexploder/.PlayOnLinux/wineprefix/l2h5/drive_c/Program Files/NCsoft/Lineage II/System)
006c:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\wineusb": c0000142
003c:fixme:service:scmdatabase_autostart_services Auto-start service L"wineusb" failed to start: 1114
0024:err:module:LdrInitializeThunk "engine.dll" failed to initialize, aborting
0024:err:module:LdrInitializeThunk Initializing dlls for L"C:\\Program Files\\NCsoft\\Lineage II\\System\\l2.exe" failed, status c0000005

I searched for an answer but couldn't really find anything specific and my knowledge about this is not enough to figure it out by myself.

BTW, when installed this I followed other people that get the game working (not for this particular server) and they say to install the following which I did:

- corefonts
- dotnet20
- msxml4
- vcrun2008
- Tahoma

And I did this all on a 32 bits prefix, cause the game is a 32 bit game.

Any help help would be much appreciated.



Tryed with wine 2.14 which was recomended, when I did that "Wine Gecko" tryed to installed but after the progress bar completed nothing happens and freezes the window so I have to manually close it because it did not respond. Anyway, after that I tryed again but a similar error arises again.

[07/28/20 14:34:19] - Running wine-2.14 l2.exe (Working directory : /home/hexploder/.PlayOnLinux/wineprefix/l2h5/drive_c/Program Files/NCsoft/Lineage II/System)
err:module:load_builtin_dll failed to load .so lib for builtin L"winebus.sys": cannot open shared object file: No such file or directory
err:winedevice:async_create_driver failed to create driver L"winebus": c0000142
err:module:attach_process_dlls "engine.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\NCsoft\\Lineage II\\System\\l2.exe" failed, status c0000005


Despite I installed dotnet20 with POL in the wine configuration libraries tab like the others.


Ändrat av Hexploder

Dadu042 Tuesday 28 July 2020 at 23:21

Does this page helps ? :

I recommend Wine v2.22 minimum.


Ändrat av Dadu042