Villagers & Heroes Won't Work on MacOS Big Sur

POM 4.4.2 will not open Game File

Författare Svar
rahmmie Friday 23 April 2021 at 1:03

Hiya, and thanks in advance for taking the time to read this and give it a thought.  

So, I have been using POM 4.3.4 and a direct download from the website for the game Villagers and Heroes.  I installed it manually and had no problems adding it to PlayOnMac and then when I clicked on the game name in the window it game the option to run the program, so I did.  It would normally crash and I would get a message that it had crashed but if I waited for about a minute, the game would actually open and I was able to play it without any problems (of course, I also got the message that there was a new version of PlayOnMac but I didn't update since my computer was too old for it

(this was with a mid 2011 iMac using MacOS High Sierra 10.13.6


Alas, I am now working on a Late 2015 27" iMac with MacOS Big Sur 11.2.3 and I am using the Play on Mac that I downloaded from It is POM 4.4.2.  I followed exactly the same procedure, I downloaded the POM 4.4.2 and installed it.  After that I did a manual installation of the file VHSetup.exe that I downloaded directly from the Villagers and Heroes website (the PC file).  I installed it using the instructions for installation of files not in the list.  Created a new virtual drive for VillagersAndHeroes, did not pick any of the options for Wine so it could upgrade anything that was needed as you can see below

Before Installation of VHSetup.exe

And as you can see, it finished installing without a problem.  As per the instructions, I DID NOT launch the game, I just finished the installation.  PlayOnMac asked me if I wanted to create a shortcut and I did for

Installation Finished


After it finishes, the pop up window closes and I can go back to POM where Villagers and Heroes is now installed and I click on run.  However, when I do that it opens a strange looking window with a couple of exe files.  Window that opens when I try to run the program



The only thing I could think of doing was double clicking on the VHLauncher.exe and POM starts downloading all the game files as an archive and then the game decodes the files and installs itself up to 100%.  I get the game fully installed and ready to click on "play".  I've included a pic of the Wine configuration, which I left as it was, didn't change anything




Ready to hit play


This is what the main window of POM looks like

POM main window

When I run the VillagersAndHeroes program directly I get a message saying Error in main
Villagers and Heroes crashed. and the debug log says it could not open the program and yet I have the window that says the game downloaded and was ready to play.  The Debug log is:

[04/22/21 16:20:00] - Running wine- regedit (Working directory : /Applications/

[04/22/21 16:20:00] - User modified something in the registry manually

0035:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.


--- running delta on appropriate versions


--- verifying md5s




--- verifying...


[04/22/21 16:20:18] - Running wine- control (Working directory : /Applications/


--- updating manifest and fileStore




took 357.44 seconds


[04/22/21 16:31:19] - Running wine- start.exe /wait /unix $target (Working directory : /Users/rahmmie/Library/PlayOnMac/wineprefix/VillagersAndHeroesVirtualDrive/drive_c/Program Files (x86)/Villagers 003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

003a:fixme:exec:SHELL_execute flags ignored: 0x00000100

Application could not be started, or no application associated with the specified file.

ShellExecuteEx failed: Success.


When I try doing the same thing with the other option, the VHLaunch.exe runs, agains checks all the game files and presents me with the pop up window for the game where I have to click on "PLAY". However, when I click on play, the window just disappears and I get a message that says "Error in main
VHLauncher crashed.
Select its shortcut and click on "Debug" in the side panel to get more details." 

The debug log is as follows:


04/22/21 16:43:06] - Running wine- VHLauncher.exe (Working directory : /Users/rahmmie/Library/PlayOnMac/wineprefix/VillagersAndHeroesVirtualDrive/drive_c/Program Files (x86)/Villagers and Heroes)

000b:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.

000d:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.

0010:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.

0017:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.

001d:err:plugplay:process_IOService_Device object 0x9403

001d:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x9407

001d:err:plugplay:process_IOService_Device object 0x650b

001d:err:plugplay:process_IOService_Device object 0x9207

001f:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.

0025:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.

0009:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

0029:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform

0029:fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot

0029:fixme:toolhelp:Heap32ListFirst : stub

force unzip =  False


errorStatus is forcing a verify


patcher: verifying =  True


--- updating manifest


got new version from url: 56392


version =  56392


URL =, fname = AMysticalLandSAC/common/newManifest.xml



--- scanning for chunks to get or unzip


--- downloading bad or missing chunks


--- verifying md5s




-- verifying...




--- updating manifest and fileStore




took 91.71 seconds


I tried restarting my computer in hopes that the restart would allow the files to work and I would be able to play but nothing.  I get stuck at the same point every single time.  The game downloads and then it unzips the files.  Finally it checks all the files are there, it shows 100%, and it gives me the option to click on "Play" 

However, as soon as I click Play, the pop up window disappears.   I also tried creating a 32 bit POM when the 64 bit didn't work.  


I've even gone into Configuration for the programs and on the Wine tab I used "repair virtual drive" and I got a pop up window telling me wine was updating and installing all missing elements but despite that, it still does not work.  I've researched as much as I could but I. haven't been able to find an answer.  I'm. just curious, did the new version of Play For Mac stopped working for MacOS Big Sur.  Any suggestions on what I could try?  I don't want to have to buy Bootcamp just for one game but it's driving me insane 


Thank you for reading this novel I've written here.  I hope the images are of some help.  And again, thanks in advance for your help

Dadu042 Friday 23 April 2021 at 13:41

This  game should work on BigSur by using Crossover:

rahmmie Sunday 9 May 2021 at 17:02

Thank you so much Dadu042.  YOu have saved a chronic insomniac's life :P

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to