Forum

Oblivion et ses add-ons

Författare Svar
Jump to the page: 1 - 2
GNU_Raziel Wednesday 20 June 2007 at 16:38
GNU_Raziel

Version de wine : 0.9.39
Distribution : Debian
Version de la distribution : SID (Unstable)
Carte graphique : Nvidia Geforce 7800GS (version 512Mo)
Drivers de la carte graphique : 100.14.9
Commentaire :
-Si vous n'avez pas l'addon-on Shivering isle il est FORTEMENT recommandé de patcher le jeu avant de l'utiliser.
-Si vous avez l'add-on Shivering isle le jeu sera automatiquement patché, pas besoin d'en rajouter.
-Faites très attention, n'activez pas d'options graphiques, cela fera planter le jeu !!!!
-Vous pouvez en revanche en désactiver autant que vous voulez, c'est même recommander si vous n'avez pas une config dernier cri

Tweak :
1-Le mod Oscuro's Oblivion Overhaul permet de réduire presque totalement les crashs wine (et oui il y en a, et c'est totalement aléatoire d'un PC a un autre) !!
*le mod :
http://jorgeoscuro.googlepages.com/
(Remarque : Bien LIRE les instructions d'installation !!!!!)
*La traduction FR :
http://forum.wiwiland.net/index.php?showtopic=32099

2-Ce patch non-officiel corrige la traduction française lamentable de ce jeu :
http://wiwiki.wiwiland.net/index.php/Oblivion_:_PNOO

Ändrat av GNU_Raziel

sral Sunday 1 July 2007 at 13:32
sralAnonymous

Bonjour gnu_raziel.
J'ai installé oblivion, sa fonctionne mais la peau des personnages et les items dans le jeu ont des couleurs bizarre et sont un peu transglucide, t'a le même résultat ? Si non, sa ressemble a quoi chez toi et avec quels options graphique ? (j'ai enlevé la luminosité).

Merci pour le script


Edit: voici ma config:
GPU: nvidia 6600 gt
CPU: amd athlon core venice 2.2 ghz

voici un screen :

Ändrat av sral

GNU_Raziel Sunday 1 July 2007 at 14:18
GNU_Raziel

Euh non je n'avais pas ce problème, ce jeu (et ses addons) était un prêt d'un ami donc je ne le possède plus a l'heure actuelle, cependant je n'avais pas de problème de textures et j'avais laisser les options graphiques par défaut.



Assure-toi d'avoir les pilotes graphiques les plus récents pour ta carte (au moins le 9755 ou le 100.14.9 si ce dernier est enfin arrivé sur les dépôts) et d'avoir la version 0.9.37 au minimum (pas la 0.9.38 car celle-ci cause tout un tas de problèmes)
Tophu Sunday 1 July 2007 at 15:05
Tophu

J'ai eu ce problème (sauf qu'il y avait le décor dans le lot) et ça c'est résolu tout seul en jonglant d'un préréglage à l'autre (0.9.39 et 100.14.9); manque de pot, le jeu plante à la sortie des égouts (au chargement après avoir valider les caractéristiques du perso), faut que j'essaie avec la 0.9.40 .
sral Sunday 1 July 2007 at 16:20
sralAnonymous

Moi aussi sa plante à la sortie des égouts.
GNU_Raziel Sunday 1 July 2007 at 16:27
GNU_Raziel

Les plantages d'Oblivions sont malheureusement assez coriaces et aléatoire...enregistrez la partie juste avant de sortir des égouts et tenter votre chance jusqu'a ce que ça passe.

Et habituez-vous a faire ça parsque quoi qu'on fasse ça reste très instable...
Tophu Sunday 1 July 2007 at 16:49
Tophu

Déjà tenté le coup de la sauvegarde, mais c'est pas mieux. Si je me rappelle bien avant la 0.9.38, le jeu plante à la fin du chargement, ensuite il plante au début du chargement. (j'ai pas essayé en dessous de la 0.9.36)
ecyrbe Tuesday 3 July 2007 at 19:11
ecyrbeAnonymous

Il semble que depuis la version 0.9.39 oblivion plante à l'exterieur... la version 0.9.40 ne corrige pas le problème.
moi aussi je ne peux plus y jouer. faudra attendre la 0.9.41 pour voir si le problème est corrigé ou repasser en 0.9.38
nasra Friday 6 July 2007 at 20:28
nasra

perso le jeu est très lent (surtout dès que j'arrive à un ennemi.
Oldoblivion installé, options au minimum, résolution pareille au bureau (je joue en fenêtré), peu de sons fonctionnels (juste les voix, et encore avec des décalages)...
Tourne très bien sous win avec la même config.
3000+
6600GT 128Mo
1Go
Gagaro Tuesday 10 July 2007 at 13:16
GagaroAnonymous

Bonjour,

J'ai le meme probleme, plantage a la sortie des egout au debut du chargement, j'ai essayer en installant le jeu sous windows, recuperer la sauvegarde, sortir des egouts, resauvegarder juste dehors, puis je retourne sous linux, je recupere cette sauvegarde et je relance le jeu, mais sa plante toujours.

Je vais essayer avec une version de wine plus ancienne.
GNU_Raziel Thursday 12 July 2007 at 13:34
GNU_Raziel

Vraiment bizarre, je n'ai pas tester le jeu très longtemps mais il me semble avoir reussi a sortir des égouts sans problème (coup de bol peut-être)...
Gagaro Sunday 15 July 2007 at 22:18
GagaroAnonymous

j'ai essayer avec d'autre versions (y compris la 0.9.41) et sa plante toujours
Asimov Tuesday 17 July 2007 at 20:09
Asimov

Bonsoir à toutes et à tous !

Les problèmes avec TES IV : Oblivion et Wine sont surtout liés aux rendus utilisant le Pixel Shaders de DirectX.

Or j'ai eu vent d'un programme pour Windows, Oldblivion (fin jeu de mots ), qui vise à réduire la qualité des rendus d'Oblivion pour que ce dernier puisse fonctionner sur des PC vieillissants.

Quel intérêt pour nous ?
En plus de permettre un gain de performances, Odlblivion permet d'utiliser Pixel Shader dans sa version 1.5 au lieu de sa version 2.0 (que Wine ne gère pas encore bien). A la clé, pourquoi pas, la résolution de certains problèmes que vous semblez être nombreux à rencontrer.

Je ne possède pas Oblivion, mais il faudrait vraiment que quelqu'un teste les effets d'Oldblivion.
Si lesdits tests sont concluant, on pourrait intégrer Olblivion dans la catégorie Patchs de POL.

Merci d'avance au(x) volontaire(s).

Site Web d'Oldblivion (en anglais) :
http://www.oldblivion.com/index.php


Nous piétinerons éternellement aux frontières de l'Inconnu, cherchant à comprendre ce qui restera toujours incompréhensible. Et c'est précisément cela qui fait de nous des hommes.

Gagaro Tuesday 17 July 2007 at 20:36
GagaroAnonymous

J'ai tester chez moi, sa ne se lance pas, et en console sa ne m'affiche aucun message d'erreur ou autre.
Freyja Monday 13 August 2007 at 18:01
Freyja

Bonjour,

Quelqu'un a réussis à installer Shivering Isles? Car Playonlinux ne lance aucune installation automatique pour l'add-on chez moi.

Mais avec wine déjà l'installation était impossible, j'avais ce message d'erreur là:

"Le module de sécurité requis ne peut pas être activé.
Ce programme ne peut pas être exécuté (8008).

Voir http://www.securom.com/message.asp?m=module&c=8008&l=fr pour plus de détails."
lordheavy Saturday 3 November 2007 at 20:52
lordheavyAnonymous

J'ai mis a jour le script d'installation/corrigé les problèmes. Maintenant le script permets d'installer aussi la version GOTY (jeu de l'année)/problème lié à securom.


#!/bin/bash
if [ "$PLAYONLINUX" = "" ]
then
exit 0
fi
source "$PLAYONLINUX/lib/sources"
cfg_check

presentation "The Elder Scrolls 4 - Oblivion" "2K Games" "http://www.elderscrolls.com/games/oblivion_overview.htm" "GNU_Raziel/lordheavy" "ElderScroll4_Oblivion"

Ask_For_cdrom
Check_cdrom "setup.exe"

mkdir -p $REPERTOIRE/wineprefix/ElderScroll4_Oblivion
cd $REPERTOIRE/wineprefix/ElderScroll4_Oblivion
select_prefixe "$(pwd)"
creer_prefixe

cd $WINEPREFIX/drive_c/windows/
mkdir temp
cd $WINEPREFIX/dosdevices
#rm ./*
#ln -s ../drive_c c:\
#ln -s / z:\
#ln -s $CDROM d:\

cd $REPERTOIRE/tmp/
if [ ! -e $REPERTOIRE/tmp/D3DX9_dll_update.zip ]; then
telecharger "Téléchargement de la mise a jour DirectX9.0c pour Wine..." http://www.threelights.de/page/projects/d3dx9_xx_dll_files/D3DX9_dll_update.zip
fi
cd $WINEPREFIX/drive_c/windows/temp/
unzip $REPERTOIRE/tmp/D3DX9_dll_update.zip
message "L'installation de la mise a jour DirectX9.0c pour Wine va débuter"
Set_OS "winxp"
cd D3DX9_dll_update/Install/
wine DXSETUP.exe

# fix for GOTY version (securom problem)
cd $HOME
Set_OS "vista"
echo "[HKEY_LOCAL_MACHINE\System\MountedDevices]" > $REPERTOIRE/tmp/securom.reg
regedit $REPERTOIRE/tmp/securom.reg

cd $CDROM
wine d:\setup.exe
message "Appuyez sur OK UNIQUEMENT quand l'installation du jeu sera terminée sous peine de devoir recommencer l'installation."

cd $HOME
Set_Managed "On"
Set_DXGrab "On"
Set_GLSL "On"
echo "[HKEY_CURRENT_USER\Software\Wine\DirectSound]" > $REPERTOIRE/tmp/directsound.reg
echo "\"DefaultBitsPerSample\"=\"16\"" >> $REPERTOIRE/tmp/directsound.reg
echo "\"DefaultSampleRate\"=\"44100\"" >> $REPERTOIRE/tmp/directsound.reg
echo "\"EmulDriver\"=\"Y\"" >> $REPERTOIRE/tmp/directsound.reg
echo "\"HardwareAcceleration\"=\"Emulation\"" >> $REPERTOIRE/tmp/directsound.reg
regedit $REPERTOIRE/tmp/directsound.reg
echo "[HKEY_CURRENT_USER\Software\Wine\Drivers]" > $REPERTOIRE/tmp/drivers.reg
echo "\"Audio\"=\"alsa\"" >> $REPERTOIRE/tmp/drivers.reg
regedit $REPERTOIRE/tmp/drivers.reg
echo "[HKEY_CURRENT_USER\Software\Wine\Direct3D]" > $REPERTOIRE/tmp/d3d.reg
echo "\"OffscreenRenderingMode\"=\"fbo\"" >> $REPERTOIRE/tmp/d3d.reg
echo "\"PixelShaderMode\"=\"enabled\"" >> $REPERTOIRE/tmp/d3d.reg
echo "\"VertexShaderMode\"=\"enabled\"" >> $REPERTOIRE/tmp/d3d.reg
regedit $REPERTOIRE/tmp/d3d.reg

cd $WINEPREFIX/drive_c/Program\ Files/Bethesda\ Softworks/Oblivion/
mv Oblivion_default.ini Oblivion_default.ini.save
cat Oblivion_default.ini.save | sed s/bForce1XShaders=1/bForce1XShaders=0/g | sed s/bSaveOnInteriorExteriorSwitch=1/bSaveOnInteriorExteriorSwitch=0/g | sed s/bUseWaterShader=1/bUseWaterShader=0/g > Oblivion_default.ini
mv Data/Video Data/Video2
mkdir -p Data/Video

simuler_reboot

creer_lanceur "ElderScroll4_Oblivion" "Program Files/Bethesda Softworks/Oblivion/" "OblivionLauncher.exe" "ElderScroll4_Oblivion.xpm" "The Elder Scrolls 4 - Oblivion"

message "Installation terminée."
message "Si vous n'avez pas l'add-on \"Shivering Isle\" il est recommander de patcher le jeu avant de l'utiliser."
exit

Laurent
Slik Friday 8 February 2008 at 18:35
SlikAnonymous

Petit truc ... j'ai eut a faire à un méchant bug (l'installation de SI ... cet add-on est un bug en lui même -_-) et j'ai du désinstaller la bête ... mais maintenant je ne peux plus l'installer . Le script me télécharge le DirectX et me dit qu'il va l'installer ... sans rien faire . Pas plus qu'il n'installe le jeu . Serait-ce le bug annoncé dans les news de la page d'acceuil ?
Je me demandais aussi ... pour ceux qui n'ont pas la version cd de Knight Of The Nine ... ont fait comment pour l'installer ? Méthode barbare à la Unshield (comme pour installer SI d'ailleurs ... le script ne marche pas chez moi je dois faire tout à la main) ?

Trois petit Tux et puis s'en vont !
HotTux Thursday 3 April 2008 at 19:03
HotTuxAnonymous

Pour l'addon Knights of the Nine version cd j'ai le meme probleme quavec SI: le script annonce qu'il a lance l'installation mais rien ne demare.
padlup Saturday 19 April 2008 at 18:59
padlupAnonymous

bonjour a tous
malgres plusieurs tentative je n arrive toujours pas a installer oblivion
j'ai la version GOTY et lors du lancement du script j ai bien la creation du prefixe , l'instalation de direct x et plus rien le cd ne se lance pas je reste sur "n'appuyer pas sur ok ..."
si je tente une instalation en execution manuel je me fait jeter par securom
et si je tente l'instalation avec l'automatique (genial ce truc ) il me lance l'executable oblivionlauncher.exe au lieu du setup.exe ce qui a pour consequence de lancer le panneau de debut de jeu avec juste quitter et le lien vers le site de clickable tous les autres lien sont unable
je vous remerci d'avance


ps message securom :SecuROM™ a déterminé qu'un outil logiciel a modifié les paramètres de votre PC.
erreur 7000 pour les connaisseurs

Ändrat av padlup

GNU_Raziel Sunday 11 May 2008 at 19:29
GNU_Raziel

Les scripts d'Oblivion (jeux-addons-patch) ont tous été refais a neuf, au programme :
-Mise a jour de la structure des scripts pour conformité a la v2
-Support de Wine 1.0rc1 (meilleure version pour Oblivion selon les tests)
-Support Multilingue des addons et du patch

Note : Ses scripts ont été fait a partir de la version ORIGINALE (pas GOTY) du jeu et des addons !!

Voila, amusez-vous bien

Ändrat av GNU_Raziel