Cannot start PlayOnLinux ?

Författare Svar
hawake Monday 25 October 2010 at 22:20

Hey all,

My PlayOnLinux worked perfect a few hours ago but now it refuses to start and when i try to start it from a terminal i get the following error: "IndexError: list index out of range"

Anybody know what is wrong?

r `{', expected character `='
Traceback (most recent call last):
File "/usr/share/playonlinux/python/", line 471, in <module>
app = PlayOnLinuxApp()
File "/usr/lib64/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/", line 7978, in __init__
File "/usr/lib64/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/", line 7552, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "/usr/share/playonlinux/python/", line 462, in OnInit
self.frame = MainWindow(None, -1, "PlayOnLinux")
File "/usr/share/playonlinux/python/", line 51, in __init__
self.texte_update = wx.StaticText(self.panel_update, -1, _("An updated version of PlayOnLinux is available.")+" ("+sys.argv[2]+")",pos=(35,0))
IndexError: list index out of range
Ante Tuesday 26 October 2010 at 6:17

I had the same problem.
And I fixed it with updating to newest PoL.

Know this, my friend - the evil that you move against is the dark lord of terror. -Deckard Cain
hawake Tuesday 26 October 2010 at 9:02

Alright, im kina new to ubuntu/linux so what is PoL and how do i update it?
Trilby Tuesday 26 October 2010 at 12:45


PoL is PlayonLinux. There are some straight forward instructions to update on Ubuntu. Just go to the downloads link at the top of the web page, click on the ubuntu icon, and follow the terminal instructions for your version.

However, I've got the same error (above) word for word, in Slackware 13.1. The version of PoL is 3.8.3, using the script from SlackBuilds. I'm not sure I've got a newer PoL to update to.

Removing and reinstalling PoL didn't have an effect, but the window for updating the scripts and downloading the fonts worked, but that was it.


Or perhaps I do have a version to update to. Looks like I posted in the middle of an update. pinch:

Ändrat av Trilby

Aymeric P. Tuesday 26 October 2010 at 19:34
Aymeric P.

This is a major bug that affect POL 3.8.3 AND 3.8.4.

You should upgrade to 3.8.5.

POL 3.8.4 and 3.8.3 was unable to launch for now.

Former member.