Starcraft II wings of liberty installation problem

No window pops up when I click install

Författare Svar
mcavoybn Sunday 20 March 2011 at 22:14

I bought a retail version of SC2 a while ago, and played it on my windows 7 installation for a long time. Last week (surprise, surprise) my windows 7 completely died, but luckily I already had a Ubuntu installation on another partition. So now I am in the process of installing these windows games that I want to play onto linux, and it has been a bumpy ride.

I have the most up-to-date PlayOnLinux version, I updated all the repositories for PlayOnLinux, and everything with Wine/PlayOnLinux works properly. I just wanted to use this program to install SC2, and it seems that is the one thing it refuses to install. This is what happens:

I open PlayOnLinux
I click the +Install icon
I type 'Starcraft' into the search box
I double-click on 'Starcraft II: Wings of Liberty'
The +Install window closes, and NOTHING HAPPENS. There is no error message, nothing, I just return to the main window and it stares at me blankly saying "What? Did you want to play that game or something? Well... sorry" :@

I have tried closing PlayOnLinux and re-running it, doing the same steps, and I get the same problem.

I tried running other games/programs and they work! Starcraft 2 is the only program that seems to have this problem.

If you can fix this problem and help me install this game I will build you a shrine and worship you until my consciousness is flung into a vast emptiness of nothing, and every piece of what I ever was is destroyed. Thank You.
GNU_Raziel Sunday 20 March 2011 at 23:07

I will check this out as soon as I can.

At least, can you try installing another application ? like a demo (Dragon Age 2 or Crysis 2 - you need to download it before or have a steam account) or a freeware (Sonic Fan Remix or Super Chuck Norris Bros. - automatically downloaded for you by PoL) supported to heck if it's really a SC2 installer related problem or something else ?


mcavoybn Monday 21 March 2011 at 4:05

Everything else seems to work fine. I tried applications in every other category (Education, Graphics, etc.) and they all worked, unless of course the server was overloaded.

The games seem to be hit and miss. Alot of them worked i tried Borderlands, Starcraft 1, Baldur's Gate, and just clicked around to see what worked, but starcraft 2 still didn't work. Nothing happens.

Strangely enough, the Sonic Fan Remix and Super Chuck Norris Bros. packages both did not work. They did the same thing as the SC2 did, where the window would close, and then nothing would happen.


This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to