Starcraft 2 gecko check

Improved SC2 installation

Författare Svar
Gustra Friday 15 April 2011 at 10:46

Hi, I am running POL 3.8.12 on Ubuntu 10.04.

I just tried the DVD installation for Starcraft 2, and it installed a different version of wine (1.3.11). During the SC2 installation and subsequent upgrade process, SC2 needs the wine-gecko package to display HTML, but the correct wine-gecko is not installed. Wine constantly asks if the gecko package should be downloaded and installed, but it always fails.

How to reproduce:

- Make sure /usr/share/wine/gecko/ is not present
- Make sure wine 1.3.11 is not installed
- Run SC2 installation using DVD
- Result: wine constantly pops up window requesting gecko download

Workaround: download manually prior to installation

Please add gecko installation to SC2 installation script to solve this issue.
GNU_Raziel Friday 15 April 2011 at 11:54

PoL installer updated :
- Added gecko dependency
- Updated wine version to 1.3.17
- Added game effects fix for ATI/AMD graphic cards users
- Added performance tweak

Ändrat av GNU_Raziel

Gustra Friday 15 April 2011 at 14:41

C'est plus rapide! Merci Beaucoup :-).

Ok, I'll stick to English ;-)

Gustra Friday 15 April 2011 at 15:40

Hi again! I tried to verify the new version, but I am having trouble getting it to work.

1. wine 1.3.17 is downloaded and that seem to work

The gecko fix does not appear to work. I remove everything from /usr/share/wine/gecko to force a geck download. The download is made, but is not installed in that directory. If it is downloaded to a different location, then wine I don't think wine find it, because after a while wine wanted to download it once more.

3. Immediately when the installation starts copying files to the HDD, I receive a "file not found" error and the installation is aborted. This is currently a stopper. I have tried ejecting the DVD so that it is reset, but it does not help.

Thank you for your efftort!
Gustra Friday 15 April 2011 at 15:54

For the gecko issue, perhaps this is the problem?

chaplin:~$ ls .PlayOnLinux/ressources/

wine 1.3.17 requires gecko 1.2.0:

wine-1.3.16 - current: wine_gecko-1.2.0-x86.msi, wine_gecko-1.2.0-x86_64.msi

Tha latest wine supported in POL_Install_gecko is 1.1.26, otherwise it falls back to 1.0.0:


Gustra Friday 15 April 2011 at 16:29

And for the copy problem, I think this is the problem:

94 cp -r "/media/PlayOnLinux/*" "$POL_USER_ROOT/tmp/SC2_WoL/"

The line number may be a few lines off, I forgot to backup the script before editing. Problem is that "*" is not subjected to glob expansion since it's in quotes (").

I think that bash correctly handles expansion of * so removing the quotes work:

94 cp -r /media/PlayOnLinux/* "$POL_USER_ROOT/tmp/SC2_WoL/"

This code will not copy files starting with a full stop (.* files), but I guess that doesn't matter in this case.

Also, this command:

88 POL_SetupWindow_check_cdrom "Installer Tome 1.MPQE"

seems to generate a "find -iname "${CDROM}/$1", but that won't work:

find: varning: Unix-filnamn innehåller normalt sett inte snedstreck (även om sökvägar gör det). Det betyder att "-iname "/media/PlayOnLinux/Installer Tome 1.MPQE"" antagligen kommer alltid att bli falsk på detta system.


find: warning: Unix filenams normally don't contain slashes (even if paths does). This means that "-iname "/media/PlayOnLinux/Installer Tome 1.MPQE"" probably will always be false on this system.

But that is a POL problem and not a problem for this installation script, I guess.

Ändrat av Gustra

GNU_Raziel Friday 15 April 2011 at 18:13

Thx for reporting, all should be fixed now.


Gustra Monday 18 April 2011 at 16:41

Just to let you know - I reinstalled SC2 and it worked like a charm :-D. Many thanks!

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to