Forum

Half-Life 1

Mes premiers tests

Författare Svar
Quentin PÂRIS Monday 14 May 2007 at 20:30
Quentin PÂRIS
Admin

1er essai

Wine : 0.9.36
Distribution : Ubuntu Feisty Fawn (7.04)
Drivers nvidia :1.0-9631
Commentaire :
L'installation plante dès le début. Impossible de lire un fichier dans c:\windows\temp

2eme essai : sortie de wine-0.9.37

Wine : 0.9.37
Distribution : Ubuntu Feisty Fawn (7.04)
Drivers nvidia :1.0-9631
Commentaire :
L'installation marche à merveille. Le jeu se lance, j'ai réussi à jouer. Seulement, lors du parcours des menus, il y a un petit bug génant. A chaque bouton cliqué, une nouvelle fenêtre est ouverte. Il faut donc faire ALT+TAB pour aller dessus
Quentin PÂRIS Wednesday 16 May 2007 at 20:17
Quentin PÂRIS
Admin

Mise à jours du 16 mai 2007

J'ai refait le script de Half-Life et tout marche à priori. J'attends les résultat de vos tests
Christhaal Saturday 19 May 2007 at 19:01
Christhaal

Wine : 0.9.37
Distribution : Debian Etch (4.0)
Drivers nvidia :1.0-9755
Commentaire : Ca marche :)

Quentin PÂRIS Sunday 20 May 2007 at 18:29
Quentin PÂRIS
Admin

Le script n'est plus en version beta desormais
acieroid Monday 28 May 2007 at 11:21
acieroidAnonymous

Wine : 0.9.31-1
Distribution : Debian Lenny (testing) + dépôts unstable (mais pas à jour d'un mois)
Drivers nvidia :1.0.9755-1
Commentaire : L'installation se passe sans problèmes, le "Half life" au dessus du menu au lancement chie un peu (problèmes de couleurs, je sais pas trop).
Lors du lancement d'une partie, le son est bien là, mais pas l'image oO

Vais peut être mettre à jour wine
edit : idem avec la version 0.0.33 de wine

Ändrat av acieroid

koan Sunday 17 June 2007 at 14:42
koanAnonymous

Bonjour,

j'ai voulu testé votre appli avec HL1 et je suis dans le même cas que la personne ci-dessus.

Le titre Half-life déconne, en jeu j'ai le son mais pas l'image.

Voici quelques erreurs tirés de mon dmesg :


ioctl32(rundll32.exe:3161): Unknown cmd fd(9) cmd(82187201){02} arg(00221000) on /home/atlza/.PlayOnLinux/wineprefix/HalfLife1/drive_c/windows
ioctl32(rundll32.exe:3161): Unknown cmd fd(11) cmd(82187201){02} arg(00221000) on /home/atlza/.PlayOnLinux/wineprefix/HalfLife1/drive_c/windows/system32
ioctl32(rundll32.exe:3161): Unknown cmd fd(11) cmd(82187201){02} arg(00221000) on /home/atlza/.PlayOnLinux/wineprefix/HalfLife1
application hl.Exe uses obsolete OSS audio interface


Excellent projet en tout cas, bonne continuation.

Ändrat av koan

koan Sunday 17 June 2007 at 15:05
koanAnonymous

Apres plusieurs tests et changements, j'ai avancé quelques peu...

J'arrive a lancer correctement le jeu (mode multijoueur ce qui m'interesse ici), affichage ok et son aussi, seulement je n'ai pas de controle clavier.

La souris est ok, je peux viser et tirer mais pas me deplacer.
Je ne peux pas non plus faire un "echap" pour un eventuel retour au menu.

c'est peut être du au clavier usb ?
Je ne sais pas... je fouille encore.
koan Sunday 17 June 2007 at 21:06
koanAnonymous

bon peut-etre que mon problème venait du fait que je lancais hl directement par wine (raccourcis dans le menu gnome), en effet le script POL produisait une erreur.

Cette erreur modifié (erreur de chemin du à des majuscules), le jeu se lance, je retrouve alors le probleme des menus HL qui s'ouvrent à chaque fois dans une nouvelle fenetre.

Par contre une fois en jeu, plus de problèmes (bon certaines textures clignotent : les traces d'explosion mais c'est minime).

Je vais maintenant tenter d'updater hl et de mettre counter, mais pour l'instant j'ai des erreurs d'écriture dans temp.

Ändrat av koan

koan Monday 18 June 2007 at 15:15
koanAnonymous

Hum bon je n'arrive pas a passer ce message d'erreur à l'install de patchs pour HL...

Il n'arriverai pas à écrire dans c:/windiws/temp

Je suis avec wine 0.9.36 quelqu'un aurait une idée ?

merci d'avance.
GNU_Raziel Monday 18 June 2007 at 15:33
GNU_Raziel

dès que j'aurais retrouver mes cd de HL1, Oposing Force et Blue shift (au passage je ferais les scripts qui manquent) je testerais tout ça serieusement, je peu cependant déjà vous dirte que les versions steam de ses jeux fonctionnent parfaitements (installées chez un ami), aucun bug recencé.

Sachez aussi que si vous avez les versions originales WON de ses jeux il est possible de les avoir sur steam gratuitement (une conversion a faire avant pour que la clé soit acceptée, reste a voir si ca fonctionne toujours).
koan Tuesday 26 June 2007 at 10:22
koanAnonymous

J'ai continué mes tests sur hl1 et j'observe quelques petites choses bizarres.

Avec compiz d'activé, les menus d'HL fonctionnent correctement, alors que sans ils ouvrent une fenetre pour chaque sous menu.

Par contre ensuite en jeu, le dernier menu (creation du serveur dans mon cas) reste devant la fenetre de jeu.

J'ai réussi une fois, par un biais de alt+tab et autres a avoir les menus half life en fenetre (donc il occupaient pas la totalité de l'ecran) et dans ce cas précis ils marchaient correctement.
Au lancement du serveur, le jeu prenait bien tout l'écran.

Ce cas est bien plus agréable que le fait d'avoir une fenetre par écran.
Du är här: Index > PlayOnLinux > Half-Life 1