Forum

Probleme De Lancement

Författare Svar
Jump to the page: 1 - 2
Glerek Monday 3 December 2007 at 20:11
Glerek

Bonjour a tous !
Et oui c'est mon premier post, mais j'aimerais vous faire part d'un probleme concernant PlayOnLinux.
J'ai téléchargé la version 2.0.3.

Je suis sous Mandriva 2007
J'ai Wine 0.9.30, et comme dit plus haut, POL 2.0.3
J'ai KDE !
Et mon erreur est celle ci :

Lorsque je lance dans ma console : ./PlayOnLinux elle m'affiche :

"PlayOnLinux v2.0
----------------
Checking python2.4 : [ Ok ]
libGL warning: 3D driver claims to not support visual 0x4c
Traceback (most recent call last):
File "/home/edouard/Desktop/playonlinux/python/mainwindow.py", line 22, in ?
import wxversion, os, getopt, sys, urllib, signal, socket
ImportError: No module named wxversion"

Bon d'accord je me suis inspiré du message type donné dans le topic "Comment formuler sa question" ^^ mais bon

Donc voila, j'ai essayé d'installé Python 2.4 comme dit dans un autre topic puis essayé de forcer en changeant une ligne dans /lib/variables/ mais rien n'y fait, ce la ne marche pas ^^

Donc si vous avez des suggestions...ben je suis preneur

Merci d'avance !
Bonne soirée !

Glerek
GNU_Raziel Monday 3 December 2007 at 21:40
GNU_Raziel


j'ai wine 0.9.30

Quote from Glerek


Euh...On est a la version 0.9.50, faudrais voir a mettre ça a jour déjà


Donc voila, j'ai essayé d'installé Python 2.4 comme dit dans un autre topic

Quote from Glerek


C'est Python 2.5 et python-wxgtk2.6 (2.8 recommandé) minimum qu'il faut pour que ca fonctionne.
Aymeric P. Monday 3 December 2007 at 21:57
Aymeric P.
Admin

Essaye avec le rpm
Je crois que tu n'as pas mesa-utils (ou demos)

Former member.
Glerek Tuesday 4 December 2007 at 19:12
Glerek

Ben tout d'abord merci pour vos reponses !

Ben je m'en vais installer tout ca et je vois si ca marche (j'espere ^^) sinon je reviendrait !!! *ahahahaha...s'enfuit en courant dans la nuit !!*

Edit: Bon j'ai installé Wine 0.9.50 La suite ^^
Hum sinon j'ai installé Python 2.5 mais pour python-wxgtk2.8 je fais comment , j'ai cherché dans mes packetages il n'y est pas et je n'ai pas trouv" de lien ou le telecharger...il me semblerait (si je dis pas de connerie) que pour Mandriva ce serait wxGTK nan ? Si c'est ca ben je suis a la version 2.8 !
Mais sinon qu'est-ce que Mesa - utils ?

Ben merci d'avance !!

Fiou chuis motivé ^^

Glerek !

Ändrat av Glerek

Aymeric P. Wednesday 5 December 2007 at 22:47
Aymeric P.
Admin

Pour mdv, prend le paquet RPM là : http://www.playonlinux.com/topic-634-PAQUET_RPM.html

Former member.
Glerek Tuesday 11 December 2007 at 11:21
Glerek

Bonjour a tous !

J'ai installé wxPythonGTK 2.6 et lorsque je lance POL cela me dit que ce n'est pas la bonne version....
Je mettrai le message exact ce soir !
Mais sinon si quelqu'un a le lien pour la version 2.8 chuis preneur j'ai cherché en vain !

Merci d'avance :
Glerek Tuesday 11 December 2007 at 20:07
Glerek

Voila le message d'erreur :

PlayOnLinux v2.0
----------------
Checking python : [ Ok ]
libGL warning: 3D driver claims to not support visual 0x4c
Traceback (most recent call last):
File "/home/edouard/Desktop/playonlinux/python/mainwindow.py", line 23, in <module>
wxversion.select("2.8"
File "/usr/lib/python2.5/site-packages/wxversion.py", line 152, in select
raise VersionError("Requested version of wxPython not found"
wxversion.VersionError: Requested version of wxPython not found


Donc ben je suis bloqué la actuellement ... d'apres ce que j'aurais compris il ne prend pas en compte le fait que j'ai installé la version 2.8 de wxPythonGTK donc comment pourrais-je faire pour que ca marche ?

Merci d'avance !!

Glerek !!!
Sp Wednesday 12 December 2007 at 0:58
SpAnonymous

Va voir sur cette page : http://www.wxwidgets.org/downloads/

Sous Debian, c'est plus simple à gérer avec les paquets mais tu y trouveras les source à télécharger. Ensuite, tu devras les compiler ...
Glerek Wednesday 12 December 2007 at 13:33
Glerek

Merci pour le lien !
Mais sinon j'ai deja telechargé et installé un paquet nommé :

wxPythonGTK-wxversion-2.8.7.1-1mdv2008.1.i586 (je viens de capter un truc, je suis sous Mandriva 2007 et le paquet la serait pour Mandriva 2008...le probleme viendrait il de la ?)

Donc normalement ca devrait marcher ?
Sinon je telecharge quoi exactement sur ton site Sp@rk ?
Désolé de vous embeter avec tout ca mais je ne comprend pas d'ou vient le probleme ^^
Merci d'avance !

Edit: Pis tant que j'y suis ... que signifie ce message : libGL warning: 3D driver claims to not support visual 0x4c

Ändrat av Glerek

Sp Wednesday 12 December 2007 at 14:59
SpAnonymous

Je te proposais de compiler les sources (en l'occurence, celles de wxPythonGTK) mais j'ai trouvé mieux !

En fouillant un peu, j'ai trouvé un lien vers ton paquet :
ftp://mirror.switch.ch/mirror/mandrake/official/2007.1/i586/media/main/backports/
wxPythonGTK-wxversion-2.8.4.0-1mdv2007.1.i586.rpm

EDIT : le lien ne s'affiche pas en entier, je l'ai coupé en deux afin qu'il soit lisible

Celà devrait convenir à tes besoins

Ändrat av Sp@rK

Glerek Wednesday 12 December 2007 at 16:26
Glerek

Chouette !!! J'ai pas reussi a en trouver un moi
Mais c'est sympa de te decarcasser pour moi ^^
J'installe ca sous peu et je te tiens au courant !!!!

Encore merci !!!!

Edit : Et zut, ca marche toujours pas....sinon ya pas une commande pour voir la derniere version de wxPython installée dur mon PC? Ou une autre solution pour que ca marche ?
Encore merci!!!

Edit 2 : Je vais encore faire mon chiant mais quelqu'un n'aurait pas un lien pour telecharger mesa-utils .... je galere depuis 3 h a en chercher un ....

Ändrat av Glerek

Quentin PÂRIS Wednesday 12 December 2007 at 20:08
Quentin PÂRIS
Admin

Il faut aussi python-wxversion
Sp Thursday 13 December 2007 at 10:49
SpAnonymous

Pour rechercher des RPM, va voir à cette adresse : http://rpm.pbone.net
http://rpm.pbone.net/index.php3/stat/2/simple/2 (adresse pour la recherche détaillée)

Tu devrais y trouver tous les paquets nécessaire à ta distribution !

Ändrat av Sp@rK

Glerek Thursday 13 December 2007 at 19:23
Glerek

Copaaaaaiiin !!!

Ben en fait c'est un site comme ca que je cherchais ^^ Mais j'lavais pas trouvé

Bon j'installe tout ca et je vous tiens au courant !
Glerek Thursday 13 December 2007 at 19:56
Glerek

Euh j'ai installé python-wxversion mais ca ne marche toujours pas.... je vois pas d'ou ca pourrait venir....

Deja merci pour tout ce que vous avez fait...pis merci pour ce que vous ferez encore ^^
Quentin PÂRIS Thursday 13 December 2007 at 21:38
Quentin PÂRIS
Admin

Alors...

Essais de modifier lib/variables

PYTHON="python"

Essais de mettre par exemple

PYTHON="python2.4"
Glerek Thursday 13 December 2007 at 21:59
Glerek

Ben en changeant lib/variables je tombe sur ca apres :

PlayOnLinux v2.0
----------------
Checking python2.4 : [ Ok ]
libGL warning: 3D driver claims to not support visual 0x4c
Traceback (most recent call last):
File "/home/edouard/Desktop/playonlinux/python/mainwindow.py", line 22, in ?
import wxversion, os, getopt, sys, urllib, signal, socket
ImportError: No module named wxversion

C'est louche ^^ Vais essayer une autre modif et je reviens

Edit : Malgres toutes les modifs faites je suis toujours soit a ce message d'erreur soit au precedent J'ai essayé de modifier PYTHON et VERSION...rien n'y fait....pourquoi j'ai normalement les bons paquets installés....sinon tu pourrais me dire exactement les paquets necessaires et je refais un check ?

Ändrat av Glerek

Quentin PÂRIS Thursday 13 December 2007 at 22:26
Quentin PÂRIS
Admin

En fait

Il faut soit que tu prenne python2.4-wxgtk et python2.4-wxgtk2.8
Ou soit python2.5-wxgtk et python2.5-wxgtk2.8

Mais pas le mélange des deux
Glerek Thursday 13 December 2007 at 22:27
Glerek

Okaaaaayyy !!

Ca vient surement de la !!!!

[Mode Exploration et cherchage ^^]
Je reviens te tenir au courant dans pas longtemps !!!

Merci encore pour vos reponses !!!!

Edit : Question , python2.5-wxgtk et python2.5-wxgtk2.8 c'est pas le meme paquet ?
Paceque actuellement moi j'ai installé :

* Python 2.5-4.1
*Python-wxversion-2.6.3.2.2-2.noarch
*wxPythonGTK-wxversion-2.8.4.0-1

Et puis voila ^^
C'est pas bon que ces paquets la soient installés ? Paceque je trouve pas les paquets que tu m'a indiqués ....

Ändrat av Glerek

Quentin PÂRIS Thursday 13 December 2007 at 22:38
Quentin PÂRIS
Admin

Les version après t'es python-wx* correspondent aux versions de wxgtk et non pas de python