Forum

Installation Diablo 2 à l'aide de POM

Författare Svar
Jump to the page: 1 - 2
panda-fehu Saturday 19 May 2012 at 10:23
panda-fehuAnonymous

Bonjour à tous,

Je tente depuis un moment d'installer Diablo 2 sur mac qui tourne sous le Mac Os X Lion 10.7. Voici le problème que je rencontre et dont je n'arrive pas à me sortir :

Après que l'installation ait commencé normalement, il me faut insérer le deuxième disque d'installation de Diablo 2 (il y en a trois). Je passe par l'éjection de disque sous PlayOnMac ce qui éjecte le cd1 et ensuite j'insère le cd2. Seulement il n'est pas reconnu sous X11 et donc l'installation s'arrête puisqu'il ne peut aller plus loin.

Version de POM : 4.0.19
Version de Wine : 1.4

Voilà toutes les informations que je puisse vous fournir.

Merci d'avance pour votre aide ^^
Quentin PÂRIS Saturday 19 May 2012 at 10:32
Quentin PÂRIS
Admin

Il faut que je corrige l'installation de Diablo II à partir des CD, mais je n'ai pas la version CD sous la main

Je te conseille de télécharger le jeu sur le site de Blizzard, ce sera plus simple
panda-fehu Saturday 19 May 2012 at 10:34
panda-fehuAnonymous

j'ai déjà payé le cd et j'ai pas très envie de repayer une version ou alors blizzard propose de le télécharger gratuitement si on a la version physique ?

Merci pour la réponse rapide au fait ^^

EDIT : Oublie ma dernière question, c'est bon ^^.

Ändrat av panda-fehu

panda-fehu Saturday 19 May 2012 at 12:24
panda-fehuAnonymous

UP

Mon deuxième soucis (bad luck brian inside), j'essaye d'installer maintenant l'extension "Lord Of Destruction" par le même chemin que tu m'as proposé plus haut, ce qui a fonctionné pour la base de Diablo 2, mais l'installation de LOD me signifie qu'il faut que j'installe en premier Diablo 2. Hors Diablo 2 est déjà installé et fonctionne.

Comment puis-je palier au problème ?

Merci d'avance ^^
panda-fehu Saturday 19 May 2012 at 12:38
panda-fehuAnonymous

UP

Mon deuxième soucis (bad luck brian inside), j'essaye d'installer maintenant l'extension "Lord Of Destruction" par le même chemin que tu m'as proposé plus haut, ce qui a fonctionné pour la base de Diablo 2, mais l'installation de LOD me signifie qu'il faut que j'installe en premier Diablo 2. Hors Diablo 2 est déjà installé et fonctionne.

Comment puis-je palier au problème ?

Merci d'avance ^^
Quentin PÂRIS Saturday 19 May 2012 at 13:19
Quentin PÂRIS
Admin

Il faut l'installer dans le même disque virtuel
panda-fehu Saturday 19 May 2012 at 13:43
panda-fehuAnonymous

Du coup ça a marché comme solution. Seulement quand je lance le jeu j'ai ce message d'erreur qui s'affiche :

unhandled exception acces_violation (c0000005)

Qu'est ce que cela veut dire et comment on passe ce problème ?
Quentin PÂRIS Saturday 19 May 2012 at 13:47
Quentin PÂRIS
Admin

Tu l'as installé comment le jeu et l'extension ?
panda-fehu Saturday 19 May 2012 at 13:51
panda-fehuAnonymous

le jeu a été installé en DL la version depuis le site de blizzard avec la clef cd. ensuite installation en cliquant sur le "downloader_diablo2_FR.exe" et là le jeu s'est installé correctement et a fonctionné direct. Du coup l'extension j'ai fait la même manipulation donc en le téléchargeant et en l'installant depuis "Installer un programme non listé". Et je l'ai placé dans le même disque virtuel dans le même fichier que Diablo2 et s'est installé.
Quentin PÂRIS Saturday 19 May 2012 at 13:57
Quentin PÂRIS
Admin

Il faut utiliser le menu "Installer" de PlayOnMac
panda-fehu Saturday 19 May 2012 at 14:00
panda-fehuAnonymous

C'est ce que j'ai fait :

Installer => installer un programme non listé.

Etant donné qu'il n'est pas listé j'ai du le faire comme ça.
panda-fehu Saturday 19 May 2012 at 14:14
panda-fehuAnonymous

Je viens de tester à nouveau et ça me sort la même erreur.
Quentin PÂRIS Saturday 19 May 2012 at 14:32
Quentin PÂRIS
Admin

Il est listé Diablo II. Donc il ne faut pas utiliser installer un programme non listé
panda-fehu Saturday 19 May 2012 at 15:44
panda-fehuAnonymous

Alors je viens de tout recommencer. Donc installation du jeu Diablo 2 par le biais de la liste des jeux. Cela fonctionne parfaitement. Je fait la même manipulation pour Lord Of Destruction via le menu installer de POM. Et je choisi Diablo 2. L'installation se passe. Lord Of Destruction s'intalle et rebelote pour le message d'erreur :

unhandled exception acces_violation (c0000005)
panda-fehu Saturday 19 May 2012 at 16:56
panda-fehuAnonymous

Que dois je faire pour que l'extension fonctionne ?
Quentin PÂRIS Saturday 19 May 2012 at 17:00
Quentin PÂRIS
Admin

Essais de changer de version de wine (par exemple mets la 1.2.3)

Sinon, inutile de poster un message de rappel une heure plus tard
panda-fehu Saturday 19 May 2012 at 17:28
panda-fehuAnonymous

Je vais être très reloud mais je n'ai que la version 1.3.2 de Wine ou System dans le panneau de configuration. (Je suis complétement noob dans ce genre de truc). Faut il le télécharger et où peut on le trouver ?

Merci d'avance et pardon pour le repost.
SuperPlumus Saturday 19 May 2012 at 18:01
SuperPlumusAnonymous
Admin

Menu Gérer les versions de Wine -> Installer la 1.2.3

Ändrat av SuperPlumus

panda-fehu Saturday 19 May 2012 at 18:33
panda-fehuAnonymous

Le jeu plante directement au démarrage sans même afficher d'écran noir et m'annonce ceci :

Writting log to /Users/aymericgardeil/Library/PlayOnMac//tmp/errors_Diablo II.log.e

[POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.2.3, x86
[POL_Wine_SetVersionEnv] Message: "/Users/aymericgardeil/Library/PlayOnMac//wine/darwin-x86/1.2.3" exists
[POL_Wine] Message: Running wine-1.2.3 Diablo II.exe
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
wine client error:0: version mismatch 407/402.
Your wine binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?
[POL_Wine] Message: Wine return: 1

Quentin PÂRIS Saturday 19 May 2012 at 20:59
Quentin PÂRIS
Admin

Outils -> Fermer tout, recommence