Problem with Star Wars: The Old Republic

Not the Launcher, the Client.

Författare Svar
ThiagoJedi Friday 3 August 2012 at 17:02

Hello there.

First, sorry if you find any english errors, it's not my native language. 

I was trying to run SW:TOR, and made all the configurations to run the launcher. Virtual desktop with res 1000x614 ~ 1000x615, and the launcher runs just fine.

But when I click "Play" on the launcher, it starts the swtor.exe and then nothing. The game don't start. No loading screen, no black screen, just the virtual desktop.

Any ideas?

- Name of the distribution (and its version) > Ubuntu 12.04 LTS
- Name of the software and its version (ex: Wine 0.9.37) > PlayOnLinux w/ Wine 1.5.1_old_republic
- Your desktop (KDE, Gnome, Xfce, Fluxbox...) > Gnome Shell
- Errors from the software. And if possible, tell when and/or where it happens. > Client game don't appear on the screen.
- Your computer configuration. 
> Intel Core 2 Duo E7500 @ 2.93GHz
> Radeon HD 6670 1GB

Thank you in advance.

Ändrat av ThiagoJedi

schotty Tuesday 7 August 2012 at 0:05

According to what I see there, there are a fwe things you need to add along with the stock install. I see vcrun2008 and directx9. Do you have them installed?
petch Tuesday 7 August 2012 at 0:58

Well, (obviously) the dedicated install script does that already.
ThiagoJedi Tuesday 7 August 2012 at 1:22

Yup. vcrun2008 and d3dx9 installed by script.

Reading the log again, and comparing with the log with the unpatched Wine, it seems like the game is unable to call the graphics renderer...
petch Tuesday 7 August 2012 at 2:17

Upgrade PlayOnLinux to 4.1.x, and you'll get a minimal video subsystem check when PlayOnLinux starts.
ThiagoJedi Tuesday 7 August 2012 at 12:55

PlayOnLinux upgraded. Still the launcher can't call the graphics renderer.

BUT, as a workaround, I did a "ps x | grep swtor.exe" and copied the arguments. Then I made a shortcut directly to swtor.exe with these arguments.

It worked.

It's sad the servers are offline by now.
Phixia Saturday 25 August 2012 at 20:00

I am having the same issue as ThiagoJedi was having origionally.



what does your shortcut script look like? When I grep out swtor.exe I get something like this;

C:\\Program Files\\Electronic Arts\\BioWare\\Star Wars - The Old Republic\\swtor\\RetailClient\\swtor.exe -set username Phixia -set password W6kESVj9VUhdrwdCX60ER1L9B0RTqlEVD/5bQQytUkBS+ABDDP9TQlr9U0NTr1ASUq0AFQ+tUkBZ+gRIXPVWSAv8UkAM9fdsfFpDD/9XQQyvAxJb/gcXXf1bFF+oAEMLqQRFXq9WE1j+ABRS+QZGDP9bFAwv8VRNerltHUv1bSA//UUcI/QBGWf4EEle/+BEfgdNbqFRGUq4GRAypAElaqFZJfdCa9bFAj7UBVZ+FFJXa9VElP0VxNd9QNAU/lXQlr7AxNe/AMSD/RXSFr9ABBa9VNJD65WRV2qBkAOr1YTD/0DQVOjoihohoihpijuU0IJ/FZGUv1WRQ+uVENeqARJD6kDQwz0UUIP+gNHWPRSSUf5B0RbqVNIWqlSR12vAEFfqVVDXq1XEAn0AUIMrVtCXA== -set platform -set environment swtor -set lang en-us -set torsets main,en-us @swtor_dual.icb

Not sure what arguments you are using...
ThiagoJedi Sunday 26 August 2012 at 18:50

yup, just like yours.

but, I think they change the password algorithm daily, so you'll have to run the launcher again to get the new arguments once in a while.

Screenshot from my POL config window:
* it's in Portuguese, but I think you can understand it

After you get the arguments, since you don't have to run the launcher again to play the game, you may deactivate the virtual desktop from Wine. That way, you may play in full screen or in any resolution you like.


Ändrat av ThiagoJedi

alexzk Sunday 18 November 2012 at 13:16

ThiagoJedi Tuesday 20 November 2012 at 0:52

I'm having a issue after the Free2Play option...

When I run the client (press Play on launcher) a dialog says "Wrong parameters".

Thanks, alex, for the post on official foruns o/
ZKRiNG Thursday 22 November 2012 at 21:00

I try install it but the launcher don't appear.

Just start the launcher but don't show the real launcher