Das Forum

small wine window/unable open or continue

Autor Antworten
puppystick Sunday 3 February 2019 at 20:27
puppystickAnonymous

Hello :-)

Thanks for updates to Playonlinux 4; great to have staging versions available, and menus etc look great.

Having this issue, where a really small wine window opens in the top left of screen, and can't be used, only closed with ksysguard:

Using Manjaro KDE, with system wine staging 4 rc5. In this particular instance illustrated, I think I was trying to use a much older version of wine within POL.

Editiert von: puppystick

Quentin PÂRIS Monday 4 February 2019 at 17:46
Quentin PÂRIS
Admin

Hi,

Can the window be resized?

puppystick Monday 4 February 2019 at 17:49
puppystickAnonymous

Hi Quentin :-) No, unfortunately not; it's stuck there until I end the process via ksysguard.

Quentin PÂRIS Monday 4 February 2019 at 20:16
Quentin PÂRIS
Admin

This seems to be a wine problem. Can you open POL in a terminal? I think that libfreetype is missing

puppystick Monday 4 February 2019 at 22:43
puppystickAnonymous

Hi, I've tried running 'playonlinux --gui' and the code below happens, concluding with a Playonlinux box saying 'There is nothing installed to run .--gui files':

 

playonlinux --gui
Looking for python... 3.7.2 - skipped
Looking for python2.7... 2.7.15 - wxversion(s): 3.0-gtk3
21:37:28: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
selected
21:37:28: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
1
[main] Message: PlayOnLinux (4.3.4) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/cat/.PlayOnLinux/
[main] Message: Filesystem is compatible

 

I can't see libfreetype in the Manjaro repo, but there's an ft2tf in the AUR, to generate fbpad tinyfont files using libfreetype ... am not very tech, and not long on Manjaro, but maybe libfreetype is in that package?

 

 

Editiert von: puppystick

Quentin PÂRIS Tuesday 5 February 2019 at 17:03
Quentin PÂRIS
Admin

Just run "playonlinux" and try to reinstall your app

puppystick Tuesday 5 February 2019 at 20:19
puppystickAnonymous

Hi, same result unfortunately; I'm having to close winecfg via ksysguard.

Quentin PÂRIS Wednesday 6 February 2019 at 15:11
Quentin PÂRIS
Admin

Any error appearing on the console?

puppystick Wednesday 6 February 2019 at 20:13
puppystickAnonymous

My apologies. It's reporting this:

 

playonlinux
Looking for python... 3.7.2 - skipped
Looking for python2.7... 2.7.15 - wxversion(s): 3.0-gtk3
19:09:55: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
selected
19:09:55: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
1
[main] Message: PlayOnLinux (4.3.4) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/cat/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[update_check] Message: List is up to date
 

Editiert von: puppystick

Quentin PÂRIS Wednesday 6 February 2019 at 21:14
Quentin PÂRIS
Admin

Even when you run wine?

puppystick Thursday 7 February 2019 at 11:34
puppystickAnonymous

Hi, definitely freetype errors, but Manjaro repo includes and has installed freetype2 (2.9.1-1) and lib32-freetype2 (same). EDIT: just found a post about this issue on the Manjaro forum ... https://forum.manjaro.org/t/issue-with-playonlinux/28578/5 ... not super confident about messing with files, and can't find any libz.so files in the directory.

 

playonlinux
Looking for python... 3.7.2 - skipped
Looking for python2.7... 2.7.15 - wxversion(s): 3.0-gtk3
10:27:57: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
selected
10:27:57: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
1
[main] Message: PlayOnLinux (4.3.4) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/cat/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: Capture...
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[update_check] Message: Web version : 1549530043
[update_check] Message: Current local version : 1549373555
[update_check] Message: Updating list
[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1549530043
[POL_Config_Write] Message: Config write: MANUAL_INSTALL_INCREMENT 12
[POL_SetupWindow_Init] Message: Creating new window for pid 19235
[POL_SetupWindow_menu] Message: menu answer: Install a program in a new virtual drive
[POL_SetupWindow_textbox] Message: textbox answer: pup
[POL_Wine_SelectPrefix] Message: Selecting prefix: pup
[POL_SetupWindow_checkbox_list] Message: checkbox_list answer: Use another version of Wine~Configure Wine~Install some libraries
[POL_SetupWindow_menu] Message: menu answer: 1.5.24
[POL_System_SetArch] Message: POL_ARCH set to x86
[POL_SetupWindow_menu_num] Message: menu_num answer: 0
[POL_System_SetArch] Message: POL_ARCH set to x86
[POL_Wine_PrefixCreate] Message: POL_WINEVERSION is already set to 1.5.24. Using it
[POL_Wine_PrefixCreate] Message: Creating prefix (1.5.24)...
[POL_Wine_PrefixCreate] Message: Using wine 1.5.24
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.5.24, x86
[POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.5.24
[POL_Wine] Message: Running wine-1.5.24 --version (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
which: no wineprefixcreate in (/home/cat/.PlayOnLinux//wine/linux-x86/1.5.24/bin/:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:rundll32:wWinMain Unable to load L"setupapi"
wine: configuration in '/home/cat/.PlayOnLinux//wineprefix/pup' has been updated.
Wine cannot find the ncurses library (libncurses.so.5).
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
/home/cat/.PlayOnLinux/wine/linux-x86/1.5.24/bin/wineserver
[POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name
[POL_Wine] Message: Running wine-1.5.24 cmd /c echo %ProgramFiles% (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
[POL_Wine] Message: Wine return: 0
[POL_Wine] Message: Running wine-1.5.24 winecfg (Working directory : /home/cat/.PlayOnLinux/wineprefix/pup)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org

 

Editiert von: puppystick

Quentin PÂRIS Thursday 7 February 2019 at 15:19
Quentin PÂRIS
Admin

As suspected, freetype is missing (because you are using wine 1.5.x which is too old). Can you try with a recent version of wine?

puppystick Thursday 7 February 2019 at 15:42
puppystickAnonymous

Yes, it works fine with the latest wine, which is great; thanks. :-) It's a little dx7 game, so I'd thought using an older version initially would be best. Some game guides (gamersonlinux) are needing older versions of wine, so is that something planned to be included?

Quentin PÂRIS Thursday 7 February 2019 at 16:19
Quentin PÂRIS
Admin

The guides are outdated :) Older version should no longer be used

puppystick Thursday 7 February 2019 at 16:27
puppystickAnonymous

No problem, and thanks again for all your work on this. The gamersonlinux guides are great too, so maybe some updates are planned, including covering older games. I use solely direct wine, POL/guides and some native games, and have been thrilled to be able to do this since coming to Linux in May 2017. :-)

Quentin PÂRIS Thursday 7 February 2019 at 16:32
Quentin PÂRIS
Admin

The best would be to update the scripts, so that everybody could benefit. It is much quicker than updating a guide IMHO

puppystick Thursday 7 February 2019 at 16:39
puppystickAnonymous

Absolutely; I'd thought a lot of people use the guides, and to be able to manually install even the older games that don't have guides via an updated POL would be wonderful. Thanks that that's an option. :-)

Deleted SPAM