PlayOnLinux fails to launch

Auteur Réponses
Firalus Vendredi 15 Mars 2013 à 14:32

Hello everyone,

I've decided to switch distros to Gentoo recently. Installed everything as it should be, including POL and all the Python-related stuff, for both Python 2.7 and 2.6.

However, I did encounter an issue when it comes down to the usage of POL. When I try to launch it, the UI fails to start and additionally there is another error. I am unsure how does it exactly sound in English, but it more or less says "Unable to reserve proper ports."

The only thing that POL does is trying to update the repos, which also doesn't really seem to work, as it shows something like this (again, it is not exact, as I have to translate it): [code]/usr/share/games/playonlinux/bash/pol_update_list: line 33: echo: write error: Stream interrupted/usr/share/games/playonlinux/bash/pol_update_list: line 45: echo: write error: Stream interrupteddu: cannot access „/home/Firalus/.PlayOnLinux//configurations/icones/The Witcher”: File or folder does not exist[/code]

I tried modifying the .conf file fetched from my Sabayon, but it didn't help. I did also try recompiling PlayOnLinux, with no effect.

I am running 32-bit Gentoo with MATE installed.

Edité par Firalus

petch Vendredi 15 Mars 2013 à 16:12


That's probably this problem?
Firalus Vendredi 15 Mars 2013 à 16:29

I believe this is not the issue - I haven't seen these:
[code]Exception in thread Thread-2:
Traceback (most recent call last):
File "/usr/lib64/python2.7/", line 551, in __bootstrap_inner
File "", line 111, in run
File "", line 82, in real_check
line = p.stdout.readline()
IOError: [Errno 4] Interrupted system call

Exception in thread Thread-3:
Traceback (most recent call last):
File "/usr/lib64/python2.7/", line 551, in __bootstrap_inner
File "/home/poncho/Devel/playonlinux/python/", line 109, in run
self.connection, self.addr = self.acceptor.accept()
File "/usr/lib64/python2.7/", line 202, in accept
sock, addr = self._sock.accept()
error: [Errno 4] Interrupted system call[/code]

It might be caused by the amount of [code]/usr/share/games/playonlinux/bash/pol_update_list: line 33: echo: write[/code]
though, because before I can kill the console, it's history is already completely stuffed with those.

Edit: tried just a moment ago. This time it didn't try to update repos, this time I got:
[code][main] Message: PlayOnLinux (4.1.9) is starting[clean_tmp] Message: Cleaning temp directory[POL_System_CheckFS] Message: Checking filesystem for /home/Firalus/.PlayOnLinux/[main] Message: Filesystem is compatiblepython2: Fatal IO error 11 (Resources temporarily unavailable) on X server :0.0.[/code]

and another startup try with:

[code]python2.6: Fatal IO error 11 (Resources temporarily unavailable) on X server :0.0.[/code]

And again an error with "Unable to reserve proper port" or whatever does it translate to into english.

Possible cause: x11 almost fully built with version 9999?

Edité par Firalus