Forums

The witcher: character invisible

Auteur Réponses
wellsaid Mercredi 19 Février 2014 à 22:35
wellsaidAnonymous

Hi i'm new on the forum,
first of all, sorry my english i'm italian :D
I have a problem whit the witcher game from steam, when i first install this game whit playonlinux evetything goes fine, but after playing a little bit, i have to uninstall gdm and gnome from my os (i'm on arch), when i install slim and xfce i try to play the witcher but all characters in game have some part invisible (watch schreenshot)

http://postimg.org/image/77tmwwqz1/

how can i solve?

Edité par wellsaid

bockscar Jeudi 20 Février 2014 à 23:00
bockscarAnonymous

This bug was fixed in Wine 1.7.13

http://www.winehq.org/announce/1.7.13

Get the latest Wine and try again :)
wellsaid Vendredi 21 Février 2014 à 17:57
wellsaidAnonymous

still have the problem on wine 1.7.3
petch Vendredi 21 Février 2014 à 18:14
petch
Développeur

If you check the bug report, the bug is considered fixed because newer versions of Wine don't require d3dx9_36.dll anymore:
http://bugs.winehq.org/show_bug.cgi?id=34052

So you not only have to upgrade Wine, but also set d3dx9_36 to builtin

By the way for me without d3dx9_36 I get a black screen display, Wine 1.7.13 or not.

Edité par petch

wellsaid Vendredi 21 Février 2014 à 18:47
wellsaidAnonymous

i set d3dx9_36 to builtin in winecfg but still have character model invisible
bockscar Samedi 22 Février 2014 à 1:50
bockscarAnonymous

What graphic drivers are you using? A bug being "fixed" doesn't necessarily mean it has been fixed across all possible driver/graphics card combinations.
petch Samedi 22 Février 2014 à 2:41
petch
Développeur

For information only, on my test laptop,
NVIDIA Corporation C79 [GeForce G102M] (rev b1)  - 512MB
Proprietary nVidia driver 331.38 (Debian experimental packages, the distro is otherwise a Debian Sid)

Edité par petch

wellsaid Samedi 22 Février 2014 à 12:05
wellsaidAnonymous

hi, i have an nvidia geforce 630m and nvidia 331.38 driver and an intel integrated card (i5 cpu). with the nvidia the bug show up (whit both optirun and primusrun), with the intel i have for sure less prestation, but the bug don't show up

Edité par wellsaid

Daerandin Mardi 25 Février 2014 à 6:56
DaerandinAnonymous

This bug certainly seems to be affecting people differently. I could never consistently get this bug, but with my current setup for The Witcher I have not encountered it at all. I use wine version 1.7.9 and GLSL support disabled and offscreen rendering mode set to fbo.

As I said, I have no idea if this removes the bug, I have simply not yet encountered the bug with these settings yet so you may want to give it a try to see if it helps.
Vivienne Mardi 15 September 2015 à 23:51
VivienneAnonymous

I kept experiencing this bug until I installed:  1.7.44-witcher1 version of wine in the configuration section in Playonlinux.  I hope this answer helps somebody.

michaldybczak Samedi 4 Juin 2016 à 18:21
michaldybczakAnonymous

I have wine 1.7.53, invidia GF 108F (GeForce GT 635M) and also have this bug in The Witcher (enchanced edition). Setting d3dx9_36 to builtin or even disabling it does nothing, bug persists. Tried many rendering options and also disabled GLSL and there was no effect either. The only way is to swich to intel gpu to avoid this bug :(.

This bug doesn't seem to be fixed.

piratmartin Vendredi 21 Octobre 2016 à 21:25
piratmartinAnonymous

Fuck! I have same problem! I see only eyeball! WTF? Eyeball fight with swort other eyeballs. Verry great game! I have nvidia, proprietary driver.

adamhm Samedi 22 Octobre 2016 à 3:07
adamhmAnonymous

Try using Wine 1.9.5 (IIRC - might as well use the latest version to be sure) or later & setting the registry key CheckFloatConstants to enabled ([url=https://wiki.winehq.org/Useful_Registry_Keys]WineHQ Wiki: Useful Registry Keys[/url])

Edité par adamhm

piratmartin Mardi 25 Octobre 2016 à 12:48
piratmartinAnonymous

adamhm: i test this with registry. Not help for me. Only once. Then i repeat run game, and eyes ball is back.